Exclude directories from the search

  • Добрый день.
    Ищу вхождение слова в текстовых файлах. Поиск идет в директории с поддиректориями.
    Подскажите пожалуйста, как исключить некоторые поддиректории из поиска ?

    edit from moderator: (translated from g.translator) :

    Good afternoon.
    I am entering words in text files. Search is in a directory with subdirectories.
    Please tell me how to exclude certain subdirectories from the search?

  • Hello, Alexandr Stepanov

    I, first, translated your Russian text in English, with Google !

    AFAIK, in the Find in Files dialog of N++ ( CTRL + SHIFT + F ), you can add several filters as, for instance, *.xml *.txt

    But, unfortunately, you can’t write several paths in the directory field nor exclude some paths from search.

    I’m agree with you : it could be a nice improvement, in future releases.

    For instance, the text C:\_683\ C:\_681\ C:\_679 | C:\_681\localization, in Directory field, would search :

    • In the C:\_683\ folder, and its sub-directories, due to the last backslash

    • In the C:\_681\ folder, and its sub-directories, due to the last backslash, and except for the C:\_681\localization folder, written after the vertical line character |

    • In the C:\_679 folder, ONLY, because NO backslash ends the path

    Of course, if the In all sub-folders option was UNCHECKED, it would have priority, to the syntaxes above.

    Right now, it’s still a dream :-((



  • +1 Having an exclude files AND exclude directories feature would be a great addition! For me it would work best if they worked similar to the “Filters:” box for files. That is, they would allow multiple entries with wildcards.

    Being able to exclude file types is useful when you want to use *.* to search all types of files that you care about without having to specify each and every one.

  • +1

    It would be great to have this feature. Many times I was forced to use Total Commander search instead.

  • I’ve manually set my project’s .meteor folder to hidden so it will only be included when “In hidden folders” is checked.

  • Hello Cees,

    Very clever solution, Indeed ! Thanks for sharing it :-) I haven’t thought of that simple and useful work-around, yet !

    Best Regards,


Log in to reply