Network drives

  • Hi! I’ve just updated to 7.4.2 and since then I can not save to network drives. Light Explorer or Explorer should solve this, but not this time. Any suggestions? Thanks

  • @György-Bugán , I’ve been on 7.4.2 for well over a month now, and I save to network drives all the time. Is it possible it’s an interaction between Notepad++ and your local network, or perhaps something coincidental happened on your network when you upgraded? Have you tried reverting to an older version, preferably the one you were on previously?

  • Tried to downgrade. Now running 6.9.2, without network drives. After starting npp I can open files from network drives, when saving npp ask to switch to administrator mode and network drives disappear. If I start Npp as administrator I can’t browse network drives at all. Thanks for your help.

  • Are you using Linux based servers over SAMBA?
    Notepad++ uses file API which causes files over SAMBA to be re-created instead of modified.
    As a result they are reassigned with new permission set according to SAMBA defaults for the user or the share. Often the new permissions will not allow addtional update on the next write.

    You can see this patch I created for myself long ago. Specifically note the comment:

    /* Use open/close API instead of fopen/fclose so when updating existing
     * files over SAMBA they will not be treated as new and retain their current 
     * access mode */

    If this is your problem then you may workaround it by modifying samba configuration so new files will get usable permissions.

  • Mapped Network drives only exist in your user’s default context. When you start an Application with “Run as Administrator” it runs in a different context and thus doesn’t see your mappings.

    Either use UNC Pathes (like \\yourserver\yourshare) or re-map your drives from a command window running as administrator (command: net use x: \\yourserver\yourshare)

Log in to reply