XML files opened as Session file



  • I’m trying to open XML files with Notepad++ (from the files selector or by drag & drop) but I get the message box: ‘Could not Load Session. Session file is either corrupted or not valid’. Anyone has an idea about this issue?



  • @Jean-michel

    not 100% sure about your file handling but at first glance it sounds like you are running explorer.exe and notepad++.exe with different
    elevation levels, could this be?

    If so, just start notepad++ with the same privileges as explorer.exe, if this isn’t the case may I ask you to clarify what exactly you do.
    Please try to explain it as specific as possible.

    Eko



  • Notepad++.exe (x86) is launched as administrator. It seems that this issue appeared since the 7.5.8 version. It’s like all XML files were considered as session files. I did not make any changes about files handling.



  • @Jean-michel

    once it was reported that if you update notepad it might be possible that the shortcut gets created to start npp as administrator.
    Can you just delete the shortcut and create a new one to see if this is your problem?

    Eko



  • Notepad++ was installed manually and the “Run as Administrator” for the shortcut is set. The issue is the same if I launch Npp from the shortcut or the executable.



  • @Jean-michel

    sorry, but with the given information I don’t see what the problem might be.
    Maybe someone else has some other ideas, or maybe you can describe in more detail
    what you are doing so that one can try to do the same steps as you did to see what is going on.
    In addition it might be useful if you post the debug info which is available under the “question mark” menu.

    Eko



  • @Eko-palypse

    Thank you to investigated about this issue.



  • Hello, @jean-michel, Eko-palypse, and All,

    Just to verify : which extension is indicated in Settings > Preferences > MISC, in the Session file ext. zone ?

    Presently, I don’t need to manage several sessions, but I remember, that, some time ago, testing the N++ sessions feature, I, generally, chose the .ses extension for session files, without any interference with all .xml files ;-))

    Hope this helps !

    Best Regards,

    guy038



  • @guy038 Thank you Guy. It’s OK now, but if you use the workspace, you need also to change extension for workspace files.


Log in to reply