Notepad++ 6.8.6 released



  • @Richard-Payne said:

    @David-Bailey The dialog that you dismissed gives an option to create a dump file. I am not aware of any other way, but maybe the Devs can clarify that?

    Thanks - I guessed as much, but I can’t reproduce the problem! Whatever the problem is, it obviously does not happen frequently, because I use NPP a great deal.



  • @pnedev @Серж-Сергей

    Could you try this binary then confirm me it’s fixed the issues you reported ?

    http://dl.free.fr/vSurTyhnX

    notepad++.exe



  • Hi.
    I found out 1 bug. In version 6.8.6
    Autocomplete single and double quotes is not working … worcked only at start of line



  • I tried to replace every occurrence of the following regular expression by the empty string:

    [[:xdigit:]]+(#[[:xdigit:]]+,[[:xdigit:]]+):

    This worked if I made the changes one at a time, but crashed if I did a replace all. The crash message box didn’t offer to create a crash dump file.

    Here is a typical string that I was trying to remove:

    0000013b(#209415,000154b1):

    This is not related to the other crash I mentioned previously.

    David



  • Hello,

    I have noticed that the auto append of file extension based on the language chosen in the editor is not working while saving the new document. It’s not working even if I choose the extension in the Save as type option. The only way I could make it work is by appending the extension to the File Name. This was working till version 6.8.3 as someone has already mentioned above.
    e.g. Steps to reproduce the same

    1. Open the new document editor and type some text.
    2. Choose the Language as HTML.
    3. Now try to save the document with or without choosing the Save as type option.
    4. It will be saved without any extension.

    Please fix it asap as it’s very inconvenient to type the extension along with the file name.



  • Using:

    Windows 7 Ultimate x64
    Notepad++ v6.8.6 Build time : Oct 29 2015 - 01:13:57
    Plugins: Converter 3.0, MIME Tools 1.9, NppExport 0.2.8, NppFTP 0.26.3, Plugin Manager 1.3.5 all with Stability = Good.

    Since I upgraded to Notepad++ v6.8.6 the option

    “Minimize to system tray” in Settings > Preferences > MISC.

    does not work anymore. The Notepad++ window remains in the taskbar and does not minimize to the system tray.

    Thank You for looking into this.



  • @Gylgamesh-OfUruk Due to Windows Administrator mode limit, this feature works only in non-admin mode.



  • Highlighting is working fine when there is no spaces near searched word like: $test=1; and no highlighting when spaces are present: $test = 1;



  • NPPFTP plugin taking time to open some files sometimes .



  • @donho
    Minimize to system tray worked in Windows Administrator Mode in all the previous Notepad++ versions.



  • Hello,

    If I want to close <form> in php, it prints EVERYTHING after the closing sign. I mean this one: >. Can you fix it for me, please? I don’t do something wrong, haha. I watched videos on YouTube, and they do it the same way, but they have an older NotePad++ and it works on that version. I am not English, so I hope I wrote it well. Thank you!



  • Hello there!

    I’ve updated today via the auto updater and encountered a bug, which doesn’t occur in 6.8.3 (hence I’ve downdated to that version).

    I have the following settings according to the tab style:
    default = 2 characters, replace tabs by spaces
    javascript = don’t use default, instead use 4 characters and don’t replace the tab

    After 6.8.3 (I don’t have tested which version introduced the bug) the javascript-specific tab style setting is ignored(!)
    Instead always the default setting is used. Other languages seem not to be affected. This bug is nasty, because I must use different indent style according to the programming language (xml, javascript, C/C++ = 4 character tabs, else = 2 character spaces).

    It whould be nice if you could fix this bug.

    Kind Regards
    David Gausmann



  • @David Gausmann
    I did a fix here:
    https://notepad-plus-plus.org/temp/npp.zip

    Could you confirm me the bug is fixed for you?

    Thanks



  • Hello!

    I am using Notepad++ on Win10 Home 64bit. When I use virtual desktops, N++ does not allow me to switch to another desktop (via Win+Ctrl+Left/Right key combo). I have to do it twice to switch and NP++ comes in front on the main desktop, if i.e Firefoy was previous app on top.

    Also shadow of Document map is visible on other desktops.

    Kind regards,
    Ales



  • @donho Sorry for my late response, but I forgot to answer over the weekend. :D
    I’ve tested your fix and the bug is now semi-fixed:
    After replacing the Notepad++.exe I’ve started Notepad++ and the bug was still present for Java script files. Then I went into to settings dialog and modified the value for the Java script tab width. After modifying this value everything was fine. This behaviour changed in comparison to the unpatched Notepad++.exe where the tab width keeps wrong after modification in the dialog, so your fix worked at this place.
    Unfortunately your fix is not used in a recently started Notepad++. You must go into that dialog and change the setting first, otherwise your fix doesn’t work.

    So there should be one place more to fix.

    Kind Regards
    David Gausmann


Log in to reply