Notepad++ v6.9.1 is out there

  • I have confirmed that this problem has something to do with a plugin (sorry)! I will get back to this issue and determine which plugin, but unfortunately right now I am rather overloaded with other things!


  • It’s a problem for me that i dont know how to fix it.

    when i type 5 or 3 it types =

    when i type 8 it types ~

    when i type 6 it types D

    please help

  • Hello @Aivaras-Bitvinskas,

    could it be that you accidentally hit the key sequence which changes keyboard layout?
    Check Control Panel->Region and Languages->Keyboards and Languages->Change Keyboards->Advanced Key Settings
    Is there a hotkey specified? If so, press it and see if problem is solved.


  • Notepad++ v6.9.1
    Build time : Mar 28 2016 - 19:48:40
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 7
    Plugins : PluginManager.dll

    I am trying to use the “Find In” feature of Notepad++ as I have in the past and receive no response from the search in the separate window as I am used to. Using the “F7” key does not restore the window, and I have disabled all plug-ins. What else prevents this feature from working?
    Thank You,

  • Hello @Paul-Robertson,

    so you are saying you used Find in Files (CTRL+SHIFT+F) dialog and result window doesn’t show up, correct?
    Did you open the dialog via the menu or by using one of the shortcuts and selecting the appropriate tab?

    F7 is used for toggling between result window and editor. This only works if search result window was once created.
    So question is, why don’t you get the result window, isn’t?


  • I have the same problem:
    when I download the file using NppFTP, the encoding has changed from UTF-8 to ANSI, and the EOF also change from “UNIX” (default in my Npp configuration), to “Dos/Windows”.

  • Claudia,
    I have tried both using the pull down menu and the shortcut sequence. Neither has an effect. A search for multiple instances in a file also does not result in the window opening at the bottom as I expect. It appears the result window is never created.
    R/ Paul

  • @Claudia-Frank
    I have found a “solution” in another site which addressed this same issue. It mentioned the config.xml file in the \user"account"\Appdata\roaming\notepad++ folder as being the culprit. I renamed this file, restarted the application and the behavior went back to normal.

  • Any chance of bringing back the online documentation? All links appear dead.

  • Hello @Paul-Robertson,

    good to see that you found the cause of your issue.
    By any chance, can you compare the “renamed” config.xml with the new one created,
    to see what the differences are?

    It happened already a couple of times where unexpected behavior was solved by deleting/renaming
    %APPDATA% directory or config files. So I’m curious to see what could have caused it.

    Thank you and cheers

  • @Claudia-Frank
    I can provide a beyond-compare output file if you tell me how to deliver it to you.

  • @Paul-Robertson

    If you don’t mind you could upload it to and post the link here.
    It stays there for at most 24 hours and then gets deleted automatically.


  • Hello,

    While closing Notepad++ I’m now forced to close/save/discard one of many unsaved files (like for example new 5).

    I used to be able to close Notepad++ and leave unsaved files and restore everything back as I left them when I closed the app!

    This feels to be a bug because Notepad++ is forcing only one of the unsaved files to be closed/saved/discarded.

  • Hello @Roger-Tannous,
    looks like automatic backup is disabled.

    Please check the following

    check remember current session for next launch
    check enable session snapshot and periodic backup


  • @Claudia-Frank

    I had version 6.9, so the complaint concerns that version. Yes, I have those check boxes checked, but it doesn’t matter, I just updated to 6.9.1 and till now, there’s no problem.

  • Very very happy to see Fortran free format support.
    However, the changelog writes “FORTRAN 77", which is actually fixed format. It should be “Fortran 90” (not all CAPS) or newer.

  • More on Fortran:
    the old fixed-form FORTRAN highlight is now broken. All Fortran source files are now highlighted in free format style.

  • So sorry… old fixed form FORTRAN highlighting was not working for me because my cloud settings folder was not updated. The configuration files in the install folder are correctly setup. Once I copied these files, fixed-form FORTRAN highlighting works properly.

    About default extensions:
    by most common convention, “.f” is used for fixed-form FORTRAN, not free format.

  • I continue to obtain this problems… if i use FTP access and download some file for edit (like a txt file or xml) from a server if this same files it’s changed on server i don’t obtain the ask for reload and if i reload manually i don’t see the modification.
    For obtain i need to re-download the file… this functions it’s very usefull when you stay to read, for example, a log file from a server… if you want to read you need every time to redownload the file.

    I have also tryed to use Filezilla or use the FTP plugins of notepad++… please fix.

  • Hello @David-Rocco,

    ftp protocol doesn’t provide any “file has changed functionality”
    If the file has been changed on the server you won’t get any information,
    if you would like to have such functionality you need to use something like samba.
    (assuming the server is a unix host)
    Basically, you need to mount the share to your filesystem so that the filesystem
    gets a chance to detect file changes.


Log in to reply