Notepad++ v6.9.1 is out there

  • v6.9.1 comes with enhancement & bug-fixes of Folder as Workspace feature, plus some minor enhancements & bug-fixes :


  • Unfortunately there seems to be a problem with searching in this version. I have a file containing the string:


    If I search for amd_ it doesn’t succeed, whereas if I search for amd it does succeed. I have, of course reverted to the release candidate version which didn’t have this fault.


  • @David-Bailey The search works fine for me. Make sure you have the correct find options set. (wrap around, search mode, direction, etc). If you are still having issues can you provide more info?

  • I’m having the two proposals while working with FaW

    1 - Add multi-selection files to Folder as Workspace
    2- Open all files (from this directory) when you right-click on the root folder.

  • Dail,

    Here is a small cutdown that still doesn’t search properly:
    label *get_label(char *&bp, int getting);
    long asm_parse_integer_token(char *&);

    static int64 amd_asm_constant;
    logical permit_arbitrary_constants = false;
    static constant_entity* the_constant;
    static char* ThisToken;

    For many versions now I have downloaded the ZIP file and ‘installed’ the new version by overwriting the old exe file. I am wondering if this has caused a problem in this particular case.

    All the search are the default ones - only the “Wrap around” checkbox is ticked, the search mode is normal, and the search direction is Down. I am running on 64-bit W10, and have used NPP for many years.


  • Still works fine for me. I’d try a fresh “install” of it and without plugins.

  • Hello David,

    As dail, the search, in normal mode, of the string amd_asm_constant, in your example text, works just fine, on my local install of N++ v6.9.1, in the folder C:\_691, from the archive npp.6.9.1.bin.7z ?!



  • I have confirmed that this problem has something to do with a plugin (sorry)! I will get back to this issue and determine which plugin, but unfortunately right now I am rather overloaded with other things!


  • It’s a problem for me that i dont know how to fix it.

    when i type 5 or 3 it types =

    when i type 8 it types ~

    when i type 6 it types D

    please help

  • Hello @Aivaras-Bitvinskas,

    could it be that you accidentally hit the key sequence which changes keyboard layout?
    Check Control Panel->Region and Languages->Keyboards and Languages->Change Keyboards->Advanced Key Settings
    Is there a hotkey specified? If so, press it and see if problem is solved.


  • Notepad++ v6.9.1
    Build time : Mar 28 2016 - 19:48:40
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 7
    Plugins : PluginManager.dll

    I am trying to use the “Find In” feature of Notepad++ as I have in the past and receive no response from the search in the separate window as I am used to. Using the “F7” key does not restore the window, and I have disabled all plug-ins. What else prevents this feature from working?
    Thank You,

  • Hello @Paul-Robertson,

    so you are saying you used Find in Files (CTRL+SHIFT+F) dialog and result window doesn’t show up, correct?
    Did you open the dialog via the menu or by using one of the shortcuts and selecting the appropriate tab?

    F7 is used for toggling between result window and editor. This only works if search result window was once created.
    So question is, why don’t you get the result window, isn’t?


  • I have the same problem:
    when I download the file using NppFTP, the encoding has changed from UTF-8 to ANSI, and the EOF also change from “UNIX” (default in my Npp configuration), to “Dos/Windows”.

  • Claudia,
    I have tried both using the pull down menu and the shortcut sequence. Neither has an effect. A search for multiple instances in a file also does not result in the window opening at the bottom as I expect. It appears the result window is never created.
    R/ Paul

  • @Claudia-Frank
    I have found a “solution” in another site which addressed this same issue. It mentioned the config.xml file in the \user"account"\Appdata\roaming\notepad++ folder as being the culprit. I renamed this file, restarted the application and the behavior went back to normal.

  • Any chance of bringing back the online documentation? All links appear dead.

  • Hello @Paul-Robertson,

    good to see that you found the cause of your issue.
    By any chance, can you compare the “renamed” config.xml with the new one created,
    to see what the differences are?

    It happened already a couple of times where unexpected behavior was solved by deleting/renaming
    %APPDATA% directory or config files. So I’m curious to see what could have caused it.

    Thank you and cheers

  • @Claudia-Frank
    I can provide a beyond-compare output file if you tell me how to deliver it to you.

  • @Paul-Robertson

    If you don’t mind you could upload it to and post the link here.
    It stays there for at most 24 hours and then gets deleted automatically.


  • Hello,

    While closing Notepad++ I’m now forced to close/save/discard one of many unsaved files (like for example new 5).

    I used to be able to close Notepad++ and leave unsaved files and restore everything back as I left them when I closed the app!

    This feels to be a bug because Notepad++ is forcing only one of the unsaved files to be closed/saved/discarded.

Log in to reply