Find in Files not working



  • Sometimes in the last few releases, Find in Files quit working for me. It tries the search,. I see the progress bar, but it never finds any matches, even though there are a lot of them - which I can verify with another editor.
    What am I missing?

    Details:
    Simple character string search, Normal mode, no options set.
    Current version 6.9.1, but it’s been this way over the last few versions.

    Thanks.



  • Hello,

    do you use the Filter “*.*”?

    Are File-System-Rights given?

    KR, Robert



  • I’ve tried several filters, no difference:
    .
    *.cgi
    *.sql

    File system permissions seem OK, no changes, and other editors can search with no problems.



  • Hello @George-Marshall,

    do you do local searches or via network?
    Can you give us an example what you are searching and
    in which directory? Could it be that this is an file system redirection issue?

    Cheers
    Claudia



  • No find-in-file searches have worked for the last few versions, with a file and directory structure unchanged on the local disk in Win 7. This is a feature I use quite often. Unfortunately, I did not notice which version broke at the time.

    Example seach:
    find a simple word, let’s say ‘order’ (no quotes) in a folder with several SQL scripts.
    Find what: order
    Replace with: <blank>
    Filters: .
    Directory: d:\Temp
    No match options set
    Search mode normal

    It does the scan - I can tell by the file names flying by that it is in the right folder.
    Result: zero files.

    In contrast, I bring up another text editor (Crimson Editor, if it matters) that has find-in-files ability, and it finds all the expected matches.



  • Can you show us the debug info? (available under ? menu)

    Cheers
    Claudia



  • Certainly. Here it is.
    For the 6.9.1 install, I took all defaults.

    Notepad++ v6.9.1
    Build time : Mar 28 2016 - 19:48:40
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : ON
    Local Conf mode : OFF
    OS : Windows 7
    Plugins : mimeTools.dll NppConverter.dll NppExport.dll NppFTP.dll PluginManager.dll SpellChecker.dll



  • Coud you give it a try to download a zipped npp?
    https://notepad-plus-plus.org/repository/6.x/6.9.1/npp.6.9.1.bin.7z

    Extract it where you want and do the same search which isn’t working.

    If this works, give it a try to rename the notepad++ directory under %APPDATA% directory
    and give it another try with the installed version of npp.

    Cheers
    Claudia



  • I tried the zipped version, no difference.
    But, inspired by that I dea, I completely uninstalled the application using control panel, and re-installed 6.9.1 using the normal installer file.

    Works great, so perhaps something in my registry got hosed.

    Thanks for all the suggestion.



  • Thanks George, the re-installation option worked for me too! Now if they could fix the memory-leak (or similar) when you scroll too fast this would be brilliant!



  • Yes, uninstall and reinstall worked for me too. It’s pretty fast.



  • no need to uninstall and then reinstall
    Find in files tab , check/select In all sub-folders



  • While @hugh-jackman 's suggestion is also good advice for common PEBCAK sufferers, in this case I had the same problem and that did not work for me.

    Fortunately, thanks to some sneaky comparison with WinMerge.exe I found the cause:

    In ~/Appdata/Roaming/Notepad++/config.xml

    <GUIConfig name=“DockingManager” leftWidth=“200” rightWidth=“200” topHeight=“200” bottomHeight=“0”>

    Change the bottomHeight value from 0 to 200 and you’ll get the file search results back :-)

    P.S would like to see a future collab between Notepad++ & WinMerge…

    FYI There’s also a typo in the config file
    useCustumDir=“no”

    Notepad++ v7.6.3 (64-bit)
    Build time : Jan 27 2019 - 17:16:47
    Path : C:\Program Files\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : DSpellCheck.dll mimeTools.dll NppConverter.dll



  • @pinchies,

    There is a plugin for Notepad++ called the Compare plugin (v2.0.0 is available thru the Plugins > Plugins Admin interface in your Notepad++ v7.6.3). Not having used WinMerge, I don’t know the ins-and-outs of WinMerge’s feature set; however, the Compare plugin will highlight differences, allow you to jump between them, and you can easily copy data from one to the other, so it has a lot of similar features to other comparison tools, like gvimdiff, TortoiseSVN’s Diff, and presumably WinMerge. If you want file-comparison features inside the Notepad++ environment, that’s what I’d recommend.



  • I get the same behaviour, last two weeks



  • @Bob-Boisvert said:

    I get the same behaviour, last two weeks

    I assume you mean the same behavior as that described 3 years ago: am I right? If so, what version are you using? Are you using the ancient version mentioned then? Or a more recent? You can use the ? menu, Debug Info > Copy debug info into clipboard and paste it in your reply.

    Are your actual symptoms identical to those described 3 years ago, or just vaguely similar? Please describe exactly what goes wrong with you, in a way that we can try to replicate.

    Did you try the steps mentioned above (ie, uninstall and reinstall)? Did it work for you? If not, what else have you tried?

    TL;DR:

    If you want help, you need to give more information. The things I asked above will help us help you, otherwise the best answer we can give is “you’re likely doing something wrong, because it works for us.”



  • @Bob-Boisvert said:

    same behaviour, last two weeks

    If you haven’t switched N++ versions in this time period, or maybe even if you have, I have wagering money that you have one of the find option checkboxes checked that you never had before you began having trouble.

    But an EIGHT word description of your problem isn’t going to get you much.


Log in to reply