Notepad++ v6.9.2 released



  • Log Monitoring is one of most wanted features. It is in v6.9.2 now.
    As indicated its name, Log Monitoring allows users to monitor log files’ writting, update by scrolling to the last line while every modification, just like Unix command tail -f.
    Click on “eye icon” on toolbar or use menu “View->Monitoring (tail -f)” to activate/disactivate this command.

    You may need to search in finder (find in files result) in order to narrow down search result. You can do it in v6.9.2.
    Launch “Find in this finder…” command via context menu of Find result panel (right click on Find result panel), a Find in Finder dialog will be display for searching in found result, and put the result in another finder result panel. You can repeat this action from the new finder result panel until you find what you want.

    This release include some bug-fixes as well. Please check Notepad++ v6.9.2 download page for more information about this version:
    https://notepad-plus-plus.org/download/v6.9.2.html

    Auto-updater will be triggered in few days if there’s no critical issue found.



  • Whenever I run HTML on chrome (in notepad++ v6.9.2) it shows the new features and bug-fixes instead of what is supposed to appear on the screen… is there any way to fix this?



  • I am experiencing a bug when using mouse buttons to copy and/or paste, but not when using copy/paste commands (ctrl-c or ctrl-v). The bug manifests when right clicking the mouse to effect either a copy or paste under N++ and then the N++ window instantly collapses to just the min/max/exit icons and shifts to the upper left corner of the screen. I can drag it and resize it back to its size and position prior to clicking the mouse button.

    I have used two different mice, but both configured for 1600dpi, and my monitors are twin Viewsonic VP2770 (each 2560x1440) driven by an Nvidia Quadro 600.

    I first began using NPP with 6.8.2 and the bug was present then and thru 6.9.2 so it seems an old bug.

    I’m a first-time commenter here, and I saw no way to post my “bug report” except as a reply to donho. Let me know what I’m doing wrong, and ask for any additional symptom/config info.

    Charles Davis



  • Some additional info on that bug:
    The two physical monitors are configured by Nvidia into a single 5120x1440 logical display.

    Even when Notepad++ is positioned on the right display, when its window collapses it jumps to the upper left corner of the display (reasonable in view of the single large logical display)

    Even when the resolution on the mouse is configured to 800dpi, the bug still happens.

    I’m running Windows 7 64-bit Pro (nearly current on maintenance) on a Dell Precision T1600 with 8 x 3.3GHz cores.



  • I’m really sorry to bother you, but could you explain, how does Log monitoring work?

    I’ve created a text file, opened it in n++, then opened it in MS Notepad and started populating file with some data. Nothing happens in n++. Every time I click on n++ window to focus it, it only says “The file has been modified by another program. Reload?”
    I press “OK”, file reloads and nothing happens as well, I have to manually scroll down to the bottom to view new lines.

    What am I doing wrong?



  • @Kondra007
    Did you activate monitoring on the file you modify outside?



  • I like Notepad++ usually but the Log Monitoring feature is really not doing it well.

    1. File is not updating as frequently as it should.
    2. It is not taking me to the last line of the file as soon as I start the log monitoring.
      Please have a look at ‘baretail for windows’ software. Log monitoring works very well there.


  • Still very disappointing. I get a refresh only when I click the “ReloadFile” button.
    File Status Auto-Detection…

    • Enable [checked]
    • Update silently [checked]
    • Scroll to the last line after update [checked]

    Also, I uninstalled “Document Monitor” thinking it might be incompatible and I am still stuck with my problem. No refresh at all



  • Auto-update installed this version today. Can’t “double click to open” files from Windows Explorer (7 Pro Build 7601: SP1). Notepad++ window is brought to the front, but the file is not opened. “Copy Address” from Windows Explorer and File-Open in Notepad++ work fine, the file opens.



  • @Duane-Dieterich OOPS! Everything is working fine now. Not sure what changed. All is good.



  • Log Monitoring is a great feature, but it seems the refresh rate is really slow (once per minute?).
    Is it possible to adjust it somehow?



  • Hello Don and Contributors,

    I’m quite late, for giving my impressions about this new 6.9.2 version ! Many thanks for the two main added features :

    • The file’s Monitoring

    • The Find in Finder feature

    I would like to add two comments, which may be useful, anyway !


    1) Concerning the Monitoring feature :

    Let’s suppose that the buffer of the current monitored file is rewritten, every n seconds, on disk, by your operating system.

    Then, as the N++ monitoring frequency seems to be 1Hz, about, if n >> 1, you may think that the monitoring feature does NOT work properly, as the display of the last lines doesn’t seem to change or very rarely !

    But if n << 1, you should see the displaying, of the monitored file, updated, nicely, any every second, about !


    2) Concerning the Find in this finder feature :

    When you right-click on the context menu, of a Find result panel, and choose the option Find in this finder…, the next searches will be performed on all the files, described in that currentFind result” panel, whatever files are opened in main N++ window, ( even none, if previously closed ) !

    Therefore, with the Find in Finder new feature, you have the possibility of searching in a small subset of files, whereas the command Find All in All Opened Documents would search for all the opened files :-)

    However, to do so, you’ll have to UNCHECK the Search only in found lines option, of the Find in finder dialog, in order to search throughout all the contents of these files !

    Best Regards,

    guy038



  • File associations does not save changes on W10 x64



  • @Aitor-González

    can you give us a bit more detailed information what you do and what you expect that should be done?

    Cheers
    Claudia



  • Please spell check the release notes. :)

    Notepad++ v6.9.2 new features and bug-fixes:

    1. Add most wanted feature: Log Mornitoring (tail -f).


  • @Charles-Davis I am also suffering the same symptoms as you, since upgrading to v6.9.2.
    I am also using NVidia Quadro cards on a multi-CPU Xeon machine (of unknown vintage but at least three or four years old) running 64-bit Windows 7 Professional.



  • @Ralph-Clark

    Long time ago, we’ve experienced issues like the one you reported when using nvidias nview manager software.
    Once this was uninstalled and computer rebooted everything worked as expected.
    Curious if this software is still the cause of the problem.

    Cheers
    Claudia



  • @Claudia-Frank
    re the nView Notepad++ mouse copy/paste conflict…

    I will both update to the latest nView drivers, and if need be, uninstall nView as an experiment.

    I would note for the record, I have run with nView for 5+ years now, and Notepad++ is the only product that exhibits the problem. I have, literally, dozens of 3rd party products that work correctly with mouse copy/paste, except for Notepad++.

    That suggests, does it not, a bug in Notepad++???



  • I’m unable to open any network files, including those files from mapped drives.
    I double click on them, and nothing happens.
    I drag them over N++, and i get the “NOT ALLOWED” (red crossed out circle ) mouse icon.

    When I go FILE - NEW, the OPEN FILE dialog doesn’t show any network mapped drives either… It does show the THIS PC, and NETWORK items thogh.



  • @Charles-Davis

    we discovered this while using in-house devleoped java applications. Later we
    recognized that npp and other c++ application were affected to but as said, this was
    long time ago. It might be that nvidia can’t be blamed anymore, I don’t know.
    That’s why I wrote I’m curious - I hoped that @Ralph-Clark would answer if this
    could be solved by uninstalling the nvidia software.

    Cheers
    Claudia


Log in to reply