Notepad++ v6.9.2 released

  • I like Notepad++ usually but the Log Monitoring feature is really not doing it well.

    1. File is not updating as frequently as it should.
    2. It is not taking me to the last line of the file as soon as I start the log monitoring.
      Please have a look at ‘baretail for windows’ software. Log monitoring works very well there.

  • Still very disappointing. I get a refresh only when I click the “ReloadFile” button.
    File Status Auto-Detection…

    • Enable [checked]
    • Update silently [checked]
    • Scroll to the last line after update [checked]

    Also, I uninstalled “Document Monitor” thinking it might be incompatible and I am still stuck with my problem. No refresh at all

  • Auto-update installed this version today. Can’t “double click to open” files from Windows Explorer (7 Pro Build 7601: SP1). Notepad++ window is brought to the front, but the file is not opened. “Copy Address” from Windows Explorer and File-Open in Notepad++ work fine, the file opens.

  • @Duane-Dieterich OOPS! Everything is working fine now. Not sure what changed. All is good.

  • Log Monitoring is a great feature, but it seems the refresh rate is really slow (once per minute?).
    Is it possible to adjust it somehow?

  • Hello Don and Contributors,

    I’m quite late, for giving my impressions about this new 6.9.2 version ! Many thanks for the two main added features :

    • The file’s Monitoring

    • The Find in Finder feature

    I would like to add two comments, which may be useful, anyway !

    1) Concerning the Monitoring feature :

    Let’s suppose that the buffer of the current monitored file is rewritten, every n seconds, on disk, by your operating system.

    Then, as the N++ monitoring frequency seems to be 1Hz, about, if n >> 1, you may think that the monitoring feature does NOT work properly, as the display of the last lines doesn’t seem to change or very rarely !

    But if n << 1, you should see the displaying, of the monitored file, updated, nicely, any every second, about !

    2) Concerning the Find in this finder feature :

    When you right-click on the context menu, of a Find result panel, and choose the option Find in this finder…, the next searches will be performed on all the files, described in that currentFind result” panel, whatever files are opened in main N++ window, ( even none, if previously closed ) !

    Therefore, with the Find in Finder new feature, you have the possibility of searching in a small subset of files, whereas the command Find All in All Opened Documents would search for all the opened files :-)

    However, to do so, you’ll have to UNCHECK the Search only in found lines option, of the Find in finder dialog, in order to search throughout all the contents of these files !

    Best Regards,


  • File associations does not save changes on W10 x64

  • @Aitor-González

    can you give us a bit more detailed information what you do and what you expect that should be done?


  • Please spell check the release notes. :)

    Notepad++ v6.9.2 new features and bug-fixes:

    1. Add most wanted feature: Log Mornitoring (tail -f).

  • @Charles-Davis I am also suffering the same symptoms as you, since upgrading to v6.9.2.
    I am also using NVidia Quadro cards on a multi-CPU Xeon machine (of unknown vintage but at least three or four years old) running 64-bit Windows 7 Professional.

  • @Ralph-Clark

    Long time ago, we’ve experienced issues like the one you reported when using nvidias nview manager software.
    Once this was uninstalled and computer rebooted everything worked as expected.
    Curious if this software is still the cause of the problem.


  • @Claudia-Frank
    re the nView Notepad++ mouse copy/paste conflict…

    I will both update to the latest nView drivers, and if need be, uninstall nView as an experiment.

    I would note for the record, I have run with nView for 5+ years now, and Notepad++ is the only product that exhibits the problem. I have, literally, dozens of 3rd party products that work correctly with mouse copy/paste, except for Notepad++.

    That suggests, does it not, a bug in Notepad++???

  • I’m unable to open any network files, including those files from mapped drives.
    I double click on them, and nothing happens.
    I drag them over N++, and i get the “NOT ALLOWED” (red crossed out circle ) mouse icon.

    When I go FILE - NEW, the OPEN FILE dialog doesn’t show any network mapped drives either… It does show the THIS PC, and NETWORK items thogh.

  • @Charles-Davis

    we discovered this while using in-house devleoped java applications. Later we
    recognized that npp and other c++ application were affected to but as said, this was
    long time ago. It might be that nvidia can’t be blamed anymore, I don’t know.
    That’s why I wrote I’m curious - I hoped that @Ralph-Clark would answer if this
    could be solved by uninstalling the nvidia software.


  • @Grant-Molloy

    It sounds like there is a permission issue - you need to take care that the files you wan’t to open
    and notepad++ are on the same elevation level.
    Catchword would be, run npp as administrator or mapped directory uses different credentials.


  • @Claudia-Frank
    re the nView Notepad++ mouse copy/paste conflict…

    Well, I am still running N++ 6.9.2 and I have upgraded my NVIDIA drivers to 368.39 (in which nView is 147.00) and the problem has gone away. It seems nView was the issue, though why only N++ was affected (for me) remains a mystery.

    In looking back at my maint history, my 1st install of N++ (6.8.2) was on Sep 2, 2015 at which time my nView version was 146.22 (from NVIDIA driver release package 348.07), so perhaps nView 146.22 (or earlier) re-introduced the bug you saw long ago, and in the interim it was reported to NVIDIA and they fixed it.

    Bottom line, there are no problems with N++ 6.8.2 and nView 147.00.

    Thank you for your suggestion. I wouldn’t have updated my NVIDIA drivers as soon, had you not suggested the connection.

    I would encourage Ralph Clark to likewise upgrade to NVIDIA 368.39 and see if that resolves the problem for him as well.

  • @Charles-Davis
    correction above: older nView version “146.22” should be “146.33”

  • @Charles-Davis

    though why only N++ was affected (for me) remains a mystery.


    It may be that reinstalling the graphics driver was solving the problem as well.
    Meaning, maybe reinstalling the old version would have solved it also.
    But at the end it would still be weird.

    I never had such an issue with ATI (note, not saying ATI is better than NVIDIA) graphic cards.
    And, unfortunately or luckily, non of my computers do have NVIDIA so can’t really test.

    Maybe keep in mind when this happens again that you just try to reinstall the current driver. !?


  • In installed N++ 6.9.2, but Log Monitoring does not seem to work - at all. When I monitor a logfile of my appserver by clicking on the “eye” in the toolbar, the content is never refreshed, unless I do this manually, or switch focus from and to N++.
    I disabled the File Status Auto-Detection feature to see if that helps, but no success. If i enable that feature, the file is only updated as soon as I switch from and to N++, and after confirming the “Reload”-popup . How is this feature supposed to work?
    Another bug(?) seems to be that with the tailing feature enabled, it that is no longer possible to delete-and-save all text (ctrl-A, DEL, ctrl-S). As soon as I select all text and delete, it is immediately replaced by the content from the file… Not what I would expect.
    (I’m on Windows 8)

  • @Herman-Onrust

    I tried a local file and it is working as expected.
    As you wrote

    When I monitor a logfile of my appserver

    I assume that the file is on a remote server? How is it integrated? Mapped? Opened with UNC path??

    Another bug(?) seems to be that with the tailing feature enabled, it that is no longer possible to delete-and-save all text (ctrl-A, DEL, ctrl-S).
    As soon as I select all text and delete, it is immediately replaced by the content from the file… Not what I would expect.

    I wouldn’t say this is a bug as it should only do what tail -f on linux does. Outputting appended data.


Log in to reply