Notepad++ 7 - 64-bit Available



  • You don’t need to install Notepad++ twice anymore to get Notepad++ 64-bit.

    Please check the following link:
    https://notepad-plus-plus.org/news/notepad-7-released.html

    Let me know if you find any critical issue.



  • 19. Add an option to restore old behaviour (open files in folder) while folder being dropped.

    Thank you so much. I was waiting for this so long.
    U best!



  • Crash while create a new udl

    Windows 10 Enterprise x64 (Version: 1607 | Build: 14393.51)
    Notepad++ 7 - x64

    start notepad++.exe -> Language -> Define your language… -> Create New… -> Name: test -> Notepad++ crashes



  • @donho Possible issue with v7? See:

    https://notepad-plus-plus.org/community/topic/12397/issue-with-saving-a-file

    Can’t replicate the issue myself.



  • Installing 64-bit on 64-bit Windows with 32-bit Notepad++ already installed ends up with two installations because the 64-bit installer doesn’t check to see if there is already a 32-bit version installed.

    The 32-bit install ends up in C:\Program Files (x86)\Notepad++ and the 64-bit install ends up in C:\Program Files\Notepad++ as you would expect.

    Not necessarily a problem but when you then uninstall the 32-bit version it also removes the various configuration files like config.xml, session.xml, etc. located in C:\Users\%username%\AppData\Roaming\Notepad++.

    I would have preferred to keep my history and session data.

    In other words, both 32-bit and 64-installs point to the same C:\Users\%username%\AppData\Roaming\Notepad++ path so running either uninstall will remove all of these files.

    On another machine I copied the existing 32-bit NPP config.xml and session.xml files to a temporary location and then removed 32-bit NPP before installing 64-bit NPP. Then I opened the old config.xml and session.xml and copied in the session data and history data into the new 64-bit installed ones which worked fine and didn’t seem to trouble NPP. Note I was careful with what I copied and where I pasted.

    It would be nice if the 64-bit installer handled an existing config.xml and/or session.xml file differently. Maybe ask if you want to preserve you current session and history data?



  • @jNizM Thank you for making Notepad++ crash !
    it’ll be fixed in the next release.



  • In addition to the issues brought up by Eric Winn, the file association is unable to switched to the 64-bit version, even if I rename the 32-bit version folder to something else. Not sure if this is a Windows 7 64 bit problem or Notepad++ problem.



  • @Salimsg-Ibrahim Could you povide the step-by-step instuctions so I can repoduce it?



  • @dail Thank you for infos. I cannot reproduce it either.
    I’ll stay tightly on this issue.



  • Hi i’m try to install notepad++ 7 x64 from command line with this switches but it will not install in this folder why? npp.7.Installer.x64.exe /S /D=C:\Program Files\Plus!\Notepad++



  • Thank you for the response. I am using Windows 7 64-bit and Notepad++ 6.9.2, which is located at C:\notepad++\notepad++.exe. After installing Notepad++ 7 64-bit, it is now located at C:\Program Files\notepad++\notepad++.exe. Right-click a .txt file to open with> choose a default program> open notepad++.exe in C:\Program Files\notepad++.
    However it is the 6.9.2 version that is called up. What I did was to rename C:\notepad++ folder to something else. Try right-click again to open with> choose a default program> goes to C:\Program Files\notepad++ folder. Problem is notepad++.exe does not appear in windows 7 open with windows anymore.



  • Hi Don, I solved my problem. This is the solution:

    The program that you’re pointing to isn’t registered correctly.

    In regedit: Navigate to Computer\HKEY_CLASSES_ROOT\Applications and find your .exe name.
    Navigate under its name to shell>open>command. In the Default change its location to the actual location of the executable, hit okay and then try and reassociate the file type as you normally would.



  • @Eric-Winn
    You are pointing out an issue where there may be some incoherence.

    Indeed there are 2 scenarios :
    if user download installer for 64-bit and install it without remove old 32-bit one, both 32-bit and 64-bit binaries will stay in C:\Program Files (x86)\ and C:\Program Files\ respectively.

    OTOH, if user uninstalls 32-bit version before installing 64-bit version, all the settings will be gone. But user is aware of what they do so it’s a normal behaviour to me.

    I have no yet idea to solve this issue. If anyone in here has a thought, please let me know.



  • @donho

    I’ve seen some uninstallers ask the user whether they’d like to keep their configuration files. Not sure how easy this would be.



  • @dail How about remove automatically the 32-bit version while installing 64-bit version and vice versa?



  • I’m curious how other applications work that have both 32bit and 64bit installations.

    How about remove automatically the 32-bit version while installing 64-bit version and vice versa?

    That might be a good solution (possibly ask/warn the user?). Either way, I think a couple of things have to be considered:

    1. If 32bit and 64bit are allowed to be installed simultaneously:
    • Users might get confused. Using the windows shell to edit a file with Notepad++ might not always use the one they want.
    • At least all the config files should be compatible between 32bit and 64bit which is good.
    • Plugins will be different between the two. Also, if plugins are allowed to be loaded from %APPDATA% do 32 and 64bit try to load the same plugins? This could be a problem.
    1. If only one of either 32bit or 64bit is allowed to be install:
    • I’m sure someone will complain, but you can’t please all users :)
    • I’ve found it useful so that I can test 32bit and 64bit plugins…but there are several other ways to do this so not a big deal.


  • Macro recording, hang the whole





  • Crashes when recording a macro. Usually when you type a \ for a special character.

    I’ve reverted to 6.9.2




Log in to reply