Notepad++ v7.2.2 released

  • After upgrading to x64 version (during install it asked if I wanted to first uninstall x86 and I said yes), Windows 10 keeps asking what program I want to use to open .txt files.
    I am the only user on the system and cannot set NP++ (x64) as default anymore.
    Control Panel to change by extension doesn’t register, and changing by program doesn’t even show NP++ anywhere.
    I have not rebooted since I installed the latest version. Last version I used that worked normally was 7.2.0.

  • I just updated to 7.2.2 on my Win10 64bit AMD PC. The first thing I noticed is that now when I open a Notepad++ associated file with a double-click when Notepad++ is open but minimized, Notepad++ will not “popup”. But when I manually pop up Notepad++, the file I double-clicked is open. This has quickly become an annoyance since I do this a lot and now I have to always pop up Notepad++ manually.

  • @donho 7.2.2 does not help to fix the 7.2 related “pending Actions bug”, still getting “gpup does not work anymore <Debug> <Close>”.
    If I click on debug, it says “An unhandled win32 exception occured in gpup.exe [5356]” Visual Studio then tells: “Unhandled exception at 0x011E1E45 in gpup.exe: 0xC0000005: Access violation reading location 0x00000000.”.

    Debug info:
    Notepad++ v7.2.2 (32-bit)
    Build time : Nov 27 2016 - 16:31:07
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10
    Plugins : mimeTools.dll NppConverter.dll NppExport.dll PluginManager.dll

  • I’m having the same problems on 7.2.1 and 7.2.2. No updates available to Plugin manager 1.4.?. (Windows 8.1 Pro 32-bit)
    So went back to 6.9, but still getting above problem with GPUP , so went into Plugin Manager and this time on the Updates tab, I was able to update plugin manager to Notepad++ is now working with v6.9 and Plugin Manager
    Dare I update to 7.2.2??

  • @sroe @Mike-Bussey242
    Try to uninstall everything and do a fresh install.
    Or chek in C:\Program Files (x86)\Notepad++\updater files gpup.exe and GUP.exe. You must have thoses files :

  • @cmeriaux I have those files thank you. I would like to get to v7.2.2, but don’t have the time to keep installing and uninstalling. It works at the mo, so I’ll stick with that until I have time to mess about. This is the first time I have had a serious issue with NPP and I have been using it forever.

  • @cmeriaux that’s what I have done, I checked that the Folders are empty, and they were, so it should be gpup.exe from the installer, which is crashing on my System. As @Mike-Bussey242 wrote, in 6.9 everything is working fine.

  • @sroe
    I took the risk and re-installed NPP v7.2.2 (overwriting v6.9) which worked with Plugin Manager
    Then upgraded P.M. to and everything (at the moment) is back to working OK again.

  • Notepad++ 32 bit running on Windows 10 x64.
    4k screen with scaling at 250%

    Doc Switcher Extension Column is too narrow. After every attempt at resizing, each time I minimize and maximize it returns to being too narrow again.

  • Only issue I’ve seen thus far is that I don’t see a “Use Old Icon” option anymore. :(
    (Though this is probably some old change that I’ve only just noticed…)

  • A scan of the download file for version 7.2.2 using the VirusTotal website shows that Locky Ransomware is in the executable.

    Can the download be blocked and this issue investigated?


  • @Samuel-Apperson

    In such a case could you provide more details?
    From which site did you download?
    What kind of package did you download (exe,zip)?
    Was it reported by one virus engine or multiple.
    Do you know that something like a false positive exists?


  • I was (I’m still) over 3 months without internet(this is my first contact), so don’t know what was happening recently in NP++, but I’m posting right now what I have prepared during offline time. I’m still using 6.9.2, and Python 3.5.2 32bit. Please don’t mind my updates numbering, I didn’t want rename all suggestions in link at end of this post.
    New updates:

    -4, [Selecting separate lines and transpose shortcut]
    I’m not able to select for example this: two lines number 5, 6; and then two lines number 9, 10. To make all four lines selected and nothing between. With Ctrl it’s not possible. I’m not sure whether it’s possible to do it NP++.
    Then I would like to Transpose them, but it only works with line on cursor + line above it.
    Is possible to remake it to select three lines in beginning of file for example, and somewhere else in file select another three lines, and then do Transpose shortcut. They would nicely switch.
    It’s useful. Please try.

    -3, [Display inconsistency]
    If user has set on his monitor high screen resolution and high magnifier settings, some things kept it’s small resolution-based size (I have found just one atm).
    Namely, it’s tree structure branching thing (plus minus clickable items) Can be fixed please ?

    -2, [Missing Python 3 syntax highlighting]
    Missing syntax highlighting for these kind of words: error objects, exception objects.
    If you write code below in python’s IDLE (ver 3.5.2) it will differ from NP++ syntax highlighting:

    print(15 / 0)
    except Exception as e:
    In IDLE it’s same color as print() function has, for example.
    These two words are missing in NP++'s syntax highlighting for Python 3, from what I have tried so far.:
    ZeroDivisionError, Exception
    Probably it’s whole group of them.
    I have tried different color themes in NP++, but result same.

    AND [Missing Python 3 builtins syntax highlighting]
    When you are writing some builtin functions like max(), min(), str(), list(), etc.; Python’s IDLE changes color, but NP++ did not. It’s same color as print() function, which NP++ does recognize.

    -1, [Back-Tab (Shift+Tab) adaptability/flexibility to accommodate for file indentation scheme]
    In general, Back-Tab works, but if you make a mistake by one more space or one less space and then use Back-Tab, it will dully do it’s job regardless of current intendation file scheme, so it will disrupt common intentation pattern in file.
    In other words it will keep this inconsistency and user has to repair it manually to fit into correct indents as lines above in same file.
    It should be modified to keep track of indent scheme in file and ignore user’s mispresses, because there is no reason for needing other than particular file type intendations rules (4 spaces in python).
    Let user choose about this behaviour by turning it on or off. Please think about it.

    AND [Messed Tabbing and Back-Tabbin in middle of lines]
    If you see situation on this picture:
    on line 22 and 23, Tab has been pressed once. On line 22 it did correctly 4 spaces, but in line below it did only 3 spaces. So fixed Tab length according programming language is working only from beginning of lines. NP++ probably considered it as random non-code text.
    It should be changed and let user to pick how he wants to NP++ behave in this manner.
    After I wrote those Tabs in lines, I pressed Back-Tab once in each line to see what happens. NP++ only moved cursor (caret) 4 spaces back in both cases, but did not moved text behind that Tab as it would do in beginning of lines.
    So this should be fixed too and let user choose to turn it on or off. Please think about it all.

    0, [Smart python indentation detection]
    IDEs and some editors have by default this feature inside:
    I will describe it for python case. If line starts with keywords as: def, if, elif, else, etc., and ends with a colon; and then user press Enter for new line, NP++ should figure out, that on next line it has to be indented and will do it automatically.
    And if line starts with keyword ‘return’ and user press Enter somewhere behind in that line, it means next line will be de-indented. But not to line begin, but just one tab back.
    And also when user is for example writing assigning statement for making new dictionary, list, tuple… He won’t write all that stuff in one line because it’s not eye friendly, but rather he will do it like this:
    So after user Enter it after opening brace, NP++ will automatically indent it in new line, because there is no other reason for non indented. Same with parentheses, brackets.
    Let’s just test it all for python and if it will work, devs may add other rules or other languages (file types).
    As always, let user choose to turn on or turn off this behavior. Please think about it.

    Here is my older post about useful changes. Please consider it all. It’s really important.

  • Previously unsaved files were maintained on closing on NP++. Now when I close NP++, I must save file!
    Unsaved files was great way for me to maintain my quick notes.

    Any reason to have that functionality removed?

  • @Ashish-Agrawal

    please check settings-preferences->backup
    Is enable session and snapshot… checked?


  • Is there an issue with “remember last used directory” in the “Default Directory” settings? It simply never works. Sometimes it resets itself to the first/default setting (follow current document), but other times, it doesn’t remember the last used directory even if selected. Issue persisted before 7.2.2.

  • Using 7.2.2 :

    I convert a text file “new1.txt” to shell file “” (menu language => S => Shell)

    The text file work fine :
    export mytest=bbb
    if [ “${mytest}a” == “testa” ]
    echo mytest ${mytest}
    echo mytest is not test : ${mytest}

    After conversion in *.sh :

    In the rigth place a “column” has added (on the left “number line” column).

    Sometimes the shell file was corrupted has :

    mexport mytest=bbb
    mif [ “${mytest}a” == “testa” ]
    mecho mytest ${mytest}
    mecho mytest is not test : ${mytest}

    How to remove the added “column” ?

    This feature works fine in 7.2.1

  • @Thierry-Grandjean

    you do not change file content while selecting the shell lexer.
    This just means that this lexer does the coloring of the current document.
    From what I see I assume that you’ve saved the file with windows eols and
    then transferred the file to unix machine but you didn’t do a eol conversion.

    Could this be?


  • Claudia, is my issue reproducible or am I posting to the wrong forum? Just wanted to follow up on my comment…

  • Why do I open the file location to use Notepad + +, but did not appear in the open file location?

Log in to reply