Notepad++ v7.2.2 released

  • Is there an issue with “remember last used directory” in the “Default Directory” settings? It simply never works. Sometimes it resets itself to the first/default setting (follow current document), but other times, it doesn’t remember the last used directory even if selected. Issue persisted before 7.2.2.

  • Using 7.2.2 :

    I convert a text file “new1.txt” to shell file “” (menu language => S => Shell)

    The text file work fine :
    export mytest=bbb
    if [ “${mytest}a” == “testa” ]
    echo mytest ${mytest}
    echo mytest is not test : ${mytest}

    After conversion in *.sh :

    In the rigth place a “column” has added (on the left “number line” column).

    Sometimes the shell file was corrupted has :

    mexport mytest=bbb
    mif [ “${mytest}a” == “testa” ]
    mecho mytest ${mytest}
    mecho mytest is not test : ${mytest}

    How to remove the added “column” ?

    This feature works fine in 7.2.1

  • @Thierry-Grandjean

    you do not change file content while selecting the shell lexer.
    This just means that this lexer does the coloring of the current document.
    From what I see I assume that you’ve saved the file with windows eols and
    then transferred the file to unix machine but you didn’t do a eol conversion.

    Could this be?


  • Claudia, is my issue reproducible or am I posting to the wrong forum? Just wanted to follow up on my comment…

  • Why do I open the file location to use Notepad + +, but did not appear in the open file location?

  • @Tamar-Weinberg

    normally I don’t have this setting activated but from my tests I can’t reproduce reported behavior.
    Which leads to two question.
    Do you have a different expectation or is your setup much more different as mine?

    From the setting I expect that every open file dialog, except the first one, opens
    in the last selected directory of that dialog. The first one should open in notepad++ directory.
    Is this your expectation as well? If so, there must be something else interfere.
    In this case, how does your setup look like?
    Which operating system, current npp version installed plugins - all can be gathered by menu
    ?->debug info. Maybe give it a try to run npp without plugins ( just rename plugins directory)

    What confuses me about your post is,

    It simply never works.

    used together with

    Sometimes it resets itself to the first/default setting (follow current document), but other times, it doesn’t remember the last used directory

    I don’t want to act like a smartass, it is just that I don’t know what the problem really is,
    because it can either never work or sometimes it is reset… but not both (or even all three).
    We need to get as much detailed information as possible in order to be able to help.


  • @動感假傳說

    sorry, don’t get the point - can you be a little bit more descriptive?


  • @Tamar-Weinberg Work for me. Could you post your debug info here?

  • @Claudia-Frank

    The “first” text file was in LF (Linux) end of line format.
    The simili column appear only when i choosing the syntax coloring shell lexer.
    I will try to reinstall notepad++ and the plugins.

    Thanks for you reply (and Happy New Year !!)

  • @Thierry-Grandjean

    as I’m currently working on a linux environment it’s easy to test but
    it looks ok for me.


  • After installation 7.3 version, the problem is over.
    I don’t know why.
    Thanks for you help

Log in to reply