NPP Crashing

  • I am currently on v7.2.2, 32-bit, and have been having an issue since updating to v7.2. (Prior to v7.2, I would not experience this issue.) Every once in a while, NPP will just exit. It won’t save my recent file lists or any unsaved files I had open at the time, so I would consider it a crash, though there is no error message that appears on screen. The program simply closes.

    During two separate occurrences, I am aware of what I was doing when it happened, though I don’t know if the crash is related to my actions–One time, I was dragging text files into NPP to open then. Another time, I was using the CTRL+TAB keystroke to switch tabs.

    NPP doesn’t crash every time I perform these actions, but I wanted to point it out anyway.

    I should also point out that I am running NPP portable (not-installed). And the files I have open when the crash happens are on a network drive.

    But, again, prior to v7.2, I had no issues with crashing. Or, at least, no recurring issues with crashing. This now seems to happen at least once a day or so. (I use NPP for work, so I usually have it open almost 8 hours or so.)

    So far, I’ve lost some work because it will crash and I will lose any unsaved files. I’m not saying NPP is the cause–because if it were, I would think other people would be complaining on the board. But I would very much appreciate it if someone can tell me how to troubleshoot this or where to look for an error log file–since there is no error message appearing on screen, I’m not sure what to do.

  • Please provide debug info

  • Here you go…

    Notepad++ v7.2.2 (32-bit)
    Build time : Nov 27 2016 - 16:31:07
    Path : \fenoffc501\UsersA-Z\digregm\DropboxPortableAHK\Dropbox\NPP\notepad++.exe
    Admin mode : OFF
    Local Conf mode : ON
    OS : Windows 7
    Plugins : ComparePlugin.dll DSpellCheck.dll mimeTools.dll NppConverter.dll NppExport.dll NppFTP.dll NppTextFX.dll PluginManager.dll QuickText.UNI.dll zoomdisabler.dll

  • Please, does someone have an idea of what the issue could be. This is really driving me crazy and causing me a lot of added work. It’s gotten to the point where I’m afraid to open a file because it could close what I already have open.

    Or, even if you don’t have an idea of why this is happening, what might you suggest I try to circumvent the issue?

  • Taking a stab in the dark here, I removed a couple of extensions that I don’t use: Compare, DSpellCheck, and NppFTP. Here is my new debug info:

    Notepad++ v7.2.2 (32-bit)
    Build time : Nov 27 2016 - 16:31:07
    Path : \fenoffc501\UsersA-Z\digregm\DropboxPortableAHK\Dropbox\NPP\notepad++.exe
    Admin mode : OFF
    Local Conf mode : ON
    OS : Windows 7
    Plugins : mimeTools.dll NppConverter.dll NppExport.dll NppTextFX.dll PluginManager.dll QuickText.UNI.dll zoomdisabler.dll

  • Path : \fenoffc501\UsersA-Z\digregm\DropboxPortableAHK\Dropbox\NPP\notepad++.exe
    Local Conf mode : ON

    Try to work on a local directory instead of a remote directory. It could be the cause of your troubles.

  • I appreciate the suggestion. I’ll give it a shot to see if it makes a difference. However, I’m not too hopeful. I’ve been working with NPP in that folder for almost two years, and the issue hasn’t appeared until the release of v7.2.

  • I didn’t said there is no issue. I said it could help you to avoid the bug.

  • I suspect this commit to be the source of your problems :

    Commit SHA-1: 39df01dab5e8bf1d3ebfe1ae81499b9255e3c1ab  
    * Add SmartHighLight node for config.xml generation

    It has been delivered on version 7.2. So can you downgrade to v7.1 and check if you still have the problem ?

  • Thanks, cmeriaux. I will try downgrading to version 7.1 when I am next in the office.

  • Any updates ?

  • I moved my portable folder to the C drive. The issue did not happen yet. But there is nothing I did before that would always make it happen, so I’m still keeping my fingers crossed.

  • Ugh, it just dawned on me. I had moved the portable folder directly onto the desktop. However, I just realized my desktop is on the same network share that the portable folder was originally on. And the computer that I use this on is a work computer, which I don’t have administrator privileges for, so I won’t be able to put it on the C drive.

    Will the commit you suspect caused my issue be something that will be fixed? Or will I just have to deal with it?

  • your problem could be fixed but It should be reported first to github bug tracker

  • Thanks for your help. I just posted on github.

  • I am still experiencing this issue on v7.3. I replied as such to the github item I posted, but no one has replied to it since I posted it in December, so I’m not sure if anyone is aware of the issue.

  • @Michael-DiGregorio

    do you see anything in the event log?
    If this isn’t helpful at all maybe consider using procmon with a filter to notepad++ executable.


  • @Claudia-Frank said:

    do you see anything in the event log?

    Hi Claudia–

    Thanks for the reply. I checked the event log. And at the time the crash last happened, there is an “error” that Windows closed NPP because the file became inaccessible, possibly due to a problem with the network connection. (Note: I am running portable NPP from a networked drive.)

    While the above does make it seem like the issue is instead a Windows issue (or at least a network connection issue), I would like to point out that I’ve been running NPP this way (portable from a networked drive) for nearly two years. And prior to when the issue started with v7.2, I have lost connection to the network while NPP was running. However, NPP never crashed in those instances; it simply remained open until the network connection was restored.

    So, could something in the code have changed starting with v7.2 that would cause the loss of access to the NPP folder to make the program simply exit?

    User cmeriaux in a post above said he suspected the issue might be related to:

    Commit SHA-1: 39df01d

    Add SmartHighLight node for config.xml generation

    I’m not sure what that means, but I thought I’d point it out.

  • @Michael-DiGregorio

    sounds interesting - let me try to hack around and see if I can find something out.


  • @Michael-DiGregorio

    keep in mind, that I did the tests using wine so it might be that windows os
    behaves a little bit different but to be honest, I think it is a normal behavior
    that application crashes when started from network share and share isn’t
    accessible anymore.
    I also tried with older npp (6.9.2 to be precise) and with MS notepad.exe and both
    applications do show the same behavior.

    I ASSUME it is related to the memory and the page file (paging in operations) mechanism,
    because if I just dropped the connection, the application was still running but as
    soon as I tried to do something with this application, I saw a network request
    to access the share, followed by the crash. MS notepad behaved a little bit different,
    multiple request were sent, but in the end it died as well.


  • @Claudia-Frank

    Interesting. I guess there is no issue with NPP then. Though I swear that the program would never crash when connection was lost prior to v7.2. But perhaps something else changed at the same time–maybe an update to Windows itself, or something like that.

    In any event, thank you very much for the time you took to troubleshoot my issue.

Log in to reply