NPP Crashing

  • Thanks, cmeriaux. I will try downgrading to version 7.1 when I am next in the office.

  • Any updates ?

  • I moved my portable folder to the C drive. The issue did not happen yet. But there is nothing I did before that would always make it happen, so I’m still keeping my fingers crossed.

  • Ugh, it just dawned on me. I had moved the portable folder directly onto the desktop. However, I just realized my desktop is on the same network share that the portable folder was originally on. And the computer that I use this on is a work computer, which I don’t have administrator privileges for, so I won’t be able to put it on the C drive.

    Will the commit you suspect caused my issue be something that will be fixed? Or will I just have to deal with it?

  • your problem could be fixed but It should be reported first to github bug tracker

  • Thanks for your help. I just posted on github.

  • I am still experiencing this issue on v7.3. I replied as such to the github item I posted, but no one has replied to it since I posted it in December, so I’m not sure if anyone is aware of the issue.

  • @Michael-DiGregorio

    do you see anything in the event log?
    If this isn’t helpful at all maybe consider using procmon with a filter to notepad++ executable.


  • @Claudia-Frank said:

    do you see anything in the event log?

    Hi Claudia–

    Thanks for the reply. I checked the event log. And at the time the crash last happened, there is an “error” that Windows closed NPP because the file became inaccessible, possibly due to a problem with the network connection. (Note: I am running portable NPP from a networked drive.)

    While the above does make it seem like the issue is instead a Windows issue (or at least a network connection issue), I would like to point out that I’ve been running NPP this way (portable from a networked drive) for nearly two years. And prior to when the issue started with v7.2, I have lost connection to the network while NPP was running. However, NPP never crashed in those instances; it simply remained open until the network connection was restored.

    So, could something in the code have changed starting with v7.2 that would cause the loss of access to the NPP folder to make the program simply exit?

    User cmeriaux in a post above said he suspected the issue might be related to:

    Commit SHA-1: 39df01d

    Add SmartHighLight node for config.xml generation

    I’m not sure what that means, but I thought I’d point it out.

  • @Michael-DiGregorio

    sounds interesting - let me try to hack around and see if I can find something out.


  • @Michael-DiGregorio

    keep in mind, that I did the tests using wine so it might be that windows os
    behaves a little bit different but to be honest, I think it is a normal behavior
    that application crashes when started from network share and share isn’t
    accessible anymore.
    I also tried with older npp (6.9.2 to be precise) and with MS notepad.exe and both
    applications do show the same behavior.

    I ASSUME it is related to the memory and the page file (paging in operations) mechanism,
    because if I just dropped the connection, the application was still running but as
    soon as I tried to do something with this application, I saw a network request
    to access the share, followed by the crash. MS notepad behaved a little bit different,
    multiple request were sent, but in the end it died as well.


  • @Claudia-Frank

    Interesting. I guess there is no issue with NPP then. Though I swear that the program would never crash when connection was lost prior to v7.2. But perhaps something else changed at the same time–maybe an update to Windows itself, or something like that.

    In any event, thank you very much for the time you took to troubleshoot my issue.

Log in to reply