Just another ordinary release - 7.5.1

  • @ImSpecial
    could you please check if your c:\notepad++ folder has full write permissions for your current username or the group “users” ?

    if you need a template to know which security settings will work, just create a new empty folder on your desktop > right click on it > properties > security >>>
    compare these security settings with the security settings of your custom notepad++ folder

  • @ImSpecial
    I’ve replied you 2 days ago.
    Please check the message above.
    I cannot reproduce your problem, and without your debug information, I can do nothing about.

  • @donho
    I’ll try and get you those as soon as I can, meanwhile can you comment on what the purpose of the folder is for?

    There are two Notepad++ folders, the “new” empty one that came with version 7.5.0 located at;

    and the second one which is located at;

    where the settings are stored.

  • settings are stored in appData/Roaming/Notepad++/config.xml

  • @cmeriaux

    I know, that’s what I said, what about the Local\Notepad++ folder? Whats stored in there?

  • Unfortunately I still can’t load big logs to notepad++ 7.5 64bit.
    For example log file size is 8GB and everytime I try to load it using right mouse click and “Edit with Notepad++” option, everytime I get “File size problem” window with message “File is too big to be opened by notepad++”
    Any chance for fixing this in the incoming releases ?

    greets from Poland

  • Having an issue I have not had in previous releases. Loading 32 or 64bit of the 7.5.1 I have a non-English language for install. Google translate says it is “Afrikaans” or “Dutch” I don’t have this issue on other programs. my default language is English. I downloaded the English version. is it an installer problem ?

  • @ImSpecial “C:\Programs” is generally reserved for special installs AFIK and is usually NOT where you should install ANY software yourself. This could be the whole source of your problem. I highly recommend getting used to installing to “C:\Program Files” (for 64 bit software on a 64 bit version of Windows, or for 32 bit software on 32 bit Windows, for 32 bit software on Windows use “C:\Program Files (x86)”. If you want a specific non-protected install folder use a path other than “C:\Programs” (“C:\Programs” AND “C:\Program Files” both have special permissions. Under normal circumstances installing to “C:\Progam Files” should work fine, the only real drawback (that I know of) is that if you want to modify files in any of its subfolders you need to have Administrator privileges, using a folder other than “C:\Program Files” OR “C:\Programs” should remove that limitation, but as I said “C:\Programs” is not where you should install your software because that’s where Windows puts special files related to things like Windows Store Apps and such).

    1. Add a spiritual quote.

    Where would I find the spiritual quote in this update? :D

  • Past versions of NPP have allowed a file to be saved using the “Save As…” command without changing its file name (i.e. works identically to the “Save” command but with the confirm file save dialog box, which is consistent with every other Windows app). In NPP 7.5.1, doing a “Save As…” without changing the file name gives an error that the file is already open in NPP and does not allow the file to be saved.

    Please fix. Thanks.

  • @Phillip-Mitchem
    start np++ with the argument -qnrandom to get a random quote every time you launch np++

    notepad++.exe -qnrandom

  • Just upgraded to latestest release, now when I try to do a regex replace with find of ^ (start of row) and replace with (, and hit replace all, it says It replaced 39 rows, which is the correct number, but the document does not get edited. No changes occur, tried refreshing window, shut down np++, still the same, no changes. Any ideas?

  • Hi
    Where can I report a bug in 7.5.1.
    when I first open the Notepad++ (where different files were open in last session), the color of the code gets changed and to force it to correct language color I have to switch the language to something else and then come back to the one I wanted. I also can share screenshot but don’t know where and how…this is my first time here…


  • @Phillip-Mitchem

    To be more specific than @Meta-Chuh was:

    The easiest way to see this (the new “spritual” quote) is to type Notepad++ #3 in an editor window, select that text in-full, and then choose **About Notepad++…" from the ? menu. After you do this, Notepad++ will open a New document window and SLOWLY type something for you.

    You could also start Notepad++ running with the following command line to see the same thing (but this is harder to do):
    your_path_to_notepad_plus_plus\notepad++.exe -qnNotepad++%20#3

    SPOILER ALERT: For those that don’t want to go to the effort to try it, but still want to know what the new and exciting quote is, here it is:

    The best things in life are free.
    Notepad++ is free.
    So Notepad++ is the best.
    - Notepad++ #3

    Interestingly, this quote is typed by Notepad++ with full ignorance of the selected line-ending type. For example, with Windows CRLF endings selected, the text is typed and Linux LF endings appear:


  • The Notepad++ Installer 32-bit x86 does not include plugin manager.

  • This post is deleted!

  • @Samandra-Khandr

    “C:\Programs” is fine and has nothing to do with windows, it’s where I put all my portable programs, the name of the folder has nothing to do with this, It could be named “C:\TEMPFOLDER” for all I care and the same thing would happen, this is not “C:\Programs Files” or “C:\Programs Files (x86)”.

    Still waiting for @donho to acknowledge what “%APPDATA%\local\notepad++” folder is used for, the one in Roaming is used for settings, Local? it’s empty.

  • @Chris-Didamo

    i’ve just tested regex-replace-all on 7.5.1 installer and zip release versions, because i also use this often.
    both notepad++ releases work perfectly.

    did you recheck your search wildcards (.*?) and $x variables in your replace string for any syntax error ?
    maybe … just maybe … they replace the same content back ?

    here’s a little working regex replace example you can try:

    test code:
    <style type=“text/css”></style>
    <a href=“url”>1</a><br>
    <a href=“url”>2</a><br>
    <a href=“url”>3</a><br>

    regex search string: ^<a href(.?)>(.?)<(.*?$)
    regex replace string: <a id=“link$2” href$1>$2<$3

    <style type=“text/css”></style>
    <a id=“link1” href=“url”>1</a><br>
    <a id=“link2” href=“url”>2</a><br>
    <a id=“link3” href=“url”>3</a><br>

  • @Chris-Didamo

    edit: i forgot the code marker, so the above example reformats the * in the code text.

    THIS is the working regex replace example you can try:

    test code:
    <style type="text/css"></style>
    <a href="url">1</a><br>
    <a href="url">2</a><br>
    <a href="url">3</a><br>
    regex search string: ^<a href(.*?)>(.*?)<(.*?$)
    regex replace string: <a id="link$2" href$1>$2<$3
    <style type="text/css"></style>
    <a id="link1" href="url">1</a><br>
    <a id="link2" href="url">2</a><br>
    <a id="link3" href="url">3</a><br>

  • Strange, I used your example and it works fine. So retested my on my data, and it doesn’t work.
    I am copying some text straight from Microsoft SQL Server Management studio result page, and pasting into np++, and running the search/replace, when I press replace all, it says Replace All 38 occurrences were replaced at bottom of replace dialog box, but nothing changes on screen.
    All I am trying to do is put a ( at beginning of line, using search ^, and replace (.
    I thought I had done that previously, but tested with (, and it finally put the ( at beginning of line.
    Thanks for the reply

Log in to reply