Just another ordinary release - 7.5.1

  • @Phillip-Mitchem
    start np++ with the argument -qnrandom to get a random quote every time you launch np++

    notepad++.exe -qnrandom

  • Just upgraded to latestest release, now when I try to do a regex replace with find of ^ (start of row) and replace with (, and hit replace all, it says It replaced 39 rows, which is the correct number, but the document does not get edited. No changes occur, tried refreshing window, shut down np++, still the same, no changes. Any ideas?

  • Hi
    Where can I report a bug in 7.5.1.
    when I first open the Notepad++ (where different files were open in last session), the color of the code gets changed and to force it to correct language color I have to switch the language to something else and then come back to the one I wanted. I also can share screenshot but don’t know where and how…this is my first time here…


  • @Phillip-Mitchem

    To be more specific than @Meta-Chuh was:

    The easiest way to see this (the new “spritual” quote) is to type Notepad++ #3 in an editor window, select that text in-full, and then choose **About Notepad++…" from the ? menu. After you do this, Notepad++ will open a New document window and SLOWLY type something for you.

    You could also start Notepad++ running with the following command line to see the same thing (but this is harder to do):
    your_path_to_notepad_plus_plus\notepad++.exe -qnNotepad++%20#3

    SPOILER ALERT: For those that don’t want to go to the effort to try it, but still want to know what the new and exciting quote is, here it is:

    The best things in life are free.
    Notepad++ is free.
    So Notepad++ is the best.
    - Notepad++ #3

    Interestingly, this quote is typed by Notepad++ with full ignorance of the selected line-ending type. For example, with Windows CRLF endings selected, the text is typed and Linux LF endings appear:


  • The Notepad++ Installer 32-bit x86 does not include plugin manager.

  • This post is deleted!

  • @Samandra-Khandr

    “C:\Programs” is fine and has nothing to do with windows, it’s where I put all my portable programs, the name of the folder has nothing to do with this, It could be named “C:\TEMPFOLDER” for all I care and the same thing would happen, this is not “C:\Programs Files” or “C:\Programs Files (x86)”.

    Still waiting for @donho to acknowledge what “%APPDATA%\local\notepad++” folder is used for, the one in Roaming is used for settings, Local? it’s empty.

  • @Chris-Didamo

    i’ve just tested regex-replace-all on 7.5.1 installer and zip release versions, because i also use this often.
    both notepad++ releases work perfectly.

    did you recheck your search wildcards (.*?) and $x variables in your replace string for any syntax error ?
    maybe … just maybe … they replace the same content back ?

    here’s a little working regex replace example you can try:

    test code:
    <style type=“text/css”></style>
    <a href=“url”>1</a><br>
    <a href=“url”>2</a><br>
    <a href=“url”>3</a><br>

    regex search string: ^<a href(.?)>(.?)<(.*?$)
    regex replace string: <a id=“link$2” href$1>$2<$3

    <style type=“text/css”></style>
    <a id=“link1” href=“url”>1</a><br>
    <a id=“link2” href=“url”>2</a><br>
    <a id=“link3” href=“url”>3</a><br>

  • @Chris-Didamo

    edit: i forgot the code marker, so the above example reformats the * in the code text.

    THIS is the working regex replace example you can try:

    test code:
    <style type="text/css"></style>
    <a href="url">1</a><br>
    <a href="url">2</a><br>
    <a href="url">3</a><br>
    regex search string: ^<a href(.*?)>(.*?)<(.*?$)
    regex replace string: <a id="link$2" href$1>$2<$3
    <style type="text/css"></style>
    <a id="link1" href="url">1</a><br>
    <a id="link2" href="url">2</a><br>
    <a id="link3" href="url">3</a><br>

  • Strange, I used your example and it works fine. So retested my on my data, and it doesn’t work.
    I am copying some text straight from Microsoft SQL Server Management studio result page, and pasting into np++, and running the search/replace, when I press replace all, it says Replace All 38 occurrences were replaced at bottom of replace dialog box, but nothing changes on screen.
    All I am trying to do is put a ( at beginning of line, using search ^, and replace (.
    I thought I had done that previously, but tested with (, and it finally put the ( at beginning of line.
    Thanks for the reply

  • Something about Encoding.
    Encoding->Convert to UTF-8 without BOM
    Encoding->Convert to UTF-8
    It should be the other way around.

  • @Scott-Sumner This is too, the part of easter egg :)

  • @donho

    I was sorry to find that the new Find box (with a find up and a find down button) has reverted to the old style. Is there an option to obtain the new Find box?


  • after few days my Find box has reverted to the old style. but without up/down search.

    screen shot

  • @Scott-Sumner said:

    The best things in life are free.
    Notepad++ is free.
    So Notepad++ is the best.

    I must point out a fatal flaw in this reasoning.
    The only thing the first two lines prove is that Notepad++ might be the best (of course we all know it is regardless).

    Also, I could get Notepad++ #2 to work but not Notepad++ #1 🤔

  • @Ohad-Schneider
    the text to trigger the first message is just Notepad++

  • Today when I started Notepad++ (after a reboot) my user defined languages were not working. I open the editor and the keywords are still there but all ‘Styler’ settings had been reset to the default font with black color.

    I was using 7.5 and I don’t know if it’s connected but this morning I also got the popup if I wanted to download 7.5.1, I declined.

  • After updating, autohotkey doesn’t seem to work with notepad++ active anymore. With this script, F12 doesn’t cause Ctrl+` to fire:

    ; Translate F12 to Ctrl+`
    Send {Ctrl Down}``{Ctrl Up}

    I’m not sure what version of notepad++ I had previously installed. If someone can point me to where that might be logged, I can add the information.

    I’ve tried a couple of other keys to overwrite, and the problem happens consistently. Here’s the rest of my configuration if that helps:
    ; AutoHotkey Version: 1.x
    ; Language: English
    ; Platform: Win9x/NT
    ; Author: A.N.Other myemail@nowhere.com
    ; Script Function:
    ; Template script (you can customize this template by editing “ShellNew\Template.ahk” in your Windows folder)
    +Delete::Send {Delete}

    SetTitleMatchMode, 2
    #NoEnv ; Recommended for performance and compatibility with future AutoHotkey releases.
    SendMode Input ; Recommended for new scripts due to its superior speed and reliability.
    SetWorkingDir %A_ScriptDir% ; Ensures a consistent starting directory.

    ; Redefine only when the active window is a console window
    #IfWinActive ahk_class ConsoleWindowClass

    ; Paste in command window wit Ctrl+v
    ; (Edit->Paste)
    Send !{Space}ep


    ; Hotkey to make window always on top
    Winset, Alwaysontop, , A

    ; Translate F12 to Ctrl+`
    Send {Ctrl Down}``{Ctrl Up}

    #IfWinActive WinDbg

    ; Go To Line with Ctrl+l
    Send ^l

  • @Phillip-Mitchem Did you find where/how to access the spiritual quote? I need to disable the thing

  • @Truk-Meister

    AFAIK it can’t be disabled. What’s the problem? Simply don’t do what invokes (desribed earlier) the “ghost quotes” feature…and it is in no way that I can see “spiritual”. Some of the quotes are maybe a bit questionable if Notepad++ is used in an educational environment with young children…is this the concern?

Log in to reply