Notepad++ 7.5.5 release

  • @Scott Sumner
    A bit off topic but can you tell me which tool you use to create the gif screen cast?

  • @Tragen said:

    which tool you use to create the gif screen cast?

    Sure, see this thread. BTW, as I type this the animated GIF above keeps playing and popping up that error box, making me think Notepad++ is crashing, over and over and … :^)

  • Thank you @donho for this latest release, particularly for adding the find buttons back in. I appreciate it. Regarding the face hugger in your avatar: I recommend nuking it from orbit. It’s the only way to be sure.

  • hi everyone. as of version 7.5.5, the Monitoring (tail -f) feature is working, but not immediately displaying new changes (within the file/log being monitored). however, it does display updates/changes, but only after clicking on another app, then clicking back to the notepad++ app. my OS is win 10 enterprise. is this a new issue?

  • Hello @don-ho and All,

    I noticed a bug while opening files from within N++, on my Win XP laptop !

    First, here is the Debug info…

    Notepad++ v7.5.5   (32-bit)
    Build time : Feb 27 2018 - 21:44:21
    Path : C:\_755\notepad++.exe
    Admin mode : OFF
    Local Conf mode : ON
    OS : Windows XP (32-bit)
    Plugins : DSpellCheck.dll mimeTools.dll NppConverter.dll NppExport.dll 

    If, in the “Open” window, I type in some characters ( loc), in the File Name field, it automatically proposes the file Localisation.txt, as below :

    Now, if I hit the Enter key to open that file, I get, instead, the following error dialog :

    Of course, I click, immediately, on the Non button ( No ) to prevent creating an erroneous file !

    Now, if I select the right file, in the complete list of files, of the folder Lettres, as below, I correctly get the localisation.txt file opened !?

    Remarks :

    • Sometimes, 1 out of 10 about , the file opens immediately, as expected. But after closing and re-opening it, at once, I get the issue !

    • Sometimes I may have two of three consecutive error dialogs, with a different weird file name, each time

    But, luckily ( or unfortunately, for Win XP users, like me ! ), I verified that this behavior never occurs on a W7 OS and probably it should be OK for higher OS, too !

    As I understood that the XP support will be dropped very soon and that @chcg said :

    7.5.1 build with platform sdk v120_xp was the last version supporting winxp

    So, I’m just posting this bug as information ! I’m also quite surprised that no other Win XP people have noticed this issue, yet. Mum, Dad, it looks like I’m the only one N++ user, with an XP machine !! Scaring, isn’t it ?

    Best Regards,


  • Hi, @don-ho, and All,

    I’ve just tried without any plugin, running a notepad++ - noPlugin DOS command ==> same issue, as shown below :



  • I like the find next/previous button but you could consider doing what most other programs do. keep the find next button as one button and add a dropdown or option button for search direction next/previous|up/down.
    my biggest issue is all other windows programs i use have the find next button on its own line and to have to move the mouse over to the right i keep accidentally hitting the back button since its first. maybe switching button placement so find next is the first button you hit then the find previous button on the right and smaller.
    let the community decide.

  • @guy038 win-xp has a subset of Unicode 3.0 and 4.0 but does it internally and does not fully support the latest versions. it will only handle those it knows and if you only use the ms fonts for win-xp. i have had many unicode issues with win-xp. the common dialog for opening/saving files can be an issue since npp changed to new dialogs. the last version i use for xp/2000 machines is v.6.9.2 with ascii/ansi only plugins but you could try 7.3.3 or 7.4.2. you dont get the latest plugins but its a trade off for legacy systems. if you read a history of file encoding you will see what problems arose around the win-xp time and the lengths it took to support older language tables vs modern unicode 3.1+.

  • Hello, Notepad++ is a great tool, but I have a problem with it. The Monitoring (tail -f) is working well on Windows 7 and later versions, but I’m using Windows XP and on XP is not working. Probably the OS “layers” between XP and newer versions work differently (flush, sync . . ., I know little about programming) and that is the cause. Would you make tail -f to work in Windows XP too?


  • @donho what is the current plan for scintilla update? Do you intend to go ahead with the longterm3 branch of scintilla or wait for the scintilla 4 to become stabilized?
    Asking to understand the vision.


  • @KantorZsolt As a user mentioned above, I found out that support for XP was dropped with version 7.5.1. I installed v7.5.1 and the Monitoring (tail -f) functionality works fine in XP. So yes, unfortunately the latest version of Notepad++ which has support for XP is 7.5.1.

  • @KantorZsolt, @guy038,
    There is an existing pull request for WinXP-compatibility, you could upvote:

  • Not sure in what version this stopped working:

    “Encoding” menu does not open when I press Alt+N, but it opens when I press Alt+Shift+N.

    Note that both Alt+ and Alt+Shift+ work for other menus.

  • @Valentyn-Shtronda,
    reproduced with Notepad++ 7.5.5 (32-bit, English localization).
    Seems to be because of the following (checked via the Settings - Shortcut Mapper while trying to assign any command to Alt+N): the Alt+N (as well as Alt+A, Alt+B and Alt+D) is registered as a shortcut key of the DSpellCheck plugin.

  • @Vitaliy-Dovgan Indeed, thanks! Fixed by removing all shortcuts from DSpellCheck plugin. It’s bad idea to use Alt+ shortcuts anyway because of conflict with main menu. I would suggest to remove them by default (or change to smth else).
    I would also show warning in Shortcut Mapper if Alt+ shortcut is assigned to smth.

  • Hi there[link text](link url)

  • There is still a problem with losing syntax highlighting when using diff (alt-D). I will try to demonstrate using perl as an example, but the issue appears to affect all languages - at least the few I have tried.

    Here is how to reproduce:
    Open two files that contain code that is syntax highlighted.

    Press ALT-D

    Now if you want to restore your syntax highlighting you will have to select any other language then select the language you prefer, or you can go to the top of the page and press the spacebar then CTRL-Z.

    This has been an issue for quite some time for me. If this is not the correct place to post this bug, please direct me to where to post.

  • @miaXcova

    It is really hard for Notepad++ (or plugins) to know what to reliably do for unsaved (“new X”) files–any reason you don’t actually save Perl files to disk with a .pl extension before doing what you are doing? You might have better luck that way. No real idea though as I don’t use the “Compare” plugin, which I’m guessing you are using because Notepad++ itself doesn’t have a “diff” capability.

    It seems like people really want to push the capability of Notepad++ when it comes to “new X” files, which really only exist as a convenience in the brief life of a file before giving it a name, or as the rawest of all “scratchpad” areas.

  • @miaXcova,

    Pursuant to Scott’s post, what diff are you using? When I use the Compare Plugin v2.0.0, on two saved perl scripts,

    it maintains syntax highlighting throughout the sequence. Not shown, but it also maintains it on two unsaved perl scripts where I’ve manually selected Language > Perl.

    Thus, I am assuming you’re either using an out-of-date Compare Plugin, or your “diff” is using a different plugin.

    On mine, Plugins > Compare > About... shows:

Log in to reply