Notepad++ 7.5.9 release

  • problem is with horizontal scroller not the vertical.

    @abdelhameedma said:

    I got this excetion when trying to use vertical scroller with wider XML file:


    vector<T> too long

    fyi, I am using “XML Tools” plugin

  • Bundled converter is still version 4.2 instead of latest release

  • @abdelhameedma If you remove XML tools plugin, does Notepad++ still crash?

  • @chcg Thank you for your heads up.
    It’ll be updated in the next release.

  • After doing a file search for text, a right-click copy command no longer copies the file the text was found in. A paste only shows the text found.

  • @Eric-Dickstein said:

    After doing a file search for text, a right-click copy command no longer copies the file the text was found in. A paste only shows the text found.

    That is how it has always worked, to wit:

    (a) Select text in Find result panel, then ctrl+c copy it: In the paste buffer will be exactly what you highlighted with the selection

    (b) Select text in Find result panel, then right-click -> Copy it: In the paste buffer will be complete lines that are touched (even partially) by the selection, without any search metadata

  • @Eric-Dickstein
    Are you talking about the 7.5.9 release?
    I cannot reproduce the problem you describe. Could you provide the detail instruction to reproduce it?

  • @donho said:

    Eric-Dickstein…I cannot reproduce the problem you describe

    Don, maybe you can’t reproduce the problem because THERE IS NO PROBLEM!


  • Hi! The C++ parser (functionList.xml) does not find the class method names if the ‘::’ characters are framed with spaces. For example:
    void TWindow :: RegisterClass (Boolean aMakeRegister)


    Correct C++ parser (functionList.xml) in two regex locations:


  • Fixed for me, in this release:
    #3939 v7.5.2: View > Summary is Crippled
    #3944 v7.5.2: File is changed by Another Application but Notepad++ does not detect this

    Much appreciated!

    Kindly also make a top priority fixing of:
    #534 v6.8: Backward Search does not work for UTF-8 Characters in a [Normal] Text File
    which is a long-standing and very annoying bug [I updated my report with recently discovered specific behaviour]

  • Switching documents looks like it now pre-renders the entire document before drawing to the screen, which freezes when switching to large Normal text files with word wrap enabled (no lag with word wrap disabled).

    eg. from a small but noticeable half second for 250k words, to several seconds for files with 3 mil words, on a stock ryzen 5 1400 cpu.

    Prior, it still took time to calculate the vertical scroll bar (the same times as above), but still instantly drew the document the moment you switched to it, so you could read, write, mousewheel around, etc, while the vertical scrollbar worked itself out.

    I imagine from the patch notes that the change is a fix or workaround for bugs or something (I don’t actually know), but I usually work with big text files, so it’s definitely annoying for my use case. Notepad++ is of course mostly for rich text editing, instead of bulk text editing like this, but it still worked great and is my favorite for any related task, so it’s worth mentioning at least.

  • I would like to confirm @Fox-E about the pre-rendering issue. I am also noticing a delay in not only switching documents but also editing them.
    I do not use word wrap but I do use code folding heavily and the problem only happens when a document has many folds and is currently all folded up. If I unfold all (alt+shift+0) everything is fast and responsive as it should be. If I start folding a few lines it is still ok but if I fold all (alt+0) then try to edit or switch to another tab and switch back, I see the processor spike for several seconds while n++ is completely unresponsive until the screen flashes and it comes back.
    Before this update, I too noticed the scroll bar taking it’s time to compute but the document would render and be responsive immediately, but now I have to constantly wait on renders if I want to continue to use folding.
    I primarily work in the JavaScript language and generally keep my code completely folded except for the particular tree/line I am currently working on. On a document with less than a few hundred lines it is not so bad but on a document with 6500+ lines, the delay is around 5 -6 seconds which becomes an eternity when it happens after every few keystrokes.

  • @Fox-E @Harold-Krueger-IV I cannot reproduce your problem at all, could you provide more detail info?
    also could you provide the last version that you used in which there’s no such issue?

  • @Fox-E and @Harold-Krueger-IV ,

    Is the N++ backup functionality switched on in your config?
    What is the period of the backups (the time interval set in the config for the backup)?


  • @pnedev I do have periodic backup enabled but I just tried disabling it, restarted n++, problem still exists.

    @donho I always keep n++ updated so I was coming from 7.5.8 and did not have this problem before.

    I was able to reproduce the issue with a new file set to the JavaScript language. I started by writing a simple object declaration with a comment block inside. The comment block contains 5 paragraphs of lorem ipsum text as generated from which I split on every sentence making the comment block 76 lines. It looks like this…

    Section1 = {
            Lorem ipsum...

    I then copied the entire comment block and pasted it 13 times, one after the other, making the entire declaration 1066 lines. Then I copied and pasted all of that 8 times, one after the other, making the entire document 9597 lines (502,626 bytes)

    Now, if I fold all (alt+0, and by the way this also takes several seconds to complete) and then unfold just one section and one comment block and just try to type some more text, I start seeing the freeze after a few keystrokes. If I unfold all (alt+shift+0), then the problem goes away and everything is very responsive as expected.

  • @pnedev Backup is disabled.
    @donho Coming from 7.5.8 , so the problem is new in 7.5.9 .

    I also tried @Harold-Krueger-IV 's method above, and have the same freezing issue when switching to a tab with lots of folded code.

    To reproduce the plain text issue using basically Harold’s method:

    1. Install a fresh Notepad++ with 100% vanilla settings. Leave the update notes tab open.
    2. Open a new tab in Notepad++ with language as Normal Text.
    3. Enable View > Word wrap .
    4. Go to and ctrl+a copy the entire page.
    5. Paste into the empty tab. Paragraphs must be wrapping for the Normal Text version of this problem to show.
    6. Hold down the paste button for a few seconds. ctrl+a copy, then hold down paste for a few more seconds. You should now have a document of several million words and lots of wrapped lines.
    7. Switch tabs back and forth between the update notes tab and the huge text file tab; it’ll freeze while pre-rendering the huge text file’s word wrapping (or code folding, etc).

    In 7.5.8 , switching to such a large or heavily-folded tab will instantly display the document at the cursor, while rendering the rest of it in the background. If you watch the vertical scrollbar, you can see it slide and shrink as it does this, until the scrollbar pops to its final position.

    In 7.5.9 , it just freezes until the whole document is rendered, and only then displays it.

    7.5.8’s method is the preferable, expected behavior in my opinion. The freezing is bad for lots of tabbing around, while the background rendering is unobtrusive and never gave me any usability problems.

  • Thanks for this great tool and the continued support!

    I just upgraded to v7.5.9 and am seeing a vector <T> too long error dialog box when trying to position the cursor at the end of a line of text that extends beyond the screen horizontally. This behavior did not occur in v7.5.8.

    For what its worth, this error does not occur when the DSpellCheck plug-in is disabled.

  • Hi, @don-ho and All,

    Many thanks for this new version and, also, for the plugin manager, which is about to be launched !

    So, I’m quite sorry, Don, for bothering you, but, indeed, there a problem with the new v7.5.9 version, when using a file, which contains very long lines ( ~1000 chars or over )

    I followed the test method, given by @fox-e and I did obtain the same results as @fox-e and @harold-krueger-iv :-((

    From the site I copied one page, and, with a lot of CTRL+V actions, I got a file of about 38.2 Mb ( > 40,000,000 bytes )

    When the Wrap option is not set, N++'s behaviour is quite correct. But, as soon as the Wrap option is on, the fact of switching from, let’s say, the change.log file to this test file needs about 10 seconds before seeing the file contents !? If you close the file, with Ctrl + W and re-open it with Ctrl + Shift + T, again, the delay is really significant !

    And, if you’re using, like me, the option Remember current session for next lauch and that this test file was the active tab, before closing, any restart of N++ take several seconds, providing that the wrap feature was set ! Just note that, on the contrary, if the active tab was change.log before closing, the restart of Notepad++ is quite correct !

    And , unfortunately, it happens that this delay gets increasing, as the file size increases :-((

    Here is my Debug Info information :

    Notepad++ v7.5.9   (32-bit)
    Build time : Oct 14 2018 - 15:02:52
    Path : D:\@@\759\notepad++.exe
    Admin mode : OFF
    Local Conf mode : ON
    OS : Windows XP (32-bit)
    Plugins : DSpellCheck.dll mimeTools.dll NppConverter.dll NppExport.dll 

    Again, problem occurs ONLY when the Wrap feature is ticked !

    Thanks for your investigation !



    When launching Notepad++ 7.5.9 on Windows 10, 64 bit system, I get the following in two
    separate dialog boxes:

    1. “Create new file” “C:\Program” doesn’t exist. Create it? YES OR NO buttons.

    2. “Cannot open file” “C:\Program Files\Notepad ++\updater\Files\Notepad++\change.log” cannot be opened:
      Folder “C:\Program Files\Notepad ++\updater\Files\Notepad++” doesn’t exist. OK button.

    Happens EVERY time at program launch.



  • @Jeffrey-Jodoin

    IIRC, it sounds like the shortcut you have for running Notepad++ has the change.log file embedded in it?

    Otherwise, try a search on site: change.log.

    Or maybe something related to this.

Log in to reply