Notepad++ 7.6 & new Plugins Admin



  • @Galen-Tackett said:

    The installer for 7.6 requires UAC elevation, and since I’m not an administrator, I can’t install Notepad++ 7.6 even for just myself. I thought this was possible with installers for earlier versions?

    Your are mistaken. The installer of Notepad++ required admin rights in previous versions too. This is a Windows restriction and can not be changed as installers copy the installed EXE file to a subfolder of Program Files or Program Files (x86) which are OS protected locations.

    @Galen-Tackett said:

    I tried unzipping the .7z archive. I can certainly run Notepad++ from there, but the Plugins Admin is missing so I can’t install any additional plugins.

    Currently the portable versions of Notepad++ (from ZIP or 7z file) don’t include Plugin Admin. This may change in the furture. Currently the only way to use plugins with portable versions is to install them manually.



  • @Guillaume-Bloss said:

    …this issue will probably disapear when plugins will be available in both 32 and 64

    There are already 64 bit plugins available (for about to 1.5 years). The 64 bit plugin manager is obtainable here, take PluginManager_v1.4.12_x64.zip. Please note: Plugin Manager is currently only usable with Notepad++ versions prior to v7.6 since the location where plugins have to be installed has been changed in this version.

    N++ should be able to manage both 32and 64b pluggins and probably also local and user plugin folder

    I’m afraid that you will never get this features. I would appreciate them too but @donho , the developer of Notepad++, has decided to simplify things and to reduce the number of installation variants.



  • Same issue as @gurikbal singh mentioned. Plugins Admin is not visible anywhere either.
    Also if I copy all plugins to the LOCALDATA location, it does not help at all.
    I had to go back to 7.5.9 and restore the shortcut for my specific command that used a plugin.
    I am on Windows 10



  • @Meta-Chuh said:

    @Max-Brante

    they don’t get ignored, but most of us are already tired of repeatedly posting the steps and reasons again and again

    Sorry, I was a bit frustrated not being able to use a tool that I really like when I was not able to manage my plugins…

    But , anyway thanks for the answers, I got it working at last.



  • Hi @donho,

    Thank you for NPP.
    After I moved to NPP 7.6 and New Plugins Admin, some how I had JSON Viewer 1.24 and JSON Viewer 1.32 together.

    In new Plugins Admin, I selected the v1.24 and clicked on Remove button.
    Strangely Plugins Admin wiped out the plugins folder.

    Thanks to I was working in a virtual machince I was able to roll back to a snapshot.
    In case you can’t reproduce the issue I have a copy of the plugins folder.

    kind regards
    Gökalp



  • Here’s a powershell module to help with the update of the plugins:

    https://www.powershellgallery.com/packages/IIT.UpdateNppPlugins/1.0

    all it takes is a plugin folder and the rest will be done automatically

    install:

    open powershell window
    Install-Module -Name IIT.UpdateNppPlugins

    run:
    Update-NppPlugins -Path “C:\Program Files (x86)\Notepad++\Plugins”

    in fact the path can be any path, a ProgramData or any other custom installation path.



  • @Andrej-Ličar said:

    Here’s a powershell module to help with the update of the plugins:

    https://www.powershellgallery.com/packages/IIT.UpdateNppPlugins/1.0

    Does it work with Notepad++ v7.6 or v7.6.2 ?
    For v7.6.2, please check https://notepad-plus-plus.org/community/topic/16645/new-plugins-home-where-notepad-will-load-from



  • After installing the 7.6.x version over the old previuos one, I had to create a folder for each plugin file and put each one into its specific folder



  • @donho I greet you!
    Is it possible to make the preview window of installed plugins not a hard size, inconvenient viewing of a window … as was done in the old plugin manager.
    Imgur



  • I found a fix, at least for my PC. On a Win7x64 system using 32-bit N++, I had the same problem with every post-7.6 version I had installed. None of them ever had the Plugins install correctly. I got it working, finally, with 7.8.9, but it’s likely the same issue as prior versions. I’m replying to this because it seems to have the most information/discussion.

    The problem was that the GUP.exe file in the notepad++/updater/ folder wasn’t ever starting. I watched my Task Manager and checked windows error logs… it never started. So I had a hunch, anc ran the GUP.exe program directly, and Windows popped up its UAC nag window ('Open File - Security Warning). I unchecked “Always ask before opening this file” to clear it with the UAC, clicked ‘Run’, and it showed the standard Notepad++ Available Update message. I clicked ‘no’.

    I then re-opened Notepad++, used the Plugins Admin to install a plugin, and it WORKED. Hopefully this will help others with the same problem, which was (for clarity) that selecting to install a plugin through the ‘Plugins Admin’, click ‘Yes’ to restart, and NPP closes but never re-opens on its own. When opened manually, nothing was installed.


Log in to reply