XML tools



  • Running Notepad++ v7.7.1 (64-bit) I used the plugin manager to download the Xml Tools and the full menu comes up but the Tag auto-close fails to work. I have tried numerous of the ‘fixes’ to no avail.



  • @Lyle-Anderson

    looks like it suffers from the same issues other 64bit plugins do, namely, using
    the outdated notification structure.
    Fastest workaround, use a 32bit npp together with xml tools.
    (Portable aka zipped version can run together with an installed version)
    Report an issue here.



  • @Meta-Chuh said in XML tools:

    thanks @Gabriel-Poulin for reporting back.
    we’re glad to hear that you got it running with a manual install. 👍

    It could be because I am on a corp latop behind a corp firewall too?

    o.m.g… yes, i am so sorry, this time i completely forgot to ask if you are behind a corporate proxy or firewall. 😳 my sincere apologies.

    if you are behind a proxy, you can set it at the notepad++ menu ? > set updater proxy as seen at the screenshot below, as long as you know the proxy server address and port.

    note: usually you can find the proxy settings at the connection settings of your browser.

    Imgur

    enter your company’s proxy server ip address and port number here as seen at the next screenshot.
    (note: do not use the example ip and port, they will not work, except if your company uses the same values by coincidence)

    Imgur

    note: currently notepad++ does not support proxy authentication (user name and password), so it will not work, if your corporate proxy/firewall needs user credentials.

    " if you are behind a proxy, you can set it at the notepad++ menu ? > set updater proxy as seen at the screenshot below, as long as you know the proxy server address and port."

    I never would have noticed the ? menu… it was staring me right in the face. BAM now I can install stuff over the proxy. +1 from the graveyard of a year old post.



  • @Chris-Werner

    An important addition to your information is that you’d want to do this (adjust Proxy Settings) while running Notepad++ in Administrator mode.



  • I think this Community web site is still somewhat buggy. The posting of mine immediately above has been upvoted by @Meta-Chuh roughly 5 minutes ago, but the member page shows that he hasn’t been logged on for many months (and we miss you Meta!):

    b78636c9-50dd-4c7c-a522-53c1a93679ce-image.png



  • @Alan-Kilborn thanks, miss you too guys.

    just want you to know that my absence has nothing to do with the project or any people involved, but is purely health and personal changes related, but it’s nothing life threatening.
    still can’t tell when i will be back, but i’ll try to stop by every now and then.

    ps: the bbs works as expected, i’ve just updated my logon status now 😉
    (if a user is set to invisible, the online status will not change, but only show the last date he was set to online or anything else)

    big hug to everyone and hopefully until soon.



  • There are of course more important things than hanging around
    in a support forum, such as health.
    Get well soon and see you soon, hopefully. :)



  • @Meta-Chuh

    Really nice to hear you here!
    Hope to hear you more here again.

    Take care.



  • Hi, notepad++ appears to be very slow during typing in (pretty large) text-files. I am used to have some logfiles where I write my daily tasks, comments, etc. This logfile can grow, e.g. 6000 lines, 2KB filesize).
    In previous versions of notepad++ I did not experience this problem. In very small files this problem does not appear. However, in my opinion, a file of 2KB is still not very large …

    The performance issue appears to be due to the plugins. After removing and reinstalling the plugings, the slowness reappears after installing the XmlTools plugin (version 3.0.3.3).



  • @Arie-Verhoeven said in XML tools:

    slowness reappears after installing the XmlTools plugin (version 3.0.3.3).

    This is a known issue and fixed.

    Note, you’ll need to install the latest version manually instead of with Plugin Admin.

    Cheers.


Log in to reply