Notepad++ 7.7 Release

  • @makiimai said:

    I couldn’t find answer if I can run c in off-line environment

    You could have tried asking in Help Wanted, we would have asked for clarification, and then probably would have eventually helped you find a way to run the c compiler from Notepad++

    please remove me from community here.

    If that’s what you desire, you can go to your own profile, click Edit, and click Delete Account.

  • @Leandro-Lopez

    Dude, why are you posting a question about a plugin in a release announcement thread? Please try the Help Wanted section.

  • There is an issue in this release with some hidden characters being added when editing and saving PowerShell scripts. So when you launch a PowerShell script that has been edited with NPP, you get lots of weird syntax errors although the code is all fine. If you edit the same block of code in PowerShell ISE or Notepad, PowerShell won’t throw any errors when launched. It’s easy to reproduce. Copy the function below (function extracted from and save it in NPP, you will get weird syntax errors running it in PowerShell although there are none. Do the same with either Notepad or the PowerShell ISE and no errors appear when you execute this same code in PowerShell.

    ###########BEGINNING OF CODE BELOW#################

    Function Update-ManagedDevices()
    This function is used to add a device compliance policy using the Graph API REST interface
    The function connects to the Graph API Interface and adds a device compliance policy
    Update-ManagedDevices -JSON $JSON
    Adds an Android device compliance policy in Intune
    NAME: Update-ManagedDevices

    $graphApiVersion = "beta"
    $Resource = "deviceManagement/managedDevices('$id')"
    try {
    	If ($ScopeTags -eq "" -or $ScopeTags -eq $null)
    		$JSON = @"
    				"roleScopeTagIds": []


    		$object = New-Object –TypeName PSObject
    		$object | Add-Member -MemberType NoteProperty -Name 'roleScopeTagIds' -Value @($ScopeTags)
    		$JSON = $object | ConvertTo-Json
    	$uri = "$graphApiVersion/$($Resource)"
    	Invoke-RestMethod -Uri $uri -Headers $authToken -Method Patch -Body $JSON -ContentType "application/json"
    	Start-Sleep -Milliseconds 100
    catch {
    	$ex = $_.Exception
    	$errorResponse = $ex.Response.GetResponseStream()
    	$reader = New-Object System.IO.StreamReader($errorResponse)
    	$reader.BaseStream.Position = 0
    	$responseBody = $reader.ReadToEnd()
    	Write-Host "Response content:`n$responseBody" -foregroundcolor "Red"
    	Write-Error "Request to $Uri failed with HTTP Status $($ex.Response.StatusCode) $($ex.Response.StatusDescription)"

    ###########END OF CODE ABOVE#################

    Could you please look into this and resolve this issue please? I think it’s got something to do with the JSON "@ string terminator and I suspect NPP is actually adding some hidden character before this string terminator which PowerShell doesn’t like and consequently breaks the whole syntax of the script.

    For instance, if you save this code with NPP, it won’t work in PowerShell. If you open this NPP saved file afterwards in Notepad, make no modification to it and save it, it will work just fine.

    Thanks very much in advance for resolving this real nasty issue!


  • Sorry, I forgot to mention (I had to wait for 1200 seconds to add this…) that it is not an encoding issue as I checked and weither you save it in ANSI or UTF-8 it makes no difference in the behaviour.

    Thanks once more for your help.


  • @Faceless-YouTuber New message you can do immediately without waiting 1200 seconds

  • Notepad++ 7.7 broken syntax highlighting (in my case ASP)
    open ASP file and background is white, the text is black for everything. I do see brace matching highlights but no other.

    rollback to 7.6 fixes it.

  • This post is deleted!

  • The right-click context menu “Plugin commands | Copy Text with Syntax Highlighting” is no longer copying the formatting. In some cases it is copying the font but never the colors.

    I rely on this feature to copy code snippets and paste them into OneNote or an Outlook email with their formatting.

    Example Image

  • After update to Notepad++ 7.7 DSpellCheck stopped to work correctly. Now it finds and marks spelling error only for lines that are visible on screen after loading a file. After scrolling the text spelling errors in all the rest of file are not marked – regardless of whether the automatic spelling check is selected or not.

  • @Artur-Krukowski Install the latest DSpellCheck plugin … manually!

  • After being constantly nagged to upgrade to this new v7.7 release I had to find out I’d better stayed with the old (I guess it was v7.5 but not sure) version.

    What happens now is someting I experienced long ago after upgrading (I don’t recall how I got rid of the bug that I’ll describe)

    After having installed v7.7 I get this repetingly and it keeps poping op. I always hit No and another popup shows. It doesn’t end.




    Now I let all my txt files open by “get diz”

    What is happening. And why does this always happen after an upgrade ?

    To translate it in English it says the file *.txt file is modified by another program, and do you want to reload it and loose the changes that have been made in Notepad++ ?

    Of course I click NO each time.

  • Had to edit within 180 seconds (???): failed of course …

    so here the refreshed/clickable links of above

  • Upon updating from 7.5? to 7.7, All my plugins are gone from the menus but the DLLs are still there. I’ve debated a reinstall.

  • @Krystal-Owen

    since npp 7.6, the plugin structure has changed.
    In addition, 7.7 introduced a new scintilla version which might break plugin functionality.
    Probably the easiest way to get your plugins back is to use the new plugin admin tool. The plugins manager is deprecated. If you have an issue with a particular plugin, let us know which one it is and we can see if there is a way to make it work again.

  • Fact is and remains that my issue from a post or 3 above is a not admissable at all because I just can’t open the Notepad v7.7++ anymore. I just saw in another forum someone giving an advice to up upgrade from a default Windows notepad to this one. Maybe they should first check this website. Another thing that’s still not solved after 3 years is that my Notepad++ (all versions before v7.5 that is), need something like 10 seconds and more, to open… It has been discussed here (not in this thread), no solution was found. All some people’s good advice here is to upgrade to the latest version. LOL.

  • @Guido-DC

    Another thing that’s still not solved after 3 years is that my Notepad++ need something like 10 seconds and more, to open …

    Can you point me to the issue you’d reported? Hoping that there is more info than just
    it takes …

    It has been discussed here …

    if you have an old version, then it makes sense to try a newer version to see if the issue is gone or not. Most of the time it is recommended to use the portable version instead of upgrading an installed one, which, from my point of view, makes absolutely sense. Don’t you agree?

  • I’ll agree with you al the way since you’ve replied. But “sometimes” it’s better to stay with an old version. There’s this verb: don’t touch a running system (aside from the time lag of 10 sec’s before it opened). Now my old version before upgrading to this v7.7 that simply doesn’t open and always keeps asking me “**.txt file is modified by another program, and do you want to reload it and loose the changes that have been made in Notepad++*” was v7.5.6.

    Now come to think of it: like I said after I installed v7.7 I got this repeating bug

    and couldn’t open the program but what’s worse I could not see if the prgram I installed was v7.7.
    I then looked for a restore point of some hours ago and applied it. The bug was still there so I also could not see if I reverted to the old v7.5. I assumed that the program did not revert to v7.5 since the bug was still there (FYI that bug was not present b4 my upgrade (v7.5 > v7.7).

    To my big surprise I just checked the notepad executable (details from *.exe) in my W7 program files (x86) folder and it is v7.56. So with the restore point I effectively reverted to the old v7.5 but I got the bugs that came along with v7.7 as a present.

    The thing of the time delay will have to wait a while. First I’d like this v7.7 to work for me. Will completely uninstalling it remove my settings ? And why is it still installed in the program files folder (x86) ?

    Thank you in advance.

Log in to reply