Notepad++ 7.7.1 Release

  • @MichielOverweel
    It always works for me!
    I can run any installer from the command line!

  • @MichielOverweel If this is a big problem for you, then use this utility:
    She can install the installer in stealth mode, and show the keys for a silent installation.

  • The menu command Edit->Line Operations->Sort Lines as Integers Ascending broke in this 7.7.1 (64-bit) release. I.e., it does attempt to sort the lines, but the ordering is off. I can’t figure out exactly what ordering it is applying, but while ordered in some fashion, it’s clearly not correct.

    It was working in 7.7, and when I reverted to 7.7 from 7.7.1, it began working again. So it’s definitely a regression in 7.7.1. I can provide a longish (140KB) file containing a list of IP addresses that reproduces the issue, if necessary.

    Thank you.

  • @sarcanon

    Commit has been already made.

  • @MichielOverweel said:

    @andrecool-68 I’m using the installer that’s available for download (npp.7.7.1.Installer.x64.exe). When I start that one with the “/s” switch, the installation runs interactively instead of silently. This used to work up to version 7.7.

    @MichielOverweel, you need to use /S instead of /s flag for silent mode installation. Mind capital S here.

  • @SinghRajenM That did the trick. Thanks!

  • @MichielOverweel said:

    @SinghRajenM That did the trick. Thanks!

    @MichielOverweel , Thank you! Glad to know that it helped you. Just for your reference, actually it is not a trick, but nsis installer design behavior.

    From Nsis developer reference doc
    There are several methods to make an installer or an uninstaller silent:

    1. SilentInstall and SilentUninstall
    2. SetSilent
    3. Passing /S on the command line (case sensitive)

    However, (from developer perspective) there are ways to make /S flag case insensitive (e.g. parse command line parameters and take care of /S or /s). Even in most of commercial s/w (at least which I developed or worked upon), command line flag is case insensitive.

    Once I get time, I will try to create a PR to make command line flag is case insensitive. Hope that may come in next release, if @donho likes.

  • @SinghRajenM said:

    Once I get time, I will try to create a PR to make command line flag is case insensitive. Hope that may come in next release, if @donho likes.

    I’ve deployed many Notepad++ versions using the “/s” (lower case) switch without issues. I understand that the switch is supposed to be “/S” (upper case) and that this is by design, but up until version 7.7.1, it has always worked using the lower case switch, so I still feel that something has changed in this version. Anyway, I’m happy to use the upper case switch from now on.

  • @Michael-Vincent that fixed it, thx for the info!

  • Help! Does anyone know how to restore lost Notepad ++ files erro " null null null " … My computer has been left from charge and the file was erro. I dont see any thing on backup file folder and how to restore the file ?

  • @Hùng-Kin said:

    Notepad ++ files erro " null null null "

    I’m sorry for your loss.

    This is much less common with recent versions. Are you using Notepad++ v7.7.1 (the newest version)? If so, then the bug needs to be reported and investigated here. If not, see the “advice” section, below

    debugging issue

    If you are using v7.7.1, please confirm this by going to the ? menu, selecting Debug Info and Copy debug info into clipboard and paste it here.

    otherwise, it’s not a problem with v7.7.1, and you should follow the advice below and possibly open a new thread in Help Wanted section if you think your circumstances are different than mentioned below and in linked files


    Advice for recovering files has been given lots of times in this forum, including Search for “null crash” using the forum search to find others. The usual locations for backups are %appdata%\notepad++\backup, which will only be populated if you had enabled **Settings > Preferences > Backup > ** ☐ Enable session snapshot and periodic backup and if the crash occurred when the data had not been saved to disk. If you enabled ☐ Simple or ☐ Verbose in Settings > Preferences > Backup >, it will be either as .bak in the file’s current directory, or .\nppBackup\___.bak, or in whatever directory you defined as the custom backup directory. If you did not have backup-on-save enabled already, or if you didn’t have periodic-backup enabled on an unsaved file, nothing you can do now will fix that. There are file recovery utilities that exist, which can be found in other threads by searching.

  • @donho Something is not working on your website. When I try to download any version of NPP(exe, 7z or zip) it just tells me that there was an error “Error 503 Backend fetch failed”. Forcing update also doesn’t work.

  • @andrecool-68 said:

    Such as?

  • @David-Dawes Sorry. Regarding HexEditor being a toy. What do you use?

  • @Meta-Chuh I have the same problem with the plugins. I cannot re-install the plugins because the plugin manager is gone too. My plugins are located in the Notepad++\plugins folder, not in separate directories.
    I’ll try reinstalling and let you know if that works.

  • @jim-software said:

    I cannot re-install the plugins because the plugin manager is gone too.

    Plugin Manager is gone because it is not compatible with v7.6 or newer. Use the Plugins Admin, the new official built-in method of installing plugins, below the line in the Plugins menu, near the bottom.

    My plugins are located in the Notepad++\plugins folder, not in separate directories.

    Then they won’t work in Notepad++ v7.7.1. You either need to create the separate subfolders yourself and move the DLLs into those folders, or you need to use the Plugins Admin to install the plugins again.

    I’ll try reinstalling and let you know if that works.

    Installing Notepad++ again won’t move your plugins for you. See my second sentence in my previous paragraph.

  • @PeterJones Thanks. I should have taken a screenshot because now I cannot remember if the Plugins Admin was there and I missed it or (as I believe) it was not there (probably just me not looking tho).
    I uninstalled and said yes to delete my settings. Then, I reinstalled notepad++.
    Now, I can plainly see the Plugins Admin.
    I’ve reinstalled my plugins and all seems to be well.
    Thanks for the help.

  • When loading even small (5k) GEDCOM (*.ged) files, progress is extremely slow, an hourglass may be displayed and a “Not Responding” message appears in the Npp title bar. This behavior was first observed in version 7.7 but was never seen in 7.6.6 and earlier versions of Npp. In 7.6.6. and earlier versions, even several megabyte files loaded without noticeable delay.

    Syntax highlighting for GEDCOM files depends upon the gedcomlexer plugin. The same version of the plugin was used for these tests with Npp 7.6.6, 7.7 and 7.7.1.

    Is this an issue for Notepad++ or the plugin?

    My configuration follows …
    Notepad++ v7.7.1 (32-bit)
    Build time : Jun 16 2019 - 21:14:50
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : gedcomlexer.dll mimeTools.dll NppConverter.dll NppExport.dll

  • @Stan-Mitchell130 said:

    gedcomlexer plugin

    I do not know the details of that plugin. However, there was a change in the underlying scintilla (which is what the lexers interact with) between v7.6.6 and v7.7: scintilla was updated from v3.56 to v4.14; this changed how some plugins and lexers interact with scintilla, though I hadn’t heard of any that just slowed down signficantly. It may be that the gedcomlexer.dll will need to be updated to be more fully-compatible with scintilla v4.14. You should probably contact the maintainer of gedcomlexer.dll and see if they think their DLL needs upgrading to work with Notepad++ v7.7 / Scintilla v4.14 and beyond.

Log in to reply