Notepad++ 7.7.1 Release





  • @Meta-Chuh I have the same problem with the plugins. I cannot re-install the plugins because the plugin manager is gone too. My plugins are located in the Notepad++\plugins folder, not in separate directories.
    I’ll try reinstalling and let you know if that works.



  • @jim-software said:

    I cannot re-install the plugins because the plugin manager is gone too.

    Plugin Manager is gone because it is not compatible with v7.6 or newer. Use the Plugins Admin, the new official built-in method of installing plugins, below the line in the Plugins menu, near the bottom.

    My plugins are located in the Notepad++\plugins folder, not in separate directories.

    Then they won’t work in Notepad++ v7.7.1. You either need to create the separate subfolders yourself and move the DLLs into those folders, or you need to use the Plugins Admin to install the plugins again.

    I’ll try reinstalling and let you know if that works.

    Installing Notepad++ again won’t move your plugins for you. See my second sentence in my previous paragraph.



  • @PeterJones Thanks. I should have taken a screenshot because now I cannot remember if the Plugins Admin was there and I missed it or (as I believe) it was not there (probably just me not looking tho).
    I uninstalled and said yes to delete my settings. Then, I reinstalled notepad++.
    Now, I can plainly see the Plugins Admin.
    I’ve reinstalled my plugins and all seems to be well.
    Thanks for the help.



  • When loading even small (5k) GEDCOM (*.ged) files, progress is extremely slow, an hourglass may be displayed and a “Not Responding” message appears in the Npp title bar. This behavior was first observed in version 7.7 but was never seen in 7.6.6 and earlier versions of Npp. In 7.6.6. and earlier versions, even several megabyte files loaded without noticeable delay.

    Syntax highlighting for GEDCOM files depends upon the gedcomlexer plugin. The same version of the plugin was used for these tests with Npp 7.6.6, 7.7 and 7.7.1.

    Is this an issue for Notepad++ or the plugin?

    My configuration follows …
    Notepad++ v7.7.1 (32-bit)
    Build time : Jun 16 2019 - 21:14:50
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : gedcomlexer.dll mimeTools.dll NppConverter.dll NppExport.dll



  • @Stan-Mitchell130 said:

    gedcomlexer plugin

    I do not know the details of that plugin. However, there was a change in the underlying scintilla (which is what the lexers interact with) between v7.6.6 and v7.7: scintilla was updated from v3.56 to v4.14; this changed how some plugins and lexers interact with scintilla, though I hadn’t heard of any that just slowed down signficantly. It may be that the gedcomlexer.dll will need to be updated to be more fully-compatible with scintilla v4.14. You should probably contact the maintainer of gedcomlexer.dll and see if they think their DLL needs upgrading to work with Notepad++ v7.7 / Scintilla v4.14 and beyond.



  • You should probably contact the maintainer of gedcomlexer.dll and see if they think their DLL needs upgrading to work with Notepad++ v7.7 / Scintilla v4.14 and beyond.

    Thanks Peter for your explanation. Unfortunately, it is the response I expected. Since I am the maintainer of the plugin, it looks like I have some work to do :)



  • @Stan-Mitchell130 said:

    Since I am the maintainer of the plugin, it looks like I have some work to do

    Awesome! Not that you have to do extra work, but that you’re still maintaining your plugins. I see it available in the old Plugin Manager, but not the new Plugin Admin and I only see a 32-bit version. Is this it?:

    https://sourceforge.net/projects/gedcomlexer/files/GedcomLexer-0.3.3-r100/

    While you’re making improvements / updates, If you can:

    • make it 64-bit compatible and provide a VS Studio solution for both 32-bit (which you already have as Release|x86) and add 64-bit (Release|x64)
    • package it for Plugin Admin


  • Awesome! Not that you have to do extra work, but that you’re still maintaining your plugins.

    Hi, Michael. Yes, you have found the current gedcomlexer plugin - 32-bit only.

    The last maintenance was in January 2017, so it will be a bit painful to get back up to speed with the code. Back then, I had made a ticket to remind me to release an x64 version. At that time the Npp Plugin Manager was in a state of flux, so it never got done, but I’ll include that now.

    I’ve noticed that Npp occasionally adds languages from the Scintilla project, from SciLexer.dll. If I submit this lexer to the Scintilla project, would Npp add it as an internal language fairly soon?



  • @Stan-Mitchell130 said:

    f I submit this lexer to the Scintilla project, would Npp add it as an internal language fairly soon?

    Unfortunately, not unless your definition of “fairly soon” is “within the next 2-5 years”, which was the approximate gap before the most-recent major Scintilla upgrade. Now that it’s back in modern scintilla, it should be easier to upgrade Scintilla more regularly (assuming they do mostly bug fixes, and not major feature-suite changes), but it’s not guaranteed that the development team will stay on top of that.

    There’s still no good reason to not submit your lexer to Scintilla, once you get it compatible with modern Scintilla.



  • @PeterJones

    Isn’t the very next Notepad++ release going to bump Scintilla to 4.20 from 4.15 (take my numbers with a grain of salt as they are off the top of my head without any checking)? [So, maybe no reason to be Scintilla-pessimistic just because the recent-to-mid history of Notepad++ had it going a long time without this type of upgrade] ;)



  • @Alan-Kilborn said:

    sn’t the very next Notepad++ release going to bump Scintilla

    I don’t follow the commit progress in the NPP code repo, so I wouldn’t know. But if it does, that’s quite promising, especially if they keep on updating Scintilla with most NPP releases.



  • Function list for perl (.pl and .pm files) does not work in 7.7.1 release



  • @Gabor-Kanizsai said:

    Function list for perl (.pl and .pm files) does not work in 7.7.1 release

    It works for me. Maybe start a new topic (*) in the Help Wanted, providing example code (++) (embedded, so we can easily copy/paste) and a screenshot showing it not working – along with an explanation of what in the screenshot isn’t working. With some back and forth, we may be able to help you get it working…

    *: I suggest in a new topic, because I think there will be quite a few rounds back and forth between us, and don’t want to clutter this thread with a more-involved debug/help session

    ++: if you need help with Markdown in this forum, so that your example text and screenshots render correctly, please see @Scott-Sumner’s post in the “how to markdown code on this forum” topic, and my updates near the end, which will show how to embed example text, and how to embed pictures.



  • Hi,

    If I have unsaved documents open and try to shut down Windows, it takes too long to do it, or simply crashes with ntoskrnl blue screen. When I get back to Windows, backup files of those unsaved documents are corrupted beyond repair.

    I’ve just lost one-year work in other program happened to be running when the crash took place, supposedly because of this behavior.

    I’m using Notepad++ 7.7.1 64-bit on Windows 8.1.

    Sorry if this kind of bug already asked before (but after searching for a while I didn’t think there was anything similar). Sorry for my English.


Log in to reply