Notepad++ community on nodebb.org



  • I restored the redirection, please let me know if all work as expected.

    RewriteEngine On
    RewriteBase /
    Redirect 301 /community https://community.notepad-plus-plus.org
    RedirectMatch 301 ^/community/(.*)$ https://community.notepad-plus-plus.org/$1
    
    


  • @donho

    if all work as expected.

    So far, so good. Following an old link into the old forum URL will redirect to the new; and I was able to follow the download links on the main site. So, at least for me, it’s working.



  • It seems that the forum is very slow now, especially when fetching unread posts. Is it a bad feeling or a reality ?
    Is it a configuration issue ? Is it a memory leak issue ?

    Cheers



  • @cmeriaux

    No, it’s not a bad feeling, I’m facing the same problem. For example, upvoting your post took 5 seconds until the upvote count has been incremented to 1.

    See also this thread.



  • @dinkumoil @cmeriaux
    It depends. Sometimes it’s faster. But indeed, it’s very slow sometimes !
    I hope it’s temporary. Please let me know if such situation lasts.
    I will ask nodebb.org team for improving it.



  • @donho said in Notepad++ community on nodebb.org:

    if such situation lasts.

    24+ hours later, It’s still occurring. Sometimes, as @dinkumoil said in the other thread, the page auto-reloads while it’s having the issue. And, even worse for me, sometimes when it reloads, it switches to a different page, rather than the last one I was on! (In fact, while writing this post, behind the editing window, it switched from the topic I was responding to back to the unread posts page that I had come from.

    edit fortunately, when I hit submit, it posted to the right topic. I wasn’t sure if it would or not.



  • I’m not ready to say it’s solved, but this morning, I haven’t noticed a large lag or any of the connection-dropped messages. This is making me hopeful. :-)



  • @donho

    Still facing performance issues. A few minutes ago I even had to re-login after a “Connection lost” message appeared.



  • OK, I will ask nodebb.org team for checking it.



  • @donho

    Since this morning I can see that my online status (the dot in my avatar icon displayed besides my comments) is green even when I’m logged out. That means the system considers me to be logged in though the toolbar in the upper right corner shows “Log in” instead of my avatar icon and I can not comment.

    When loggin in or out I get constantly the “connection lost” messages, sometimes the site reloads automatically.

    This new forum software seems to be very buggy. :-(



  • Just get the reply from nodebb.og team:

    Last week, we added some nginx rate limiting to resolve the issues with performance it seems those rules were too strict and was causing real users to experience slow downs. 
    
    I have changed those settings, let me know if you still notice lag when switching pages. 
    

    It seems the problem has been solved!
    \o/



  • @donho

    Yeah, click response is much faster now!

    The only disadvantage of the new forum is that the browser needs to send the referrer in order to allow the forum to work correctly. Since this is a global setting I have to turn it on all the time.


Log in to reply