Notepad++ 7.8 Release



  • @donho

    I suppose everyone has features in mind that they consider important. How come you glossed over this one (apparently from Middle-Earth) that might be more important to a quantity of users than some obscure command-line parameter:

    @Bilbo47 said in Notepad++ 7.8 Release:

    “3. Add “No to all” and “Yes to all” options in Save dialog.”
    Regression: The Yes/No/Cancel buttons used to have hotkeys so that single keystrokes could give a command on how to proceed. In 7.8, “Y” and “N” are ignored, while “Escape” still works. This is a showstopper for me; back to 7.7 for that basic usability feature. Also for standard usability, the new “All” buttons need to have their own hotkeys.


  • Banned

    @donho
    The global bold thing is a bug. Just check it yourself . . .



  • @Zsolt-Kántor

    I was under the impression that you have to tick Bold from Font Style as well
    if you want to enable the global bold font style.
    Am I wrong?


  • Banned

    @Ekopalypse said in Notepad++ 7.8 Release:

    @Zsolt-Kántor

    I was under the impression that you have to tick Bold from Font Style as well
    if you want to enable the global bold font style.
    Am I wrong?

    That’s right. But the problem is different. If Bold and Enable global bold font style are not checked - this is the default setting, right?, some but not all characters and words are thicker, as bold would be selected, but actually bold is not selected. The first screenshot demonstrates this.

    Just watch carefully the first screenshot, watch the case keyword, and the punctuation marks like dots, semicolons and commas.

    Now keep watching those elements. Make sure the Bold box is checked and check the Enable global bold font style box. You will observe that those elements will be thinner. My question: why are they turning thinner (by the way they should turn thicker in the worst case - but that’s another problem) when the global Bold box is not checked?? IMHO if the global Bold box is not checked nothing should be changing visually if you toggle the Enable global bold font style box.


  • Banned

    P.S. instead of: Make sure the Bold box is checked
    my intention was to write: Make sure the Bold box is not checked

    sorry!



  • @Zsolt-Kántor said in Notepad++ 7.8 Release:

    My question: why are they turning thinner

    Because you told it to. Those letters started bold (because that was the syntax highlighting for case statements), and you set it to override any bold settings with bold=false; so it did; case would normally be bold, so it turned bold off.



  • @Zsolt-Kántor

    That’s right. But the problem is different.

    Ah, ok, sorry for confusion, I guess @PeterJones said it right.

    To summarize my understanding:
    If both, Bold and Enable global bold font style are unchecked then
    the styling settings from the language are used.

    If both, Bold and Enable global bold font style are checked then
    everything will be bold.

    If Bold is unchecked but Enable global bold font style is checked then
    everything will NOT be bold.


  • Banned

    @PeterJones @Ekopalypse
    Yes, both of you are right. Sorry for the misleading posts.
    I checked and found that (at least with C) syntax highlight makes the keywords and other punctuation marks Bold by default.



  • @donho said in Notepad++ 7.8 Release:

    @tomasz1986 @patrickdrd

    I’ll make it optional in the future release.

    I just downgraded from 7.8 to 7.7.1 after reading this. When you do implement this option, please let me know so that I’ll know to update.





  • @SinghRajenM I noticed the same issue today, but at first I thought it had to do with my homebrew MSI installer. I created my own debugger redirect a while ago when Notepad++ didn’t have the ability to do that. If it helps… source code and binaries are available if anybody is interested.



  • @Bilbo47 said in Notepad++ 7.8 Release:

    “3. Add “No to all” and “Yes to all” options in Save dialog.”

    Regression: The Yes/No/Cancel buttons used to have hotkeys so that single keystrokes could give a command on how to proceed. In 7.8, “Y” and “N” are ignored, while “Escape” still works. This is a showstopper for me; back to 7.7 for that basic usability feature. Also for standard usability, the new “All” buttons need to have their own hotkeys.

    It appears the new “X to all” buttons are available only after the “Close All” command; in case of the “Close” command, they are greyed out. User interface principles say that buttons that are never available in certain circumstances should not even be visible in those circumstances. If “Close” and “Close All” are going to be two separate commands, then the corresponding dialog functionality/discoverability should also be different. If “X to all” is going to be not-available after “Close” then the “All” buttons should be not-visible after “Close”. Or, if “X to all” is going to be available after “Close” then “Close All” should not be a separate command. In short, the decision of all-versus-one should be made only once, or should be made available as often as possible. But showing that different functionality is available only if User backs up and starts over, that’s just maddening.

    From experience, custom buttons can be added to the Windows-standard Common Dialogs instead of writing custom dialogs; it just takes some more subclassing and API work to do so.

    Agree with Bilbo47. Need the keyboard hotkeys back on the save and close dialogs. I did not realize how frequently I used them until now.

    LOVE having the options of Yes to All (which I believe the standard hotkey on that is A) and No to All, though! Was very excited to see that when I am closing a large number of files that I do NOT wish to save, I no longer have to hold down the “N” key until they all close!

    Thanks!!!



  • Syntax highlighting on SQL files has a small glitch. This problem existed in the previous version of notepad++:

    243aea7c-97e0-4c3c-b355-105d223cb24c-image.png

    All lines after “set column” appear with string colours. It appears the 2nd ’ character is not being correctly interpreted.



  • @TrueVulgarian

    the backslash escapes the second quote.
    To disable this behavior go to
    settings->preferences->Language and uncheck
    treat backslash as escape …

    a4697de9-34f4-4ce1-a535-4e2423fc64bf-image.png



    • since 7.8.0, text direction only flip the scroll-bar. npp is now useless for rtl texts.
    • I’ve found no related issue on npp’s github or scintilla bug tracker.
    • and almost all rtl related issues are dismissed as scintilla’s.


  • @geminorum

    I tried version 7.8 and then some earlier versions, back into the 6.x area. I don’t see any difference in any of these; to me they all appear to do the same thing when RTL is selected. From you comment I was expecting some large difference when I compared 7.8 to an earlier version. But I see no such thing.

    So, can you elaborate on what exactly you think is wrong, by means of comparison of the errant RTL features in 7.8 with the apparently fine earlier version(s)?



  • @Alan-Kilborn said in Notepad++ 7.8 Release:

    So, can you elaborate on what exactly you think is wrong, by means of comparison of the errant RTL features in 7.8 with the apparently fine earlier version(s)?

    To help with that, I recommend sharing an example RTL file (not everyone has a valid RTL file laying around; I could try to create one, for example, but I’d have no idea if it was valid or not, and wouldn’t know how it “should” look vs how it “does” look). You could post a link to a pastebin or similar file-sharing site; or, if you wanted to be nice to those of us who have pastebin-like sites blocked for a significant portion of our waking day, you could open an RTL file in a version of Notepad++ that works right, Edit > Select All (often Ctrl+A), Plugins > MIME Tools > Base64 encode, and paste the file in your reply, select the base64, and hit the </> button to mark it as code/plaintext (to make sure nothing gets lost in transmission). For example

    SGVsbG8gV29ybGQ
    

    is derived from

    Hello World
    

    We can then get back your exact file by using the Base64 Decode operation.

    If you are using an encoding other than UTF-8, please let us know, so that we can set our Notepad++ copies the same way.

    Then, using that file, grab a screenshot under your previous Notepad++ version and under Notepad++ v7.8.0 (or v7.8.2, to prove that it hasn’t been fixed yet). It might help if your screenshot included the ?-menu Debug Info window, like
    432b8dc8-c4be-4988-b0ab-11692be6c7db-image.png

    Anyway, all of that to say, with Alan, that the more you give us, the easier it is for us to help you.



  • @PeterJones said in Notepad++ 7.8 Release:

    To help with that, I recommend sharing an example RTL file (not everyone has a valid RTL file laying around; I could try to create one, for example, but I’d have no idea if it was valid or not, and wouldn’t know how it “should” look vs how it “does” look). You could post a link to a pastebin or similar file-sharing site; or, if you wanted to be nice to those of us who have pastebin-like sites blocked for a significant portion of our waking day, you could open an RTL file in a version of Notepad++ that works right, Edit > Select All (often Ctrl+A), Plugins > MIME Tools > Base64 encode, and paste the file in your reply, select the base64, and hit the </> button to mark it as code/plaintext (to make sure nothing gets lost in transmission).

    rtl is not about encoding but rendering. it’s just some unicode strings that reads from the right of the screen.

    a poem in RTL screen layout (npp v7.7.1)
    notepad++_2019-12-11_01-15-06.png

    same in the default LTR layout (npp v7.8.2)
    notepad++_2019-12-11_01-12-56.png



  • @geminorum

    So we have:

    RTL screen layout (npp v7.7.1)

    which is presumably correct, and we have:

    default LTR layout (npp v7.8.2)

    which might be of questionable value since we are talking about RTL…

    But that’s it. If one uses 7.8.2 and enables RTL, will we see the reported bug?

    I’m AFK right now (at least my keyboard that types into N++), so I can’t try exactly that, but if that’s all you can give us in the way of an explanation, I’m out. I’m sure Peter will keep going, however. :-)



  • @Alan-Kilborn said in Notepad++ 7.8 Release:

    @geminorum

    I tried version 7.8 and then some earlier versions, back into the 6.x area. I don’t see any difference in any of these; to me they all appear to do the same thing when RTL is selected. From you comment I was expecting some large difference when I compared 7.8 to an earlier version. But I see no such thing.

    please just try this search.


Log in to reply