Notepad++ v7.8.5 released



  • This update breaks a lot of my macros. Here’s a typical one:

        <Macro name="Find Heading" Ctrl="no" Alt="yes" Shift="no" Key="72">
            <Action type="0" message="0" wParam="0" lParam="0" sParam="// ***** [Alt+H] ***** //" />
            <Action type="3" message="1700" wParam="0" lParam="0" sParam="// Find Heading//" />
            <Action type="3" message="1700" wParam="0" lParam="0" sParam="" />
            <Action type="3" message="1601" wParam="0" lParam="0" sParam="^(.+?)(`~Marker`-Heading~`)" />
            <Action type="3" message="1625" wParam="0" lParam="2" sParam="" />
            <Action type="3" message="1702" wParam="0" lParam="512" sParam="" />
            <Action type="3" message="1701" wParam="0" lParam="1723" sParam="" />
        </Macro>
    

    The error is: “Internal Error: Unknown caved command!”

    Reverting to 7.8.4 fixes the problem.



  • Hello, @stefan-travis and All,

    Stefan, really strange, your macro example !

    • First, you’re using the Alt + H shortcut for this macro. Normally, this shortcut is the default one, used by Notepad++, for hiding current or selected line(s) ( View > Hide lines menu option )

    • Secondly, you have two <Action> tags, with message 1700, which is used to initialize a search/replace operation !

    • Thirdly, the wParam attribute ( 1723 ), of <Action> tag, with message = 1701 is not a valid command number ! I suppose that its value should be 1, corresponding to a Find Next command

    Here is a summary of all the <Action> tags, of type = 3, which defined a search/replace operation, in the <Macros> section of shortcuts.xml

    04f88671-864b-4358-8957-ce51671e9704-image.png


    However, thanks to you, I’ve learned something new, today ;-)) We already know that XML comments, as <!-- Comments --> are not kept at end of the <Action> tags lines.

    But your special syntax <Action type="0" message="0" wParam="0" lParam="0" sParam="COMMENTS" /> seems to be kept, at any location, inside a <Macro> section of the shortcuts.xml configuration file


    Now, regarding the search regex, the parentheses, to define groups, seem useless as no replacement regex occurs and not-used in the search regex either ! So, its syntax could be changed as below :

    (?-s)^.+?`~Marker`-Heading~`

    Note that I added the (?-s) part, which forces the regex engine to consider that any dot . symbol matches a single standard character and not any EOL char


    Therefore, assuming that you deleted the default N++ shortcut Alt + H, there is, below, a correct macro code, which finds the next occurrence of the string `~Marker`-Heading~`, when using the Alt + H shortcut :

            <Macro name="Find Heading" Ctrl="no" Alt="yes" Shift="no" Key="72">
    
                <Action type="0" message="0" wParam="0" lParam="0" sParam="// [Alt+H] = Find Heading //" />
    
                <Action type="3" message="1700" wParam="0" lParam="0" sParam="" />
                <Action type="3" message="1601" wParam="0" lParam="0" sParam="^(?-s).+?`~Marker`-Heading~`" />
                <Action type="3" message="1625" wParam="0" lParam="2" sParam="" />
                <Action type="3" message="1702" wParam="0" lParam="512" sParam="" />
                <Action type="3" message="1701" wParam="0" lParam="1" sParam="" />
            </Macro>
    

    Best Regards,

    guy038

    P.S. :

    I realized my tests with the last v7.8.5 release. However, I confirm that your initial macro, although not correct in some points, does work, when using Notepad++ v7.8.4. Really weird !??

    Some hours later, I also confirm that my new syntax works nice with Notepad++ v7.8.4 !



  • @Stefan-Travis and @guy038

    This commit to the source code made it into version 7.8.5.

    Doing some research on it, it appears that Stefan’s macro must have been recorded using the two-button Find mode’s “downward Find Next” button. The solution is, as Guy said, to change the 1723 to 1.

    Deeper background:

    It appears that, with the introduction of two-button Find mode (back around version 7.5.0-ish), two new but totally unneeded (and indeed, confusing) new macro value commands (1723 and 1724) we introduced. 1723 was for 2-button-find-next and 1724 was for 2-button-find-previous.

    As macros already had direction control (via one of the 1702 messages bit-weightings, and there was already a FindNext (1701 command id = 1) that respected the direction control, nothing more was required.

    It appears from the research I did that the removal of this is part of some future feature of Notepad++?

    Anyway, anyone that recorded macros this way is going to have to rerecord them, or hand edit them to fix them. Here’s how this would be done:

    If the macro uses 1723 in the 1701 message: Change the 1723 to a 1 and make sure that the 1702 message contains a 512 bitweighting.

    If the macro uses 1724 in the 1701 message: Change the 1724 to a 1 and make sure that the 1702 message doesn’t contains a 512 bitweighting.

    For info on “bitweighting”, see Guy’s excellent documentation above.





  • @Alan-Kilborn

    Alan, you’re an idiot: Everywhere in your previous post where you typed 1724, you really meant 1721. That’s the proper id for “Find Previous”. (1724 is the id for the checkbox for two-button-find-mode). Arrrrgh!

    This is substantiated by the following from the source code’s FindReplaceDlg_rc.h file:

    #define IDC_FINDPREV 1721
    #define IDC_FINDNEXT 1723
    #define IDC_2_BUTTONS_MODE 1724
    


  • @Alan-Kilborn said in Notepad++ v7.8.5 released:

    Alan, you’re an idiot

    LOL!!! No you’re not, don’t be so hard on yourself.

    Cheers.



  • Hi all,

    I’ am getting next error in messagebox popup when i call npp with a session file in commandline.
    Note 1: Any file(s), except sessions, in commandline are loaded normally.
    Note 2: If a click OK on the error popup, then the session is loaded normally without any other errors.
    Note 3: DSpellCheck plugin working as expected, and the error appear not matter if the plugin is enabled or not at npp startup.

    npp 7.8.5 x32 portable (zip)
    DSpellCheck.dll plugin version 1.4.14.0 by Sergey Semushin ( https://github.com/Predelnik/DSpellCheck
    )
    Windows 10 pro x64 v1903


    Plugin Exception

    An exception occurred due to plugin: DSpellCheck.dll
    Exception reason: Access violation

    OK



  • I’ am very sorry for my previous post - please ignore it
    i installed the last version of DSpellCheck plugin 1.4.15.0 and there is NO ERROR any more (fixed)
    I’ am very sorry for my previous post - please ignore it

    Best Regards



  • @PeterJones
    With reference to the usermanual PR#75
    I haven’t the notepad++ icon in the “Volume Mixer”.
    I use n++ minimalist without installation.
    Do you think this is my problem?
    How can I do?



  • @ans_user said in Notepad++ v7.8.5 released:

    I haven’t the notepad++ icon in the “Volume Mixer”.

    I did some experimenting and found that you actually have to run an unsuccessful search (and thus force Notepad++ to make its sound) before it will appear in the “Volume Mixer”. At that point, if you mute Notepad++ in that little applet, it will forevermore be silent on failed searches. A bit strange, but it works, and Windows remembers the choice. Not sure what Windows uses to remember it, though…would one have to do this on any new Notepad++ release? I didn’t care enough to investigate that further. :-)


  • Banned

    This post is deleted!


  • @zh0so,

    Even an animal, which, at every moment, must fight to eat and not be eaten, would not have the indecency to say such things !

    In these exceptional times, when the Corrona virus is rampant all over the world, could you, at least once, make yourself useful, instead of wasting your time on such messages ?

    As for me, as a moderator, I am obliged to ban your account.

    guy038



  • @donho


    In the middle of the night that sound scares the hell out of us.
    BTW forcing to turn it off via the Volume Mixer settings of Windows as a workaround is not too professional way of solving it.



  • @Norbert-Kiss

    The sound has always been there for an unsuccessful search!



  • @Norbert-Kiss said in Notepad++ v7.8.5 released:

    BTW forcing to turn it off via the Volume Mixer settings of Windows as a workaround is not too professional way of solving it.

    Don’t believe there even WAS a way to turn it off before now.


Log in to reply