Notepad++ v7.9.3 Released

  • Notepad++ v7.9.3 Release

    Notepad++ v7.9.3 bug-fixes & enhancements:

    1. Discontinued support for Windows XP due to technical reasons. Notepad++ 7.9.2 is the last version to run on Windows XP. (Ref)
    2. Upgrade Notepad++ License: update GPL version from v2 to v3. (Fix #9425)
    3. Fix the regression of copying line data from search results. (Fix #9334)
    4. Fix “Print Line Number” preference is ignored for printing regression. (Fix #9379)
    5. Fix a regression in Chinese Simplified localization. (Fix #9329)
    6. Fix dockable panels not being displayed regression due to multi-instance mode activation. (Fix #9341 & #9363)
    7. Make split-lines feature work again with multi-edge rightmost specified edge. (Fix #8262)
    8. Enhance modern style file dialog for allowing UNIX style file path. (Fix #9374)
    9. Use the modern browse folder dialog to get folder path. (Fix #8513)
    10. Improve option for setting save dialog filter to All Types. (Fix #9325)
    11. Add ability to delete entries from combo box history in Find dialog with DELETE key. (Implement #9366)
    12. Fix lost session issue on Windows reboot/shutdown. (Fix #7839)
    13. Add “save Folder as Workspace in session” option in save session dialog. (Implement #9165)
    14. Make value dialog height accurate in any DPI. (Fix #8443)
    15. Fix issue that Switch-To-Panel keyboard shortcuts cannot be used in context menu. (Fix #9435)
    16. Fix a memory leak issue. (Ref)
    17. Fix blurry display problem on an extended monitor. (Fix #8115)
    18. Fix incompatible plugin not being deleted issue. (Fix #9377)
    19. Synchronize GUP localization file (if available) with Notepad++ in installer.
    20. Enhance “No update” dialog with the download page link in the Notepad++ updater.
    21. Fix NPPM_SETLINENUMBERWIDTHMODE API not working issue. (Fix #9338)

    Stay safe, stay home

  • NPP doesn’t run after I successfully installed npp.7.9.3.Installer.exe (32bit)

    Using Windows 10 x64 version 20H2

    There is a short time blue circle throbber when I start NPP, nothing more.
    For 4-5 seconds notepad++.exe appears in taskmanager, and then disappears.

    I tried to reinstall npp.7.9.2.Installer.exe, but I got the error

    Error opening file for writing error:

    C:\Program Files (x86)\Notepad++\plugins\NppExport\NppExport.dll

    Click Abort to stop installation,
    Retry to try again, or
    Ignore to skip this file

    Abort Retry Skip

    and similar errors for mimeTools, NppConverter, SciLexer plugins

    and for

    C:\Program Files (x86)\Notepad++\Notepad++.exe

    I ignored these error, but NPP again doesn’t run.

    I booted Windows in safe mode, and successfully installed and run 7.9.2 , then I installed 7.9.3, but it doesn’t run, so I reinstalled and use now 7.9.2.

    Portable version

    The simple extracted portable version runs fine.
    However if update my portable npp folder with 7.9.3, this doesn’t run, similarly to the installed version.
    But if I then copy here the notepad++.exe (7.9.2 version), this runs fine.
    I tried further with 7.9.3 exe, and begin to rename the plugins, and I found that NppSaveAsAdmin causes this.

    Installed version

    So I renamed the NppSaveAsAdmin plugin before installed 7.9.3. After this NPP 7.9.3 runs fine.

  • Sorry, I see that this was detected already.

  • This post is deleted!

  • Stupid question I’m sure, but I noticed now with this release some of my config files are now encoded in UTF-8 instead of the previous Windows-1252, should I update the rest of my config/XML files to match UTF-8 or is leaving them as Windows-1252 fine? Do all I need to do is just change the header part to ( “encoding=“Windows-1252” ?>” —> "encoding=“UTF-8” ?> )?

  • @ImSpecial
    You can keep your Windows-1252 coding. There will be no harm.

  • @Timo-Moisio-0 said in Notepad++ v7.9.3 Released:

    Viallisen moduulin nimi: ntdll.dll, versio: 10.0.19041.789, aikaleima: 0xe8ba8c09

    What’s your debug info please?

  • @donho

    I noticed later that it was the same issue with NppSaveAsAdmin plugin as reported earlier.
    That plugin was used on the second computer.
    After I removed it, there was no problem.

  • V7.9.1 is better than V7.9.2/V.7.9.3

  • I found a bug which was also in 7.9.2
    Open a text file, mark a column with multiple rows and press tab.
    The Col: xx value isn’t updated.

  • @Tragen
    I am not quite sure I understand your problem.
    Can you explain with an example what you do and what you expect?

  • @Tragen said in Notepad++ v7.9.3 Released:

    found a bug which was also in 7.9.2
    Open a text file, mark a column with multiple rows and press tab.
    The Col: xx value isn’t updated.

    This behavior exists in all prior versions I checked (I spot checked back a few years).

    Really, Ln and Col are only meaningful when NOT in column mode. To convince yourself of this, what should Ln say when you have a column mode block active and your block spans lines 3 thru 10?

    I suppose Col could have a fixed value if the column block has zero-width (your case) and the carets (yes there are more than 1 in col mode) are all in the same column.

  • @Alan-Kilborn

    aah - it is about the statusbar and the Col field, thx for clarification.

  • Zen Coding is not working

  • Notepad++ 7.9.3 fails to start after install. Window Event Viewer contains the following relevant entry:

    <Event xmlns="">
      <Provider Name="Application Error" /> 
      <EventID Qualifiers="0">1000</EventID> 
      <TimeCreated SystemTime="2021-02-18T19:50:40.9870900Z" /> 
      <Correlation /> 
      <Execution ProcessID="0" ThreadID="0" /> 
      <Security /> 
      <Data>C:\Program Files\Notepad++\notepad++.exe</Data> 
      <Data /> 
      <Data /> 

    Reverting to 7.9.1 based upon other comments found in this thread.

  • @David-Michael-Paxton updating: This is installed on Windows 10 Pro 20H2. Originally attempted upgrade of NPP 7.8.9. After initial failure, uninstalled and reinstalled 7.9.3 fresh, which still failed to start. Same symptoms as @László-Botka

  • @David-Michael-Paxton ,

    Same symptoms as @László-Botka

    Does that mean that you also have NppSaveAsAdmin plugin, too? If so issue #9514 is looking into it – and you can choose whether to downgrade to v7.9.1 or whether to disable that plugin until a fix is available.

    If you don’t have that plugin, please let us know what plugins you do have.

  • Did clean install on Windows 10 1809 and it failed to start. Clean install on my 20H2 started just fine.

    Unfortunately don’t currently have access to 1809 device to get logs from Event Viewer.

  • By the way, you can temproarily workaround the problem with NppSaveAsAsmin by installing an older version of this plugin as it was suggested here

    1. I recently installed NPP793 portable and attempted to install the Quicktext 021 plugin using the Plugins Admin. The install starts but then it errors out with this message npp_quicktext.png

    2. I tried manually installing it but after placing the unzipped folder (with associated files) for QT021 in the plugins folder, and following advice in the CHANGELOG notes, copied QuickText.ini to the plugins/config/ folder. It was not recognized by NPP793. Unfortunately the README notes for QT021 has conflicting information (versus CHANGELOG) about the location of the DLL and the INI. In any case following the instructions in either does not work. As far as I can tell the support for QT021 has long since disappeared.

    While I can do nothing to fix 1) above, is there anything I am doing wrong in 2)? or is there a newer alternative to Quicktext 021?

Log in to reply