Notepad++ v7.9.5 released



  • I googled with keywords “event viewer compatibility fix applied to” without finding any answer. No idea what it is but it seems not an important issue.



  • The last hope in this “Event Viewer compatibility fix message” issue would be to ask on some Microsoft forums.



  • @mere-human

    IMO, you’re better off finding out by disabling this “compatibility fix” fixing (probably a Windows Service of similar name) and running notepad++ then, and “hopefully” notice some kind of issue and fix said issue. Then once fixed, maybe this “compatibility fix” won’t happen anymore. (A big if :P)



  • There’s also a Group Policy that does just that.

    https://gpsearch.azurewebsites.net/#19



  • FYI:
    Notepad++'s Auto-updater has been triggered for updating to v7.9.5.



  • In the latest version, the functionlist definition of markdown does not work. Creating a new custom file does not work either.

    Notepad++\functionList.xml

    add:

          <association id="Markdown_Monokai" userDefinedLangName="Markdown_Monokai"/>
          <association id="Markdown_Monokai" ext=".md"/>
          <association id="Markdown_Monokai" ext=".markdown"/>
    
    

    Notepad++\functionList\Markdown_Monokai.xml

    <?xml version="1.0" encoding="UTF-8" ?>
    <!-- ==========================================\
    | To learn how to make your own language parser, 
    | please check the following link:
    | https://npp-user-manual.org/docs/function-list/
    \============================================= -->
    <NotepadPlus>
    	<functionList>
    		<!-- ==== [ Markdown_Monokai ] -->
          <parser
            displayName="Markdown_Monokai"
            id         ="Markdown_Monokai"
            commentExpr=""
          >
            <function
              mainExpr="(?x)((?:^|\n)\s*[#]+\s+(.*?)(\r*|\n*)$)
                           |((?:^|\n)\s*[\r\n]+\s*[-]{3,}\s*[\r\n]+\s*(\r*|\n*)$)"
            />
          </parser>
    	</functionList>
    </NotepadPlus>
    

    Notepad++\userDefineLangs\Markdown_Monokai.xml

    
    <NotepadPlus>
        <UserLang name="Markdown_Monokai" ext="md markdown" udlVersion="2.1">
            <Settings>
                <Global caseIgnored="yes" allowFoldOfComments="no" foldCompact="no" forcePureLC="0" decimalSeparator="0" />
                <Prefix Keywords1="yes" Keywords2="yes" Keywords3="no" Keywords4="no" Keywords5="no" Keywords6="no" Keywords7="no" Keywords8="no" />
            </Settings>
            <KeywordLists>
                <Keywords name="Comments">00# 01 02 03&lt;!-- 04--&gt;</Keywords>
                <Keywords name="Numbers, prefix1"></Keywords>
                <Keywords name="Numbers, prefix2"></Keywords>
                <Keywords name="Numbers, extras1"></Keywords>
                <Keywords name="Numbers, extras2"></Keywords>
                <Keywords name="Numbers, suffix1"></Keywords>
                <Keywords name="Numbers, suffix2"></Keywords>
                <Keywords name="Numbers, range"></Keywords>
                <Keywords name="Operators1"></Keywords>
                <Keywords name="Operators2"></Keywords>
                <Keywords name="Folders in code1, open"></Keywords>
                <Keywords name="Folders in code1, middle"></Keywords>
                <Keywords name="Folders in code1, close"></Keywords>
                <Keywords name="Folders in code2, open"></Keywords>
                <Keywords name="Folders in code2, middle"></Keywords>
                <Keywords name="Folders in code2, close"></Keywords>
                <Keywords name="Folders in comment, open"></Keywords>
                <Keywords name="Folders in comment, middle"></Keywords>
                <Keywords name="Folders in comment, close"></Keywords>
                <Keywords name="Keywords1">http:// https://</Keywords>
                <Keywords name="Keywords2">==== ----</Keywords>
                <Keywords name="Keywords3"></Keywords>
                <Keywords name="Keywords4"></Keywords>
                <Keywords name="Keywords5"></Keywords>
                <Keywords name="Keywords6"></Keywords>
                <Keywords name="Keywords7"></Keywords>
                <Keywords name="Keywords8"></Keywords>
                <Keywords name="Delimiters">00[ 01 02] 03` 04 05` 06** 07 08** 09* 10 11* 12_ 13 14_ 15( 16 17) 18 19 20 21 22 23</Keywords>
            </KeywordLists>
            <Styles>
                <WordsStyle name="DEFAULT" fgColor="DCDCCC" bgColor="272822" fontName="" fontStyle="0" nesting="0" />
                <WordsStyle name="COMMENTS" fgColor="7F9F7F" bgColor="272822" fontName="" fontStyle="1" nesting="0" />
                <WordsStyle name="LINE COMMENTS" fgColor="FF8040" bgColor="272822" fontName="" fontStyle="1" nesting="0" />
                <WordsStyle name="NUMBERS" fgColor="8CD0D3" bgColor="272822" fontName="" fontStyle="0" nesting="0" />
                <WordsStyle name="KEYWORDS1" fgColor="408080" bgColor="272822" fontName="" fontStyle="0" nesting="0" />
                <WordsStyle name="KEYWORDS2" fgColor="FF8040" bgColor="272822" fontName="" fontStyle="1" nesting="0" />
                <WordsStyle name="KEYWORDS3" fgColor="DCDCCC" bgColor="272822" fontName="" fontStyle="1" nesting="0" />
                <WordsStyle name="KEYWORDS4" fgColor="CC9393" bgColor="272822" fontName="" fontStyle="2" nesting="0" />
                <WordsStyle name="KEYWORDS5" fgColor="000000" bgColor="FFFFFF" fontName="" fontStyle="0" nesting="0" />
                <WordsStyle name="KEYWORDS6" fgColor="000000" bgColor="FFFFFF" fontName="" fontStyle="0" nesting="0" />
                <WordsStyle name="KEYWORDS7" fgColor="000000" bgColor="FFFFFF" fontName="" fontStyle="0" nesting="0" />
                <WordsStyle name="KEYWORDS8" fgColor="000000" bgColor="FFFFFF" fontName="" fontStyle="0" nesting="0" />
                <WordsStyle name="OPERATORS" fgColor="DFC47D" bgColor="272822" fontName="" fontStyle="1" nesting="0" />
                <WordsStyle name="FOLDER IN CODE1" fgColor="000000" bgColor="FFFFFF" fontName="" fontStyle="0" nesting="0" />
                <WordsStyle name="FOLDER IN CODE2" fgColor="000000" bgColor="FFFFFF" fontName="" fontStyle="0" nesting="0" />
                <WordsStyle name="FOLDER IN COMMENT" fgColor="000000" bgColor="FFFFFF" fontName="" fontStyle="0" nesting="0" />
                <WordsStyle name="DELIMITERS1" fgColor="408080" bgColor="272822" fontName="" fontStyle="2" nesting="0" />
                <WordsStyle name="DELIMITERS2" fgColor="CEDF99" bgColor="272822" fontName="" fontStyle="0" nesting="0" />
                <WordsStyle name="DELIMITERS3" fgColor="CC9393" bgColor="272822" fontName="" fontStyle="1" nesting="0" />
                <WordsStyle name="DELIMITERS4" fgColor="CC9393" bgColor="272822" fontName="" fontStyle="2" nesting="0" />
                <WordsStyle name="DELIMITERS5" fgColor="CC9393" bgColor="272822" fontName="" fontStyle="2" nesting="0" />
                <WordsStyle name="DELIMITERS6" fgColor="408080" bgColor="272822" fontName="" fontStyle="0" nesting="0" />
                <WordsStyle name="DELIMITERS7" fgColor="000000" bgColor="FFFFFF" fontName="" fontStyle="0" nesting="0" />
                <WordsStyle name="DELIMITERS8" fgColor="000000" bgColor="FFFFFF" fontName="" fontStyle="0" nesting="0" />
            </Styles>
        </UserLang>
    </NotepadPlus>
    
    


  • @linpengcheng said in Notepad++ v7.9.5 released:

    Notepad++\functionList.xml

    I’m away from my PC right now, but isn’t the file you want here named something like “override_map”?



  • @linpengcheng said in Notepad++ v7.9.5 released:

    In the latest version, the functionlist definition of markdown does not work

    Yes it does. As @Alan-Kilborn said, the <association> tags don’t go in notepad++\functionList.xml anymore: the behavior was changed in v7.9.1. As is documented in the function list overview and config files: function list pages of the npp-user-manual.org, it goes in notepad++\functionList\overrideMap.xml .

    It’s also documented there that the <association> tags no longer require/support the ext="..." attribute.

    If you do a search of the forum for “function list”, and you will find at least two very recent threads with examples of the exact steps necessary to get function list working with your UDL.



  • @Alan-Kilborn @PeterJones Thanks, I added the following line in “Notepad++\functionList\overrideMap.xml” and it can be displayed correctly.

    <association id="Markdown_Monokai.xml" userDefinedLangName="Markdown_Monokai"/>
    


  • I noticed an issue with the “style token” feature. The problem is that styling is not applied consistently within words.

    We have line 1: “training” and line 2: “train”.

    Case 1: If I select “train” on line 2 and style that then only “train” on line 2 is styled.

    https://i.imgur.com/D18IOEx.png

    Case 2: If I select “train” on line 1 and style that then “train” on lines 1 and 2 are styled.

    https://i.imgur.com/QbbT21R.png

    I tried older versions of Notepad++, through 7.8, and deleted my %appdata%\notepad++ folder between tests, but the older versions have the same behavior. It must be a coincidence I noticed this now.

    I’m accustomed to case 2 where “train” is always styled: even within words. Somehow, that is the way styling worked out in the past.



  • @Michael-Mientus-0 said in Notepad++ v7.9.5 released:

    noticed an issue with the “style token” feature. The problem is that styling is not applied consistently within words.

    It really is a bit, well, awkward, isn’t it?
    Here’s how it works:

    If you select some text, if that text is a full “word”, then N++ will check the Match whole word only setting in the Find dialog to decide what to do. If that is ticked, it will only do the selected word occurrences and NOT the occurrences where that word is part of a larger word. For all other input conditions it will also do whole words and parts of longer words.

    That description might be hard to understand; it is even harder to remember.



  • @Alan-Kilborn said in Notepad++ v7.9.5 released:

    the Match whole word only setting in the Find dialog

    In my mind, the dialog box is modal. Also, I don’t have that option selected.

    So how should I change the mode?



  • @Michael-Mientus-0

    Hmm, actually my earlier description was something I had documented for how it worked, but my notes are quite old and maybe something in the software has changed (or my notes were wrong). I’ll try to work with it and figure it out…



  • @Michael-Mientus-0

    Continued experimentation shows me that it works as I described, with one addition: If you have no selection but your caret is sitting in the middle of a word when you invoke the style command, it acts like I said earlier when I said “If you select some text, if that text is a full “word””.

    But otherwise, I cannot duplicate your result from:

    Case 1: If I select “train” on line 2 and style that then only “train” on line 2 is styled.

    with the caveat of:

    I don’t have that option (match whole word) selected

    Also:

    In my mind, the (Find) dialog box is modal.

    Well, it’s not.
    And, even if it were, how is that relevant to the current discussion?

    So how should I change the mode?

    No idea, sorry.



    • Close and open Notepad++.
    • Type my test: “training” on line 1 and “train” on line 2.
    • With nothing selected, right-click on “train” on line 2 > Style token > Using 1st Style.

    Under these conditions, only “train” on line 2 is styled.


    • Close and open Notepad++.
    • Type my test: “training” on line 1 and “train” on line 2.
    • Open the Find dialog.
    • Clear ‘Match whole word only’.
    • With nothing selected, right-click on “train” on line 2 > Style token > Using 1st Style.

    Under these conditions, “train” on lines 1 and 2 are styled: The token will be styled within words.

    You could not reproduce my issue because Style Token will continue to match within words after opening the Find dialog once. This might also explain why I haven’t seen this issue before. I must have always used the Find dialog at least once before styling tokens.


    With regard to the user interface, I’m saying there is no logical connection between the Find dialog box and Style Token. I suggest decoupling Style Token from the Find dialog. If people still want to toggle the behavior then create a new preference.



  • @Michael-Mientus-0 said in Notepad++ v7.9.5 released:

    You could not reproduce my issue because Style Token will continue to match within words after opening the Find dialog once.

    There is a similar open issue regarding Match case.
    See Applying Style Tokens is case sensitive until search is done.

    With regard to the user interface, I’m saying there is no logical connection between the Find dialog box and Style Token. I suggest decoupling Style Token from the Find dialog. If people still want to toggle the behavior then create a new preference.

    As I hinted earlier, I agree this isn’t the best design.
    But we’re not the developers here, just a user community to discuss things and help each other out.



  • @Alan-Kilborn said in Notepad++ v7.9.5 released:

    There is a similar open issue regarding Match case.
    See Applying Style Tokens is case sensitive until search is done.

    I found that thread earlier but did not recognize it at the time. It seems similar.





  • It seems with this last release, the “Default Directory” preference no longer works. I always use the Default Open/Save file directory as “Remember last used directory”, but the location is always the Notepad++ installation folder (In Program Files). I tried to set manually the path, but this method worked only once. On the second test, the location returned to the Notepad++ installation folder.



  • @Jean-Michel-Coinus said in Notepad++ v7.9.5 released:

    Default Open/Save file directory as “Remember last used directory

    but this method worked only once. On the second test, the location returned to the Notepad++ installation folder.

    I also see this behavior, when I set to “Remember last used directory” (which I don’t normally use).
    Perhaps opening an issue on it (see FAQ) is the way to proceed?


Log in to reply