What is the Notepad++ file size limit?



  • Hey folks,

    I recently ran into a problem where I was was trying to load a 350MB text file into Notepad++, and I got an error saying “File is too big to be opened by Notepad++”. However, another 317.9MB text file opens with no such error.

    What is the actual file size limit in Notepad++?



  • I have the same issue here on Notepad++ v6.8.3. Anyone has an answer?



  • Actually my file size is 423MB which should not be too big. I closed some programs like MS SQL Server Management Studio and re-open the file with Notepad++ and it worked. Hope closing some programs to free memory is helpful for you too.
    By the way my memory is 4GB which is large enough but for some reason Notepad++ cannot take use of my free memory unless I close other programs manually.



  • I just hit this problem, trying to open a 438m file when I had plenty of free memory. Here’s what worked for me: I closed all the other files already open in NP++ (with File>Close All), and then it let me open this file.

    And for those who would be concerned that in closing the files they’d lose track of the files they already had open, note that NP++ has a wonderful File>Save Session option to let you save off the list of what files are open. You can save the session, open the large file, and then use File>Load Session to pick up where you left off. (It’s just a tiny xml file of the names/paths and their relative location in the tabs. And you do need to save any unsaved files, but otherwise it was a big relief to get back the files I’d had open.)

    As for the problem, well, I didn’t think I had any particularly large file already open, but I didn’t dig in to them to confirm if one was large. The solution of closing all files worked for me, and I hope it may help others.



  • Following up my last comment, I forgot to mention that I did need to restart NP++ after closing all files, and THEN I could open the large file. (I tried to add this as an edit, but you only get 3 mins before you are no longer allowed to edit replies here. And if you are new to the forums, then you have to wait 20 mins to post another. Understandable but grr.)

    And I’ll add that I tried the same trick with a 600m file, but it would not open (and I had 7g available real ram). Oh well.



  • One more followup, and perhaps it’s obvious to some readers. But now that the 64-bit version of NP++ is available, I got that and it had no trouble opening the larger file. Hope that may help some other readers.


Log in to reply