Bug Fix: Windows 10 Virtual Desktops

  • I use Windows 10 and quite often have various virtual desktops open for different development environments. Unfortunately though Notepad++ has a tendency of always opening a file in the latest instance.

    For example if I open file by double-clicking on Virtual Desktop 2, but Notepad++ is already open on Virtual Desktop 1 , then the file opens on Virtual Desktop 2, rather than launching a new instance on Virtual Desktop 2.

    Be awesome if this could be fixed. :)

  • I’m not sure this is a bug I think it is a function of how Notepad++ handles opening additional files. With that said, it is really annoying when working within windows 10 virtual desktops. It slows down my work flow enough that I find myself using another editor instead of moving Notepad++ to the current virtual desktop.

    As a work around I think I would be happy with the ability to open a new instance of Notepad++ by shift + right click like I do with most other applications.

  • Hi, same here, I really like notepad++ but this is really annoying :(

  • Hello @Adam-Bednarski,

    I don’t have multiple monitors therefore I started
    windows 10 in a virtualbox environment. (2 monitors configured)
    When having virtual desktop mode extended and npp setting
    always in multi instance mode the documents get opened
    where npp initially was started.

    E.g. You start npp on monitor1 and move it to monitor2.
    New documents start always on monitor1.
    But if you start on monitor1, move it to monitor2 and close it
    on monitor2. Restart on monitor2 any new document is displayed on monitor2 as well.

    Could you test if a real 2 monitor setup behaves the same?


  • Settings > Preferences > Multi-Instance > Default (mono-instance)
    This is what I have and files always open in the currently open instance on the Desktop Notepad++ is on.

  • Yes, if you only want to have one instance running but the problem here is, as far as I understood,
    that they use multi instances of npp.


  • I’ve had this same issue. Although I usually have one project I am working on and want files to be opened in that instance of npp, sometimes I want to open a file in a separate window and on a separate desktop.

    What I did was as follows, I mad a shortcut to npp on my desktop (or taskbar) and ritgh-click > properties, in the target field, I added the following:
    C:\Programs\Notepad++\notepad++.exe -multiInst -nosession

    Now, when I want to open a file in a new instance wherever I want, I just drag the file onto that icon - works great!

  • @DaveyD, nice trick, indeed.


  • I have a written a program which enhances Windows 10 desktops and works around this issue for word/excel for you by detecting the switch to a new desktop to open the existing document and then open of a new document - it then moves it back where it belongs.

    I suspect it will also work with Notepad++. You will need to edit the settings file to add Notepad++ as one of the executables it does this for - see the User Guide. Let me know it it works!


    Full set of features are:

    Windows 10 Desktop Switcher using a grid layout
    Switch desktops using arrow keys with configurable modifier keys
    Move active window to another desktop using keyboard
    Make windows Always on Top or Sticky using keyboard
    Activate last active window when switch from empty desktop (Windows 10 bug)
    Chrome/Firefox activation to make web links open on same desktop if window exists
    Word/Excel new window detected and moved back to current desktop if auto-switched


  • Thx to Simon Liddington, NPP might not annoying you.
    But it’s not fixed yet? NPP is the only app which appears on all Virtual Desktops in Windows 10.
    It does whatever mode (multi- or mono-) you set.

Log in to reply