i am getting the below error message when trying to save a file to our sharepoint site the file cannot be and it may be protected do you want to launch notepad++ in administrator mode?

  • This is not really an error. this is an informational message informing you that you are editing a locked / protected file. this is normally a system file of some sort. if you are positive you want to modify / replace the file then click yes to allow NPP to restart in administrator mode. I would also suggest you have a copy of the unmodified file before allowing NPP to make the requested change.

    This is a safety feature not a problem with the program.

  • Considering this topic has 1.7K views I felt it was necessary to post what fixed this problem for me.

    I run notepad++ under Windows7 Home Premium. A few weeks back I too started getting the same error message: “The file cannot be saved and may be protected. Do you want to launch Notepad++ in Administrator Mode?” The problem as it turned out was that I had windows explorer open with the preview pane ON highlighting the file I was editing in Notepad++. The preview pane button sits top right between the directory listing view button and help button. Turn off the preview and you will be able to save without any problem.

    Hope this helps.

  • Thank you Kerry, that was very helpful!

  • @kerry-ruddock Incredible! Thank you for this information! It was making me crazy.

  • Here is what’s happening with me -

    1. Create a text file directly in a folder by RightClick->New option
    2. Try opening the file in notepad++
    3. Edit and save
      You get the same error -
      “The file cannot be saved and may be protected. Do you want to launch Notepad++ in Administrator Mode?

    I am using V7.4 version on Win10

  • @Devesh Srivastava I am also seeing the exactly same problem

  • Thanks Kerry! You saved my life!

  • Hi!.. Guys, I know this issue is silly but it upsets us much more.

    So please follow my words to close this issue completely.

    if you see this message ->>>“The file cannot be saved and may be protected. Do you want to launch Notepad++ in Administrator Mode?"<<<- when you try to save file in notepade++ means, Please go to
    C:\Program Files\Notepad++
    C:\Program Files (x86)\Notepad++

    “notepad++.exe” select the file and right click it. Then go to properties-> Then go to the tab Compatibility-> check the checkbox “Run This program as an administrator”

    Then click ok…

    Thats it.

    Note: To do this you need to have a administrator rights.

  • it was soooooo simple solution!
    I hope this helps someone.

    My Answer:

    1. Install the correct version х64 notepad++ (if you installed the wrong version, etc.)
    2. Сlick the right mouse button on your file in WinSCP->correct…->editor->…
    3. Delete the old path to notepad++ and add new path to new notepad++ (C:\Program Files\Notepad++\notepad++.exe)
      that’s all

  • This may help someone. I was in thew same situation as everyone else & none of the solutions worked for me. I think it is a bug because I had this particular issue with only 2 of the many I had open in NPP.

    Also, I was able to make changes to these 2 files only yesterday & save them without any issues. And, it was a work machine & didn’t have the privileges to run NPP as admin.

    Long story short, I took the lazy/poorman’s approach.as below:

    1. “TestFile.txt”: File => Save As using a different name - say “TestFile_Backup.txt”.
    2. Close the file “TestFile_Backup.txt”.
    3. Make sure files “TestFile,txt” & “TestFile_Backup.txt” are identical.
    4. Delete the original file “TestFile,txt”.
    5. Rename file “TestFile_Backup.txt” back to “TestFile.txt”.
    6. Voila - you have saved the file in a roundabout way!
      By the way, after this fix, I was able to open, make changes & save the file ““TestFile.txt”” successfully.

Log in to reply