Carat cursor randomly switches to underline



  • Not sure if this is some keyboard shorcut I’m triggerring accidently or some sort of bug.
    When I’m just typing and editing normal text, using nothing other than keyboard and mouse.
    Randomly or for no reason I can find, the carat cursor switches to underlining the following charcter.
    I only notice when instead of inserting text, it replaces it the underlined character as I type.
    I suspect it’s intended behavioras CRLF are also underlined, but it’s not my intention and the only way I’ve been able to reverse it is by restarting Notepad.
    Any idea what may cause and/or reverse this, I thought it might be the column mode, but thats not it.
    Nothing seems to reverse this except a restart and it’s reoccurred 3 or 4 times now.



  • @UhuruNUru

    it didn’t happen to me yet but there is a key on the keyboard which does this normally.
    The key is called insert and is the upper left of the 6-key group next to the normal one.
    Better take a look here
    I guess this explains it better than me.

    Cheers
    Claudia



  • Thanks, I must have hit the insert key by accident, I always use the menus, don’t use this enough to justify learning the keybord shortcuts.
    Now I know what it is caused by I can reverse it, I assume simply by pressing the insert again or just disable it entirely.
    It was removing the existing text I didn’t want, and would never have thought that, would be called Insert and not replace.
    Just an annoying problem, I had a quick fix to reverse it, but couldn’t find a menu settingt.



  • @UhuruNUru
    yes, the key has only this two states, either insert or override and pressing it toggles the behaviour.
    This is standard keyboard functionality it happens in other editors as well.

    Cheers
    Claudia



  • I use Open Office mainly, I don’t using that but I took the trouble a long time ago to disable all but the basic keybord functions as I recall only Tab and Backspace were kept.
    I mainly play games, my right hand is always welded to my mouse, not efficient for typing, but one finger left hand typing is as fast as I get.
    That’s all I can think of, I “insert” by clicking mouse where I want to insert text. I may claim it’s due to being blind in one eye, but I’d be lying, in reality and in a reference to my mispent youth
    and great way to end a song. If you know what that is from, you had a mispent youth too. (Hint: Sid isn’t a typo)
    I’m a lazy sod
    I’m a lazy sod
    I’m a lazy sod
    I’m so lazy
    Yawn
    I’m a lazy sod
    I’m a lazy Sid
    I’m a lazy sod
    I’m so lazy
    I can’t even be bothered
    Lazy
    Lazy



  • @UhuruNUru

    well I know the sex pistols but I don’t listen to them. They are to soft.
    Your typing behaviour is a challenge so, I tried it for a couple of seconds and it drives me crazy.

    Cheers
    Claudia



  • Must be a wild typing experience if it is “hunt and peck” with one hand and this happens…seems rather difficult to believe that one would hit the Insert key at some random point…unless you are having a seizure.


Log in to reply