Issue with macro

  • I have this JSON text that contains a string attribute which is another escaped JSON in quotes. I wanted to extract that text and un-escape the JSON. So I tried it with the following steps to record a macro:

    1. Start the recording
    2. Bookmark the line that contains the JSON to un-escape
    3. Remove the unmarked lines
    4. Use Regex with group to find text and crop (Find/replace) the retain the escaped JSON
    5. un-escape the JSON
    6. Stop the recording

    Manually doing all the above steps, gave me the expected JSON un-escaped. but when I replay the recording, it gave me only one single “{”. Is this a bug in the existing Notepad++? I tried this with many ealier releases and the latest v6.8.8.


  • Hello @Hongyan-Li,

    I assume it depends on how you did it.
    From my experience it is better to use as much keystrokes as possible instead
    of using the mouse and click. For example it you clicked the bookmark margin
    it doesn’t get recorded but when using CTRL+F2 to bookmark it gets recorded.


  • Check if you have auto insert of closing parenthesis, etc. I found an issue where they don’t insert during record, but do during playback. (Settings->Preferences->Auto Completion, look on the lower right panel)

Log in to reply