Bug: Auto insert of {,[,",( is off when recording macro, but on during playback



  • I am loving the macro functionality, but have found an issue with the auto insert of the matching characters. When I record a macro, the closing parenthesis (and so on) do not get inserted, so I don’t do anything to deal with them. When I play the macro back, the closing character is included. As you can imagine, this creates syntax errors in my code.

    The work around is to turn off the auto insert, but it would be nice for recording and playback to have the same behavior.

    Thanks!



  • What version of Notepad++ are you using? It looks like it was fixed in v6.8.4



  • Dont know about OP, but I have this Bug too, also and more badly with autocomplete. Running a just recorded makro runs fine, but once I save it, it breaks.
    6.9

    (side note, writing this on a android Tablet with Chrome is really painfull, Layout is completely broken once the screen keyboard shows up)
    But otherwise I love Notepad ;)


Log in to reply