Problem with the macro



  • Hi !
    I’ve some problem with the Macro!
    1 + I start the process
    2 + I write the macro
    3 + I stop the process
    4 + I save it.
    And it’s not working!

    Please could you tell me what can I do?
    Thanks for your help.



  • Hello @Fourmi-Krohonde,

    and step5 should be replay but I assume you did this step as well, didn’t you?
    If you wanna explain what you might to achieve we can maybe provide a way how to solve it.

    Cheers
    Claudia



  • Hi Claudia,
    thanks for helping me.
    I haven’t understand your question?
    I explain you the process I do:

    Macro:
    1 + Start recording
    2 + II write the Macro, for exemple: <span class=“red”>
    3 + Stop recording
    4 + Save currently macro recorded with “ctlr + shift + R”

    I have tried to do “replay”, but it doesn’t change nothing. When after I do “ctlr + shift + R”, nothing appears!

    Sincerely.
    Fourmi



  • Hello Fourmi,

    because the used accelerator CTRl+SHIFT+R is already used by npp.
    It is used to toggle macro recording ;-)

    Settings->Shortcut mapper

    shows you which accelerators are already in use.
    Unfortunattely you have to scroll the list for each of the topics, as, currently, there is no
    other easy way to retrieve the information you need.

    Cheers
    Claudia



  • WOnderfull, Claudia, lot of thanks: it’s work.
    Thanks, from France.
    See you



  • Hi,
    Why the macro I create is always played at where it’s created? i.e. At line 10, I start recording the macro, hit the enter key, and stop recording. Move cursor to line 20 and playback. The text I recorded is added at line 10, not line 20. How do I get the macro to playback at where the cursor is? I’m using latest 6.9.1
    Thanks,
    Tony



  • Hello Tony,

    tried it on win7 x64 with npp 6.9.1 and cannot confirm
    your reported behavior.

    Did you save the macro?
    If so, can you show what has been recorded?
    It’s saved in shortcuts.xml.

    Cheers
    Claudia


Log in to reply