plugin update prompts for missing gpup.exe file



  • I was on npp 8.8 on w8-32.
    I ran plugin update which did update one plugin, but then asked for restart.

    When I let it restart, it prompted that gpup.exe file (or some name, I don’t remember) missing so plugin can’t be updated.

    I checked through harddisk and could see gpup.exe file very much present there in one of the folder.

    and ever since, on each run of npp, same issue is appearing, it asked to restart, and on my allowing it, it says that file is missing.

    I downloaded 8.9.1 and installed, and the problem disappeared.

    I think this is bad point that a running program gives such a tiny error because it doesn’t know where to look for a file which is very much present.

    Thanks.

    Rawat



  • Hello @V-S-Rawat,

    but it sounds that the file wasn’t where it was expected and after your upgrade it has been placed in the directory where it
    should be. So from my point of view, it is absolutely ok. Why should npp look for a different folder to find its executables?

    Cheers
    Claudia



  • Dear madam,

    I don’t think I had moved that file.

    It must have been placed by npp installer itself at that place in some previous installation.

    so, it should have known where to look.

    of course, I have changed the location of plugin folder, so if that changes the location of this file, then the path should be stored relative to the location of plugin folder.

    At least, it should have told me where it was expecting to find that file, so that I could have manually moved the file there, but it just gave message “file not found” and aborts, doesn’t tell me the location or anything.

    So, I guess some user-friendliness could be added there.

    Thanks.

    Rawat



  • I got the same error…


Log in to reply