"Runtime Error!" when opening file through shell.

  • When I try and open up a file using Notepad++ through Windows Explorer and Notepad++ is already open (usually with unsaved files) I usually get a message box stating:

    Runtime Error!

    There are two instance of Notepad++.exe running at this point, original one and the one spawned by the shell.

    The main thread’s call stack is:

    user32.dll!_NtUserWaitMessage@0() Unknown
    user32.dll!DialogBox2() Unknown
    user32.dll!InternalDialogBox() Unknown
    user32.dll!_SoftModalMessageBox@4() Unknown
    user32.dll!_MessageBoxWorker@4() Unknown
    user32.dll!_MessageBoxTimeoutW@24() Unknown
    user32.dll!_MessageBoxTimeoutA@24() Unknown
    user32.dll!_MessageBoxExA@20() Unknown
    user32.dll!_MessageBoxA@16() Unknown
    SpellChecker.dll!070f7d84() Unknown
    [Frames below may be incorrect and/or missing, no symbols loaded for SpellChecker.dll]
    SpellChecker.dll!070f70f4() Unknown
    notepad++.exe!014161f5() Unknown
    ntdll.dll!_NtQueryVirtualMemory@24() Unknown
    KernelBase.dll!_VirtualQueryEx@16() Unknown
    KernelBase.dll!_UnhandledExceptionFilter@4() Unknown
    ntdll.dll!ExecuteHandler2@20() Unknown

    So it would appear that something in the SpellChecker.dll is what caused the problem. Anyone else had this problem or can replicate it?



  • Oh, and if I hit ok and then open the file again through the Explorer, it will usually eat all of the unsaved files (i.e. they all disappear).

  • It looks like you are using the old spell checker. This hasn’t been included with Notepad++ for a couple of years at least! The default spell checker that comes with Notepad++ is called DSpellCheck. It is available through the Plugin Manager. I’d recommend uninstalling your current one and using the new one instead.

  • Ah, ok. Well I got the other spell checker from the plugin manager. I don’t think that there was any ‘default’ spell checker when I installed notepad++ so I just found one that started with ‘s’.

    Anyway. I removed the dll and tried the new one you suggested. It still crashed. I then deleted that dll and was still able to replicate the problem. Here’s the call stack:

    KernelBase.dll!_RaiseException@16()	Unknown
    notepad++.exe!0140c21e()	Unknown
    [Frames below may be incorrect and/or missing, no symbols loaded for notepad++.exe]	
    notepad++.exe!0140bb40()	Unknown
    notepad++.exe!0133297b()	Unknown
    notepad++.exe!01332793()	Unknown
    notepad++.exe!01414627()	Unknown
    notepad++.exe!0140c345()	Unknown
    notepad++.exe!01414839()	Unknown
    notepad++.exe!01414a21()	Unknown
    notepad++.exe!01414cfb()	Unknown
    notepad++.exe!01415444()	Unknown
    notepad++.exe!0140c602()	Unknown
    ntdll.dll!ExecuteHandler2@20()	Unknown
    ntdll.dll!ExecuteHandler@20()	Unknown
    ntdll.dll!_KiUserExceptionDispatcher@8()	Unknown
    KernelBase.dll!_RaiseException@16()	Unknown
    notepad++.exe!0140c21e()	Unknown
    notepad++.exe!0140bb40()	Unknown
    notepad++.exe!0133297b()	Unknown
    notepad++.exe!0133276e()	Unknown
    ntdll.dll!_bsearch()	Unknown
    ntdll.dll!_bsearch()	Unknown
    ntdll.dll!_bsearch()	Unknown

    Seems to be an exception being thrown in an exception, which IIRC is bad.

    Is there a place I can get the .pdbs for this? Or am I going to have to build this thing myself and debug it?



  • Couple things. Try temporarily removing all plugins to make sure it is not one of those. Also, does it do it for all files or just a specific one? What version of Notepad++ are you using?

    Is there a place I can get the .pdbs for this?

    None are publicly available that I’m aware of.

  • I moved all of the dlls in the D:\Program Files (x86)\Notepad++\plugins folder to D:\Program Files (x86)\Notepad++\plugins\disabled and was able to still replicate the problem.

    It happens with all files that I’ve tried. .xml, .ini, .txt.

    Can you replicate this problem? I’m a bit surprised that I am the only one having this issue, but I’d be also surprised that nobody would have reported this as a problem before now if it was happening on other machines.

    I’m using v6.9.1 and IIRC, was happening on earlier versions too. I was just too lazy to look into it.

    Also, can someone increase my rep? I can’t post for 20 min between posts. :(


  • It’s never happened to me before. I’d assume it is something specific to your machine or possibly settings since if more people were running across this there would be more reports.

  • Maybe try to completely uninstall and reinstall. I’ve heard that sometimes fixes very random errors.

  • Thanks dail, but it didn’t work. Also thanks for the rep points.

    This problem is specific if you open Notepad++ directly from the executable. If you first open it using the Shell via opening a file that is associated with Notepad++, this problem doesn’t occur. So it is still possible that most users are opening Notepad++ indirectly via opening a file and not experiencing this issue.

    Try opening Notepad++ directly from the executable and then opening a file associated with it. If the problem persists beyond my computer, it should cause it to crash.

    I’m also using Windows 8.1 in case that matters.



Log in to reply