Force UTF-8 only OPEN



  • I have been using npp for quite some time and it always worked for me: All my files are UTF-8 (without BOM), and npp always worked around opening them in UTF-8, but since I updated to Windows 10, npp will always open them as ANSI. Yes the option “use UTF-8 when opening ANSI” is checked, yet the files have plenty of UTF-8 characters, but it will simply not open as UTF-8, it always opens as ANSI.

    I simply do not have any sort of file on my computer that is ANSI (why? I use portuguese as main language, there are non ANSI characters everywhere) and I would be very much glad if files opened with UTF-8, is there any way to force it to only open as UTF-8? this is driving me nuts, I have to remember to switch encoding to UTF-8 every time I open a file or npp!

    I am pretty sure this is a bug on npp because it will still open as ANSI even if the first character is a UTF-8 like this: 🚌



  • @Caio-Vianna-Lima-Netto

    did you disable autodetect character encoding? (Settings->Preferences->MISC.)

    Cheers
    Claudia



  • No, it is enabled.

    However it is now working.

    Apparently it only worked past a system reboot (I usually hibernate). I rebooted yesterday and now it is opening UTF-8 as it should.

    Some weird setting that was not being saved?



  • Forget it, it is not working, it apparently “remembers” those I switched to UTF-8 so they re-open in UTF-8, but any file I open for the first time still opens as ANSI …



  • Thought utf-8 is the default. I don’t have autodetect character encoding enabled and if I open a document, either new or existing,
    statusbar reports it being utf-8.
    Need to check the code to see if there are circumstances which prevents this to happen.

    Cheers
    Claudia



  • Well, it is very unfortunate that this problem is happening. Even files that were open/saved with UTF-8 still get opened as ANSI and this is just unbearable when I have to open dozens of files over and over and remember to switch to UTF-8 or get corrupt data. I used npp for years and seems it is time to move on =/


Log in to reply