BUG: Alt + CapsLock +S crashes Notepad++



  • After being rather fat fingered regularly throughout my work day, I’ve found that the following occurs:

    Alt + Shift + S trims trailing whitespace and saves.
    Alt + CapsLock +S crashes Notepad++ without fail every time.

    Build details:
    Notepad++ v6.9.2
    Build time : May 18 2016 - 00:34:05
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 7
    Plugins : ComparePlugin.dll mimeTools.dll NppConverter.dll NppExport.dll NppFTP.dll PluginManager.dll PyNPP.dll Python Indent.dll ScrollPastEOFUni.dll SourceCookifier.dll TagsJump.dll

    Thought it was worth advising someone of this bug.

    Cheers!



  • What does Alt+S do for you, without CapsLock or Shift? I ask, because I am guessing it will crash your setup as well. CapsLock isn’t a modifier key, and I would be surprised if it’s having any effect.

    In my installation of ComparePlugin (1.5.6), Alt+S is Compare to last save. Every time I tried to hit Alt+CapsLock+S, the ComparePlugin would successfully run its Compare to last save. I wonder if it’s the ComparePlugin that’s crashing for you – either because of a bad installation of the plugin, or because it’s interacting badly with one of your other plugins.

    Notepad++ v6.9.2
    Build time : May 18 2016 - 00:34:05
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : ON
    Local Conf mode : OFF
    OS : Windows 7
    Plugins : ComparePlugin.dll dbgpPlugin.dll mimeTools.dll NppConverter.dll NppExec.dll NppExport.dll NppFTP.dll NppTextFX.dll PluginManager.dll PreviewHTML.dll PythonScript.dll 
    

    You might want to try to run notepad++ -noPlugin and see if the same thing happens: Alt-S should just open up the Search menu in that case, and Alt+CapsLock+S should do the same. If it doesn’t crash with -noPlugin, then it’s one of your plugins… and you can then disable each of the plugins one at a time (move their DLL to a temporary storage location) and try to determine which plugin is really causing the issue.



  • It is indeed the compare plugin (Alt+S) that causes it to crash, Thanks!

    I’ll raise a bug report there.

    FYI - I don’t work locally - I use NppFTP and literally every file exists on a dev server elsewhere. This means there is no local saved files to compare against when this Alt+S shortcut is triggered.

    Having a locally saved file open in Npp and hitting Alt+S is successful but having no locally saved files open or in history causes the crash out.

    Cheers,
    Phil



  • For your specific instance, it makes sense to me to just disable the Compare plugin. However, if there are future users out here who find topic: if you still want to have the Compare plugin, but just don’t want it on the Alt+S shortcut, because of the slippery finger from Alt+Shift+S to Alt+CapsLock+S, I would recommend just removing or editing that shortcut: Settings > Shortcut Mapper > Plugin Commands > Compare to last save (Alt+S) > Modify: either pull down to “None” or to whatever key you do want for the Compare feature, then OK.

    (Personally, I like the Trim Trailing and Save so much – I’ve never had reason yet for maintaining trailing whitespace in the files I edit – that I swapped the shortcuts so that Save is Alt+Shift+S and TT+S is Ctrl+S; that’s probably why I’ve never slipped from the Shift to the CapsLock during a TT+S)


Log in to reply