Failure to Launch

  • Jfyi -to start npp without any plugins loaded (they don’t get deleted/renamed etc… just ignored) use the -noPlugin switch.
    See ? menu -> Command line arguments.


  • ---------------- FIX ----------------

    I just found the problem of Dropbox. The problem is in the Shell Explorer DLL of Dropbox (that takes care of things like the sync icons in Windows Explorer in the Dropbox directory).

    You can still use Dropbox AND Notepad++ using the following method:

    • Download ShellExView from NirSoft. Make sure you download the 32-bit version of ShellExView, because Notepad++ uses the 32-bit DLL’s of Dropbox.

    • Start ShellExView and sort the list by Description.

    • Select all the items from Dropbox

    • Disable all the selected items by pressing F7, or right-click->Disable selected items, or click the red-dot-icon in the upper toolbar.

    • Explorer.exe already loaded all these DLL’s, so restart explorer.exe with the Taskmanager, or just simply log out in Windows and login again.

    • Now Notepad++ should start, with any explorer plugin’s enabled and with Dropbox installed.

    Possibly this fix will be temporary, because Dropbox can update the DLL and I don’t know what happens with the disabled items. But of course you can just run ShellExView again to fix this.

    I encountered the problem using the LightEplorer plugin and the WindowManager plugin in Notepad++. Now it all works again.

  • Thanx, Joris. Hope, there will be a solution from the NPP-Developer(s) soon.

  • Just wanted to confirm that uninstalling Dropbox resolved the issue for me as well.

  • Notepad++ will only run for me on Win7 in admin mode unless I delete (or rename) plugins\Explorer.dll. I use Dropbox too often to uninstall it. Hopefully either the Explorer plugin or Dropbox will get an update to overcome this glitch.

  • ------------- Edit: FIX -------------

    Downloading the 32-bit version of ShellExView did not work. So it doesn’t matter if you download the x86 or x64 version of the program, make sure you’re only disabling the 32-bit DLL’s:

    • Go to Options in the toolbar and enable the first option Show 32-bit Shell Extensions

    After that, you can sort the list and disable every Dropbox item in the list. Both Notepad++ AND Dropbox will still work fine after this.

    Let’s hope the Dropbox- or Notepad++ developers come with a solution. In the meantime I hope this will help anyone with the same problem.

  • Joris de Ruiter - You star!!! Disabling the Dropbox context menus works. Thank you so much!

  • Thanks for sharing the info, Joris! Disabling all Dropbox shell extensions per your instructions seems to have fixed the problem. Strangely, I still have Dropbox context menus and icon overlays. It took a couple of reboots, but it seems that NPP launches just fine now, and I didn’t have to uninstall anything or disable Explorer Lite. Good luck!

  • I’m having the same problem with the explorer plugin. Any update on a permanent fix?

  • I’ve just manually updated Dropbox to 8.4.21 (released early today, 24/Aug) and that seems to have put things right. Dropbox does not seem to pick up small increments automatically so I went through

    I have cured ‘failure to launch’ on Windows 10 64-bit, WIndows 7 64-bit and Windows 7 starter, so it looks promising. I have tried as many plugins as possible to try and provoke failure but so far it’s looking good.

  • My Dropbox version is now at 8.4.21 and the NPP Explorer plugin issue appears to have been fixed.

  • If you move explorer.dll from disable then you have to give permission to current user to access and it will fix :)

  • Same hapened to me after Avast update. Remove “plugins” folder and problem solved.
    Suspect on avast and LigthExplorer plugin combination, just becouse explorer plugins seems to have something to do.

  • Same problem here.
    I use DriveOnWeb instead of Dropbox, disabled all respective shell extensions, problem remained.
    I use 360 Total Security instead of Avast, disabled the anti virus program, problem remains.
    Any ideas what else might interfere with Explorer and LightExplorer plugins?

  • Hi,
    I come back to this thread because I’m facing the same problem ‘failure to launch in browser’. By now I have tried several things. Dropbox I do not use, so that cannot cause the problem. Today I uninstalled the ‘normal’ version of NPP, and installed the portable one (on a stick), but does not help. Debug info looks like this :

    Notepad++ v7.5.4 (32-bit)
    Build time : Jan 1 2018 - 01:47:45
    Path : G:\Notepad++Portable\App\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : ON
    OS : Windows 10 (64-bit)
    Plugins : DSpellCheck.dll NppConverter.dll NppExport.dll mimeTools.dll

    Logging in as admin doesn’t help either. Anyone who knows how to fix this ?

  • @Jos-Debouvere177 said:

    I’m facing the same problem ‘failure to launch in browser’

    “…in browser” ?

Log in to reply