npp version above 6.8.7 run twice caused XP System hang



  • Hi, Sir
    When I run notepad++ first, It seems work fine,
    and the second time, I run notepad++ , The BSOD (blue Screen)
    Stop c000021a Unknown Error

    I have try many old version, It runs fine on my XP sp2 system.
    Hang–>V6.8.8
    Hang–>v6.9.2

    OK–> v6.7.8.2 ,v6.8.3 ,v6.8.6 ,v6.8.7



  • @Lin-Jeffer

    can you reproduce this always? I’m running XP in a virtual machine and don’t have such problem.
    Did you try to run npp without plugins used?

    Cheers
    Claudia



  • @Lin-Jeffer
    A BSOD happens when a Kernel-Mode failure occurs. Since no part of NPP runs in Kernel-Mode, it cannot trigger the BSOD directly. But AFAIR newer versions of Scintilla (a component used in NPP) use DirectDraw which in turn relies heavily on the graphics driver/card. So you may want to check for updates to your graphics driver or even try a different adapter (if possible).



  • @Claudia-Frank
    Yes , I am using (no installer, bin_zip npp++) and no any plugin.
    It always hang at second time launch.
    Just launch npp++ , then exit. Launch npp++ again —> (hang)



  • @gerdb42
    It also happen on VM, XP clean install and npp++ only(virtualbox 4.2.36) ,
    at second time launch, VM stop Siently(no any message or hint)
    I put SciLexer.dll (from 6.9.2) into 6.8.7 , npp++ 6.8.7 run quite well , so I think it’s not the point .



  • @Lin-Jeffer

    I can start npp multiple times without any problem.
    Did a test with >10 restarts.
    Did you try running xp in safe mode?
    What about using sfc tool, did you already run it?

    Cheers
    Claudia



  • @Claudia-Frank
    In VM safe mode (no network),
    Npp Launch first time , It silently stop. (same as normal mode)

    Software compatible issue is case by case.
    maybe MY CPU is AM1 (althon 5350) .
    But an Editor normally don’t need too special instruction or I/O special function, heavy memory/search/move/display/fileIO.

    Maybe npp change new compiler/or optimize deeply method . or link new library.

    so older version is OK for me. I just report for someone as a hint.



  • I have the issue is that VS new compiler planed abandon XPSP2, not my AMDCPU .
    I create a new XPSP3 VM in virtaulbox, then run NPP6.9.2 , it runs pretty well.

    and I notice that VS2010 not support XPsp2, and NPP source code project file , had an M$ famous “X” , like docx, xlsx …
    VcXproj.
    X"b


Log in to reply