After Win 10 update, '&' doesn't display in C code

  • I let Win 10 update last night. This morning I started up NP++ and started working on a C file in my current project. It continued to compile okay, but then after a while I realized that none of the ‘&’ characters were displaying (as when taking the address of a variable), a blank space was showing in their place. I’d also had a problem running LibreOffice this morning, it was showing black box-chars in place of many of the menu characters. Changing and resetting the the language settings in LibreOffice cleared up its problem, but nothing I’ve tried is clearing up the ‘&’ issue in NP++, except to set the Language to “Normal” rather than ‘C’. I’m runinng 6.9.2. I’ve made ZERO changes for MONTHS to the NP++ settings prior to this problem.

    Anyone else encounter this? Or have any suggestions of what to try?

  • It is a known issue with the SourceCode Pro font.

  • @dail Thanks! I’d Googled for the problem, but didn’t find the stuff on GitHub. That fixed it!

Log in to reply