Notepad++ v7.2 released



  • I noticed a few issues with Notepad++ 7.1 and 7.2 (x64) on Windows.

    • When you silently deploy Notepad++ (using the ‘/s’ switch in Powershell), the installer can’t seem to tell if an older version is running, so the silent installer doesn’t close the old version or throw an exception that the process is running…
    • When you silently deploy a new version of Notepad++ while an older version is running, the Notepad++ installer updates the Registry and the Control Panel information to match the new software details but does not upgrade the program itself. This issue is present even after rebooting a machine. Essentially, the system has all the information of the new software, but the software itself doesn’t update.
    • The silent uninstaller leaves custom settings behind in the “C:\Program Files” folder rather than moving them elsewhere or removing them altogether.

    I appreciate the hard work on this tool and just wanted to give you a heads up about these issues in case anyone else is experiencing them.



  • Hello, thank you for the release.

    I’ve noticed that when choosing the options while installing the program, I can no longer choose the “Use the old, obsolete and monstrous icon” for the associated files as was available in previous installers (image).

    How can I change the icon? With all the pluses of Notepad++, the files icon is not one for me :)

    Thanks!



  • @Pablo-Santa-Ana
    You might want to see/read Notepad++ obsolete icon back and npp 7 - regression and follow the mentioned link to Github.



  • @Pablo-Santa-Ana
    Download the Resource Hacker freeware. …
    Locate the EXE file that you want to change. …
    Make a backup of the EXE file. …
    Right-click on the EXE file. …
    Click Action and select Replace Icon. …
    Open the new icon. …
    Click the Replace button. …
    Click File and select Save.



  • hi all!

    1. in status bar to the right we have current opened document’s encoding info (STATUS-BAR_ENC-NFO) ANSI/UTF-8-BOM/UTF-8/…

    my problem is
    lots of years I’ve problems with Encoding

    1. in settings - preferences - New Document (tab) - I selected Encoding’s point “UTF-8 with BOM”

    2. Ctrl + N. in this case new document will have document encoding “UTF-8” but here in STATUS-BAR_ENC-NFO value is “UTF-8 with BOM”.

    3. in this new doc I’ve wrote ONE russian CHAR - “Ы” (e.g. - without ")

    4. saved this new doc and realy it has “UTF-8” because 5 bytes

    +++++++
    SORRY FOR ENGLISH. here I uploaded video. it’s match more better look at this video
    N++ 7.2 - new doc lable is “UTF 8 with BOM” but realy “UTF-8”



  • more problems with indication encoding

    please look at other uploaded video

    N++ 7.2 Encoding indication problem



  • Are parallel installations officially supported? I ask because if I silently install notepad++ 32-bit on a system that already has notepad++ 64-bit installed, it will uninstall 64-bit in the process.

    If they are supported, then during silent installation the prompt “You’re installing 32-bit version. 64-bit version has been installed. Remove it?” should default as “No.” If parallel installations are not recommended or supported, then the current silent installation behavior is fine.

    The addition of another command line switch to choose the answer to that prompt would also work as well.



  • When using find/replace, it doesn’t do so completely. I needed to replace | (pipe) and " (double quote) with nothing and it ignored those which were separated by . (period). This is not a problem for my colleagues who ignored the upgrade pop-up.



  • @Joe-Dawes

    Are you sure you didn’t have Regular Expression mode turned on when you did your F&R? Your use of “pipe” and “period” make regex bells go off in my head? Maybe provide a specific example with real data where it screws up?



  • @Scott-Sumner
    I don’t know how to check if I’m in that mode. It’s not listed in my installed plugins. Here’s a data sample:
    |.|xxxx |#xxx |HENDERSON |NV|89074|0000|…|…|…|

    I installed an old version so this is no longer an issue for me.


Log in to reply