Notepad ++ slow at opening new post



  • When I want to make a new Notepad++ text file it takes about 10 seconds b4 I get a new empty page. However making a new document in any other format is as good as instantly (rtf, doc etc…). Opening an already existing notepad ++ document is a bit faster but still takes sometimes 5 seconds. What could be the reason ?



  • I repeat for those that think this is resource related, like slow PC etc… No, because every other txt app opens instantly (0,5 s). Developers of this software should know what is going on I guess.



  • The process of opening NPP from scratch (including opening my default text file) and then clicking the New File button, and then “waiting” for the empty file to appear took a total of 2-3 seconds on my machine (yes, that 2-3 seconds included having to move my mouse to the right monitor and find and click on the New button).

    You’ll have to describe a little better what exactly is going on, because your slowness doesn’t happen for everybody: what does the ? > Debug Info say for your installation, what OS are you on, what else is going on in the background of your computer, etc.



  • Thank you 4 your reply.

    The thing is that the time counting starts, average 8 seconds from the moment I double click on a new txt file. So the empty file has never been opened and it’s called new txt document.

    The mouse pointer gives this “waiting” sign.

    The OS is W7 with i7/ 2.6Ghz and 16GB RAM. Nothing running in the background. Opening any other kind of “new” txt document takes 0,5 sec. *.rtf file for example or a *.doc. file, because I only use notepad++ for typical txt files.
    Opening an already existing file takes about 5 sec’s, which is, given my configuration also way too long.

    Under the icons on the main page and the different menu items there is always a list of other recently opened or made txt files, horizontally spread out over the page, that have to be opened in the background I think. Can I avoid that so that there is no list at all ?

    Where can I find this debug info ?



  • Since there is zero information to analyze all that can be done is share some experience.

    I assume you are talking about creating new file from explorer right click. There is zero advantage of creating a “Notepad++ document”, it is zero-size anyway, you can create a Notepad text document and later “open with” Notepad++.

    How long does it take to Notepad++ to launch?

    Disable “Remember current session” under [preferences -> Backup] and see if slowness still happens.

    Remove all plugins and see if slowness still happens.

    Slowness in windows is often because of unexpected network accesses. “Network path references” that find there way into the registry. It is really hard to debug. Sysinternals tools like process monitor may help but these are for experts.
    Make sure that NP++ installation is completely local to your hard disk.



  • The launching of notepad takes 5 to 10 sec’s as I said. And that’s from the moment I double click on a notepad.txt file.

    Furthermore if it helps, I notice that while loading, the scrollbar on the right is nervously jumping up and down. Maybe you misunderstood but I mean that the page instantly opens (blank) but it is the content that lasts some 5 to 10 seconds to show, even for very small content.

    Sorry, but I can’t find that setting Disable : “Remember current session” under [preferences -> Backup] and see if slowness still happens. Under preferences in settings there seems to be no “backup” line.

    I still think that I should get rid of the list of all the other files on top of the page since I suspect they’re loading in the background.



  • I too have seen an increase in loading time since upgrading to 7.1 (I think it was).
    To open a .txt document of a few kb from a local drive now takes 6-7 seconds.
    I have tried disabling “Remember current session for next launch”, that didn’t seem change loading time.

    From ? -> Debug:
    Notepad++ v7.2.2 (32-bit)
    Build time : Nov 27 2016 - 16:31:07
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10
    Plugins : ComparePlugin.dll mimeTools.dll NppConverter.dll NppExport.dll NppFTP.dll NppTextFX.dll PluginManager.dll XMLTools.dll

    I captured opening a file with Process Monitor and saw one point where the total time (last ), jumped 4,7 seconds.
    The capture is a total of 1760 commands, but I didn’t want to copy it all in here for public exposure.

    02:32.7 notepad++.exe 2752 RegCloseKey HKCU\Software\Classes\Wow6432Node\CLSID{E31EA727-12ED-4702-820C-4B6445F28E1B}\Instance SUCCESS 0.0000126 00:01.3
    02:32.7 notepad++.exe 2752 IRP_MJ_CLEANUP C:\Windows\WinSxS\x86_microsoft.windows.common-controls_6595b64144ccf1df_6.0.14393.447_none_89c64d28dafea4b9 SUCCESS 0.0000111 00:01.3
    02:32.7 notepad++.exe 2752 IRP_MJ_CLOSE C:\Windows\WinSxS\x86_microsoft.windows.common-controls_6595b64144ccf1df_6.0.14393.447_none_89c64d28dafea4b9 SUCCESS 0.0000068 00:01.3
    02:32.7 notepad++.exe 2752 Thread Exit SUCCESS Thread ID: 11820, User Time: 0.0000000, Kernel Time: 0.0000000 0 00:01.3
    02:37.7 notepad++.exe 2752 IRP_MJ_CREATE C:\Utilities SUCCESS Desired Access: Execute/Traverse, Synchronize, Disposition: Open, Options: Directory, Synchronous IO Non-Alert, Attributes: n/a, ShareMode: Read, Write, AllocationSize: n/a, OpenResult: Opened 0.0000237 00:06.3
    02:37.7 notepad++.exe 2752 IRP_MJ_CLEANUP C:\Utilities SUCCESS 0.0000201 00:06.3
    02:37.7 notepad++.exe 2752 IRP_MJ_CLOSE C:\Utilities SUCCESS 0.0000043 00:06.3
    02:37.7 notepad++.exe 2752 IRP_MJ_CREATE C:\Program Files (x86)\Notepad++ SUCCESS Desired Access: Execute/Traverse, Synchronize, Disposition: Open, Options: Directory, Synchronous IO Non-Alert, Attributes: n/a, ShareMode: Read, Write, AllocationSize: n/a, OpenResult: Opened 0.0000205 00:06.3
    02:37.7 notepad++.exe 2752 IRP_MJ_CLEANUP C:\Utilities SUCCESS 0.0000056 00:06.3
    02:37.7 notepad++.exe 2752 IRP_MJ_CLOSE C:\Utilities SUCCESS 0.0000043 00:06.3



  • Thank you Jonas, the good thing is that I’m not the only one with this bug, so developers might consider looking into this. I mean every other txt file opens within 0.5 sec., but notepad files need 5 to 10 sec’s ? And this with a file of barely a few lines of text ? BTW why are my posts blocked (tried several times at different hours and days), when I use the built-in VPN of my Opera browser.



  • @Guido-DC
    there is no such thing as a notepad file as notepad++ doesn’t have its own format or protocol when saving a file.
    Your assumption that files in the background could be the cause can be correct but must not be.
    Check the following settings, as already suggested, and see if unchecking remember current session for next launch

    or checking Don’t check at launch time solves your problemn.

    Debug info

    @Jonas-Nyrup

    you didn’t provide an example that it took 4.7 seconds to load a file instead the example shows that it
    has been loaded instantly.

    Cheers
    Claudia



  • @Claudia-Frank
    Thanks for looking into this, I’ll try to give more info to show my problem.
    Please let me know, if there is any specific info you’d like.

    Debug info:
    Notepad++ v7.2.2 (32-bit)
    Build time : Nov 27 2016 - 16:31:07
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10
    Plugins : mimeTools.dll NppConverter.dll NppExport.dll PluginManager.dll

    Steps:

    • Complete uninstall of npp with removal of custom settings
    • Default install
    • Remove all 3rd party plugins
    • Unchecked “Remember current session for next launch”

    With a fresh npp I tried to open “C:\Program Files (x86)\Notepad++\change.log” which took the aforementioned ~5 seconds.
    I noticed that if I open the same file through most recent files from the File menu, it loads instantly.
    I also tried to uninstall v7.2.2 and installed v6.9.2 for which I don’t remember to have experienced any problems previously. I now see that is also has the problem, so the root cause might be somewhere else.

    Please see the dropbox folder below for a screen recording of the delay I’m experiencing and a complete dump from process monitor for both loading through File->Open (npp-open.csv) and through File->Recent Files (npp-latest.csv).
    https://www.dropbox.com/sh/sxvq4o99a1cjbjp/AAA5RAiyF3qL2rUs6W_ZmEhQa?dl=0



  • Some observations from the logs.

    The big delay is just before this line

    30:48.8
    IRP_MJ_CREATE
    C:\Program Files (x86)\Notepad++
    Desired Access: Execute/Traverse, Synchronize, Disposition: Open, Options: Directory, Synchronous IO Non-Alert, Attributes: n/a, ShareMode: Read, Write, AllocationSize: n/a, OpenResult: Opened 7.79E-05 00:13.7

    Note that this access the directory not the file.

    For the “latest” CSV there is no such access. The file is accessed directly.

    33:44.7
    IRP_MJ_CREATE
    C:\Program Files (x86)\Notepad++\change.log
    Desired Access: Read Attributes, Disposition: Open, Options: Open Reparse Point, Attributes: n/a, ShareMode: Read, Write, Delete, AllocationSize: n/a, OpenResult: Opened 1.86E-05 00:06.7

    A wild guess is that this may be related to the call to SetCurrentDirectory.
    Perhaps some other software (anti virus?) monitors processes and get excited because of the directory change.
    The log is filtered for Notepad++. You should observe the unfiltered log if there is any suspicious other activity between the 2 lines with the big delay.

    If you can build Notepad++ and test it on a system that exhibit the problem you may comment out this call to check the speculation.



  • I think I’ve found the cause…
    While disabling various programs I found out that disconnecting from the internet helped.
    I looked at the complete dump from process monitor, and found an internal ip from my home network together with some tcp/udp traffic.
    By removing a smb share pointing to the home ip (why I don’t have access to at my current location) seems to have solved the problem.

    Now I just wonder why npp (or some api npp uses) tries to connect to an smb share when opening a local file.



  • Try to lookup the registry to references to the SMB share. Perhaps some icon or whatever is being taken from there.



  • @ Claudia Frank

    If I apply the things described in your last post, I get a constant loop of queries to save files. Also I now see that I haven’t the latest version of Notepad. I’ll get the latest version and get back here.



  • @Guido-DC

    that is correct, because if you disable remember current session…
    session snapshot and backup functionality gets disabled as well.

    The idea behind this was to ensure that a hidden network file
    gets cleared from history and/or tab because this could explain
    the slowness.

    Cheers
    Claudia



  • So what do you suggest Claudia F. because I have some 12,500 txt files spread over different folders. Am I going to resave all those files ? I see that they are now doubled on my desktop for the one’s that I already resaved on my desktop.



  • @Guido-DC

    do you say you have 12500 files open in notepad++??
    How is this even possible to handle.
    It affects only the files which are currently open in npp, not every .txt file on the disk.

    Cheers
    Claudia



  • Thank you Claudia Frank but this is getting more confusing every day. No normally I have only 1 or max 2 *.txt files that are open.

    All my files that have the txt extension I let them open with Notepad ++ (I know they can be opened with other programs). I just checked how many files that have the txt extension and so eventually will open with Notepad ++ if I doubleclick on them. But there is this row on top of the window of that opens when I doubleclick on a txt file, is that what you mean ? I don’t use that list.

    If I do the modifications you suggested above I always gets this question if I want to save some file. And what Is it that I get these question ? That’s what confuses me and why and can’t finish your suggestions in the menu’s.

    Grts,



  • @Guido-DC

    let’s summarize to see if we have the same understanding.

    You use the latest npp version without any additional plugins, correct?

    You do have open the windows explorer and double click on a file with a txt extension.
    Notepad++ starts instantly but does not show the content of the file instantly,
    instead it takes 5 seconds before the content is shown.
    This does not happen if you open files with other extensions like rtf and doc
    (side note, can you actually read these documents clearly, because normally they are formatted?)
    but using the the same method to open ( by using double click in windows explorer), correct?

    In addition, (the point I don’t understand at all)
    if you create a new txt file it takes 10 seconds before you even see the empty document and, again, this does not happen if it is a rtf or doc document.
    How does this work? You cannot open a new txt file you only can open a new
    file and only after saving it for the first time it becomes a txt, or whatever you choose, file. What do you exactly mean by this?

    I’ve posted the image about the debug-info, can you post the info, please.

    As said, when you disable the mentioned settings you need to choose a name
    for the file to save to when you close npp otherwise the file is gone. This is the
    normal way when saving files. So what did you do in the meantime - did you reset
    the settings or do you still use npps automatic saving feature?

    Cheers
    Claudia


Log in to reply