Show Verticle Edge in wrong position



  • Using N++ v6.7.8
    I used style configurator global styles global override font from default to Lucida Sans and set font size to 12.
    I checked option to enable global font, and also enable global font size.
    Then I went into Preferences>Editing and selected Show vertical edge, line mode and selected number of columns to 72.
    I am finding the vertical line is not aware of the change to the fonts. The line is positioned based on default font.
    Is this a known issue? or have I overlooked something?



  • Through various iterations I have narrowed down the issue to “enable global font”
    When unchecked the vertical line gets positioned in correct column. Otherwise it is offset in wrong column.
    Is there a procedure to report this defect to someone?



  • Hello Tbimbra,

    I’ve never noticed this fact, because I usually work with the default Courrier New font

    First of all, just have a look to my old post, on SourceForce forums, about the differences between the monospaced fonts and the other fonts, at the address below :

    https://sourceforge.net/p/notepad-plus/discussion/331753/thread/5c8c669b/#2143

    Now, let’s create, in a new tab of N++, a small text file, with the eight lines, below :

    iiiii
    IIIII
    wwwww
    WWWWW
    123456789012345678901234567890123456789012345678901234567890123456789012
             1         2         3         4         5         6         7  
                                                                            
    ------------------------------------------------------------------------------------------
    

    Notice that the seventh line contains exactly 72 spaces (\x20)

    Then, supposing that you previously choose 72 columns, in vertical edge settings, of the Settings - Preferences - Editing panel :

    • First, select these 72 spaces, at the seventh line of the new tab

    • Open the Style Configurator ( Settings - Style Configurator… )

    • Choose the language Global Styles

    • Choose the style Default style

    • Select, on the right, the Font name field

    • Use the Up and Down arrow keys, to change the current font

    => You’ll easily notice that :

    • The vertical edge line is between columns 72 and 73, ONLY IF the current font is a monospaced font

    • The physical width of the selection change, for all fonts, monospaced font or not

    So, we can deduce that, in vertical edge settings, the number represents, rather, the number of spaces of the current font than the number of physical columns.

    In addition, don’t forget that the physical width of a space is generally smaller than letters or digits, for NON monospaced fonts !

    Here are two pictures with the Courrier New and the Lucida fonts

    With Courrier New

    With Lucida Sans
    Best Regards,

    guy038

    P.S. :

    BTW, could someone be so kind to tell me how to attach images, stored in my computer, to a NodeBB post ? As you can see, the two links With Courrier New and With Lucida Sans don’t work at all, infortunately :-(((

    I currently use Firefox v38.0.5, on a Win XP SP3 computer


Log in to reply