Notepad++ v7.3.1

  • Do you know…
    MD5 of “Notepad++ v7.3.1 is available on” is

  • I just wanted to let you know, that the “Pending Actions bug” now seems to be fixed. Maybe because that I have deleted the Notepad++ Folder under %USERPROFILE%\AppData\Roaming\Notepad++ if someone else still has that behavior.

    I would also mension that the Uninstaller should also delete that Folder as someone choose to not Keep custom Settings. But ist just a Suggestion.

    Thanks donho if it was something you changed in 7.3.1 in compared to 7.3.

  • @donho can you package the latest release of plugin manager (v1.4.3) ?

  • It’s a bit distracting that 7.3 Hungarian (and possibly others too) translation update was still not included in 7.3.1 release! There was a PR created for 7.3 with a lot items updated. Even if some few items from 7.3.1 new feature was not yet done, it should be included ! Thanks! György

  • Settings/Preferences/Default Directory: Use new style save dialog

    Reverts to checked when program restarted

    This was OK in version 7.3.0

  • In 7.3.0 was possible to save the session even with unsaved files. It was useful because it allowed me to take some quick notes without the need to add a new file each time, but now looks like that it has been removed.

  • @Alan-Chronos

    Did you check if settings are still set.
    Remember current session …
    enable session snapshot …


  • @Claudia-Frank Uh, it worked perfectly! Thank you very much!

  • @Sam-Sung said:

    Settings/Preferences/Default Directory: Use new style save dialog

    Reverts to checked when program restarted

    This was OK in version 7.3.0

    Having the same issue. :( Should I just use 7.3.0 instead? What does the new version offer any ways?

  • @Scott-Shao

    Every new version shows the changes whens started first.
    The file is located in the installation directory and is called change.log.

    Concerning your issue - you can open an issue here.


  • I have problem with Windows 10 (64). When you run the NP ++ (x86 version) as an administrator, drag-drop file in window, does not work.

  • @Artur-Hareson

    I assume that the access rights from source to destination are different.
    E.g. when starting explorer with a normal user account and you want to drag
    something into an application with evaluated rights than it get rejected
    as otherwise you would cancel the whole permission concept.


  • Video

    Some files are automatically defined as Mackintosh instead of the Windows-1251.
    The problem occurs only when using the Cyrillic alphabet.

  • @Artur-Hareson

    I’m a little bit confused by the video and the new text.
    Video shows the previous question about privileges
    whereas the new text indicates an encoding issue.
    So I assume you do have two different issue.

    Concerning the video let me try to explain what happens (or what doesn’t happen)
    With introduction of UAC Microsoft changed their security concept and allowed
    that different process with different privilege levels run on the desktop. This means,
    that if you logon as a normal user explorer.exe gets started with the security token
    of this normal user. When you start npp as administrator this process gets elevated rights,
    meaning different security token.
    The desktop where your file is located belongs to the explorer.exe process - if you drag this file
    (as normal user) into npp (which run elevated) the security tokens don’t match and therefore it gets
    rejected. You can only open the file if you use the file dialog menu from npp or when starting another
    instance from explorer as administrator and dragging the file from it.
    If you want to get more details about how exactly this works I would recommend searching the web for

    • User account control (UAC)
    • Mandatory Integrity Control (MIC) and
    • User Interface Privilege Isolation (UIPI)

    About the encoding - yes this can happen - there is no guarantee that npp finds the “correct” codec.
    I tried to explain this already here.


  • @Claudia-Frank
    Thanks for clarifying.

    About Mackintosh
    I just turn off ‘auto encoding character’ option.

  • File with german umlaute not working
    I created a text file with the Windows Notepad which contains german umlaute (e.g. ä ö ü=0x4e 0xf6 0xfc) and saved it with ANSI encoding. When I open this file with Notepad++ v7.3.1 the file encoding is shown as Windows-1255 and the umlaute are rubbish.

    The same even happens if I create a new file with ANSI encoding in Notepad++ and enter some umlaute.
    When I save and reload from disk, the encoding changes to Windows-1255 and the umlaute are rubbish.

  • Try disabling “Autodetect character encoding” in Preferences->MISC. It sometimes produces odd results.

  • Strange behavior when copying the search results.
    Context menu and Ctrl + C .
    Problem of copying (video)

  • @Artur-Hareson This is the expected behavior.

Log in to reply