Scripts from Notepad++ do not run in Python/Jupyter 3.5(already read prior help discussions)

  • @scott-grossberg

    depends what exactly is used in nppexec dialog.
    Normally something like this

    cd C:\Users\myname\Anaconda3\
    python "$FULL_CURRENT_PATH”


  • I greatly appreciate all of your help and patience but still cannot get it to work.


  • @scott-grossberg

    Scott, you need to be more descriptive what you get
    and/or what isn’t working.
    Maybe include a Screenshot (upload to e.g imgur) and use the syntax like


    to embed it in a post.


  • In the run box in notepad++ I have placed the following commands:

    1. cd C:\Users\myname\Anaconda3\python "$FULL_CURRENT_PATH”
    2. cmd /K C:\Users\myname\Anaconda3\python.exe -i “$(FULL_CURRENT_PATH)”
    3. cmd /K C:\Users\myname\Anaconda3\python "$FULL_CURRENT_PATH”
    4. cmd /K C:\Users\myname\Anaconda3\python "$(FULL_CURRENT_PATH)”

    On all 4 of these tries python opened up with a message stating “the system cannot find the path specified.” I would greatly appreciate it if you have any additional suggestions on how to get this to work.


  • @scott-grossberg

    Sorry, you cannot get the same error message on all 4 runs.
    The message “the system CANNOT find the path specified.” is descriptive isn’t it.

    I start thinking you are trolling.


  • Your right. 1. from above doesn’t give me the same output as the others but just shows “run…” in the dialogue box. It was sloppy of me to post that.

    I am a novice at programming, not a troll. I am trying to learn programming. I can understand if you run out of patience trying to help me with this as the amount of times that I have tried to fix this is also trying my patience. I did not plan on spending since yesterday trying to get notepad++ to communicate with python but rather to learn how to use python. Can you suggest any basic resources that I can look at to learn how to fix this?

    Thanks for all of your help


  • @scott-grossberg

    Scott, we can get this work in maybe 2-3 posts if you would describe step by step what you do
    instead of writing “I did what you do”, because any slight modification could break it.

    What do you want to do?
    I assume you want to run python with the current script you have open with notepad++.
    What do you use to execute the script?
    I assume you use the Run dialog from the run menu and not the nppexec plugin.
    I would suggest you use the nppexec plugin.

    • Find out where your python.exe is located. We need to know the directory.

    • Press F6 to open the nppexec dialog

    • put the the following into the dialog opened by pressing F6

      python “$(FULL_CURRENT_PATH)”

    • Press ok

    A console opens and either shows the expected result or an error.
    If an error appears copy it and post it then we see what is going on.
    Do not interpret it - copy the real output.
    If there is sensitive data in it - replace it with question marks - but only that part.


  • @scott-grossberg as you are a beginner, I suggest you to remove Anaconda and install the official python

  • Here is my solution.

    1. uninstall anaconda

    2. install python 3.6 in c:\python36

    3. do an “hello world” script to test
      4 append to the end of script os.system(“pause”) in order to pause your script and be able to read the result

      import os
      print(“Hello World”)

    5 run your script with “notepad++ run” command

    C:\python36\python.exe "$(FULL_CURRENT_PATH)"

    Here is what i got

  • @scott-grossberg any news ?

  • I followed your suggestion of removing anaconda and installing python directly and I can run notepad++ scripts in python (I tested this with the hello world program). Unfortunately the class that I am using this for has extra formatting in the scripts since they were saved as a python notebook. Therefore I get an error message when I try to run these scripts with notepad++ with my current set up. This is the error message:

    C:\Anaconda\python.exe “C:\Users\scott grossberg\Downloads\controlflow_demo_test”
    Process started >>>
    Traceback (most recent call last):
    File “C:\Users\scott grossberg\Downloads\controlflow_demo_test”, line 21, in <module>
    “execution_count”: null,
    NameError: name ‘null’ is not defined
    <<< Process finished. (Exit code 1)

    I placed the command below into the run box (I saved Anaconda to C:\Anaconda) as well as within the box when I hit the f6 key and it successfully runs the hello world program above in python and the lower console box respectively:

    C:\Anaconda\python.exe “$(FULL_CURRENT_PATH)”

    Do you know how I can get the notepad++ script to run in the jupyter notebook?

    Thank you very much for the help.


    Thank you very much for the help.================ READY ================

  • I should have mentioned in the above post that after I successfully installed and tested the notepad++ and the python 3.6 integration I removed python 3.6 and re-installed Anaconda. I did this to try to get notepad++ to run the scripts in the python notebook rather than directly on python.

    I greatly appreciate all of your help.



  • Sorry I don’t know Jupiter and I didn’t understood your issue.

  • I greatly appreciate your help as you showed me how to integrate notepad++ and python.

    Does anyone know how to run notepad++ scripts in python/ jupyter?

  • @scott-grossberg

    Jupyter as the successor of IPython?
    If so, isn’t it just a better python shell??
    So copy and paste should work - but I assume you want to do something different.


  • You should keep original Python then install Jupyter with ‘pip installer’ that is provided with python

Log in to reply