Change in word boundary behavior?



  • I updated to 7.3.3 today, and since doing so my word boundary behavior seems all wrong. When I double click on a word, it selects everything between 2 delimiters, but the list of delimiters no longer seems to include a blank space. If I hit ctrl-arrow, it selects, not to the next blank space, but to the next other delimiter (hyphen, new line, punctuation, etc.)

    I’ve not messed with any of the Scintilla settings to the best of my knowledge and just want it to work like 7.3.2 did out of the box.



  • @Kevin-Knox

    Settings->Preferences->Delimiter replace the open and close chars with a space.

    Cheers
    Claudia



  • Thank you, Claudia.

    Last week, prior to posting, I already did what you recommend here, and it had no impact, so I went back to the default characters. Today, after a weekend and a restart, the problem no longer exists. Apparently, something was cleared in the restart and I should have tried the Windows fix-all before asking here. Sorry and thanks.



  • @Kevin-Knox I have the same problem as you mentioned.
    @Claudia-Frank Your fix didn’t fixed it. Delimiters are used for Ctrl+Click selection. The problem is on Smart Highlighting.
    If I start Npp with SH (Smart Highlighting) off, then activated it, there is no problem.
    If I start Npp with SH On, SH doesn’t work correctly : it doesn’t respect word boundaries.

    Do you have the same trouble as me ?



  • @cmeriaux

    from my understanding, OP asked for the selection by double clicking maybe I’m wrong
    but it looks like this was the problematic area.

    I don’t have your reported issue. Started npp with this settings.

    Can you try what he OP did? Reset the delimiter ?

    Cheers
    Claudia



  • Reseting the delimieter didn’t fix the problem.
    However unchecking “highlighting/Match Case” like in your configuration fixed the problem.

    I can reproduce the problem but there is a tricky combination of parameters that I didn’t understood very well :

    • having “highlighting/Match Case” checked
    • having “regular expression” activated in search panel
    • starting Npp without anything selected

    I’ll try to understand and do a deep dive in the code if necessary
    Thanks for the help
    Cheers



  • Interesting, this just happened to me as well. Notepad++ was running as administrator when it happened (probably not relevant); and double click and ctrl+arrow had the different behavior as described above. I don’t remember this happening in the previous versions. The problem didn’t persist after I restarted Notepad++, and now I (fortunately) cannot reproduce it, I hope it stays that way.



  • Just FYI I just recently ran into this as well and haven’t been able to reproduce it. My Notepad++ is very non-standard…however I haven’t messed with the built in highlighting or the custom word character list.



  • I was having issues around double clicking “words” and it was just highlighting the whole line. Also, it was marking the whole line as a smart highlight block. The above recommendations didn’t resolve the issue for me.

    I “fixed” it by opening the np++ directory and renaming my config.xml to config.backup.xml. I then copied my config.model.xml and renamed that to config.xml. Once I started np++ again highlighting and selection worked as expected.

    The down side is my “fix” reset all my settings, which I then went back and manually re-configured. I’m not recommending this as a solution, but putting it out there so it is known that there is something in the settings that changed in version 7.3.3 (for me at least).



  • I can fix it using beach-dix’s method, but I do the followings to save my settings:

    1. Close NP++
    2. Go to NP++ directory
    3. Rename config.xml to config_backup.xml
    4. Copy config.model.xml to config.xml
    5. Start NP++
    6. Check if it’s fixed.
    7. Close NP++
    8. Delete config.xml
    9. Rename config_backup.xml to config.xml
    10. Start NP++

    So the config file isn’t changed in the end, but when I started NP++ with a new config.xml something got reset, then I could copy back my configs.


Log in to reply