Disable "are you sure you want to replace all occurences in" message



  • Hi there,
    I work with a lot of .xml files and need to change data on them.
    For that, I’m using find in files Notepad function, but each time I need to check “are you sure you want to replace all occurences in …” which is very annoying when you have 100 files to do…
    Is it possible to disable this safety message ?
    Maybe saving my data change in a macro, and changing some parameters ?
    Best Regards,
    GR



  • @Guide-Rencontre

    Is it possible to disable this safety message ?

    Afaik, no.

    which is very annoying when you have 100 files to do…

    But you only have to acknowledge it once for all files, haven’t you?

    Cheers
    Claudia



  • Ouch ! That’s a bad news…

    I have something like 20 modifications to do for each files…
    So even if I save it in a macro, I have 20 times…

    Stranges facts :

    • if I save in a macro one action of find in files, the message doesn’t show up
    • if I save find in files using regex, it works only for the current file open and not for other…


  • @Guide-Rencontre

    wait, so you are saying you record a macro and you were able to record the click to confirm?
    I tried that some time ago (maybe some long time ago) and it wasn’t working.

    I will give it a try.

    Cheers
    Claudia



  • @Guide-Rencontre

    Strange - I don’t have that behavior using npp 7.3.2.
    I’m still getting the dialog to confirm the replace action, regardless
    if using normal or regex searches and when using regex searches all files get replaced.

    Can you provide your debug-info (under ? menu) together with a sample
    text and sample find/replace?

    Cheers
    Claudia



  • @Claudia-Frank You’re right, my mistake…
    If anyone has a solution to disable this safety message…
    Cheers ;)