Can't initialize plugins directory

  • I removed npp and then tried to reinstall it the 32 bit or 64 bit version 7.5.1. I get an error: Can’t initialize plug-ins directory. Please try again later.

    This is a computer where I have limited rights so I am no administrator and cannot run safe mode. Is there anything I can do or any other way to install npp again?

    Thank you,

  • I did a lot of Google search and tried removing Temp directory under AppData/Local but to no avail.

    1. Grab the zipfile (portable) of either 32b or 64, instead of the installer, from the download page. Unzip it into a directory where you have full access.

    2. Manaully create your own shortcut to that version, which you should be able to pin or paste wherever your old NPP shortcut was.

    This should run with the unzip-directory as your config-storage location. If you want it to use %AppData%\Notepad++ (c:\users\xxxxxx\AppData\Roaming\Notepad++ or similar) for your config/settings, then

    1. Delete the doLocalConf.xml from the unzipped directory (with that file, it will use the unzip-directory for your settings; without the file, it should use AppData)

    I believe that should work.

  • This works but I am trying to get it as default when I use Open with but it does not appear to be working. Also miss the right click context menu. I’ll see if I can get any of those.

    Thank you very much!

  • If you use the portable (zip-file) version, it doesn’t register itself with Windows, so Windows doesn’t automatically list it for choosing with “Open With…” or similar. However, under most versions of Windows, you can select “browse” in the “Open With” dialog, and go find notepad++.exe yourself.

    Or, if you are an advanced user, you can edit your association(s) in your registry. (For example, in mine, HKCR\.txt\ uses the (Default) string value with data txtfile, and HKCR\txtfile\Shell\open\command\ uses the (Default) string value of my full path for notepad++.exe. If you don’t understand any of those terms in these parentheses, you probably should be wary of editing your registry yourself.)

Log in to reply